Get the pid info from the socket fd
[platform/framework/native/channel-service.git] / packaging / osp-channel-service.spec
1 Name:           osp-channel-service
2 Summary:        osp channel service
3 Version:        1.2.2.0
4 Release:        1
5 Group:          System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  pkgconfig(bundle)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(chromium)
14 BuildRequires:  pkgconfig(libsoup-2.4)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(libsmack)
17 BuildRequires:  pkgconfig(message-port)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20 BuildRequires:  pkgconfig(capi-appfw-package-manager)
21 BuildRequires:  osp-appfw-internal-devel
22 BuildRequires:  hash-signer
23
24 # runtime requires
25 Requires: osp-appfw 
26 Requires: osp-installer
27 Requires: osp-app-service
28
29 Requires(post): coreutils
30
31 %description
32 osp channel service
33
34 %prep
35 %setup -q
36
37 %build 
38 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
39 %ifarch %{ix86}
40 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
41 %else
42 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
43 %endif
44
45 # Call make instruction with smp support
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 mkdir -p %{buildroot}/usr/share/license
51 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
52
53 %make_install
54 %define tizen_sign 1
55 %define tizen_sign_base /usr/apps/cp7ipabg4k
56 %define tizen_sign_level public
57 %define tizen_author_sign 1
58 %define tizen_dist_sign 1
59
60 %post
61 /bin/rm -fr /opt/apps/cp7ipabg4k
62 /usr/etc/package-manager/backend/tpk -i /usr/apps/cp7ipabg4k
63
64 #%postun -p /sbin/ldconfig
65
66 %files
67 %manifest osp-channel-service.manifest
68 /usr/share/license/%{name}
69 /usr/apps/*