Update version to 2.2
[framework/osp/channel-service.git] / packaging / osp-channel-service.spec
1 Name:           osp-channel-service
2 Summary:        osp channel service
3 Version:        1.2.2.0
4 Release:        1
5 Group:          TO_BE/FILLED_IN
6 License:    Apache License, Version 2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  pkgconfig(bundle)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(chromium)
14 BuildRequires:  pkgconfig(libsoup-2.4)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(libsmack)
17 BuildRequires:  pkgconfig(message-port)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20 BuildRequires:  pkgconfig(capi-appfw-package-manager)
21 BuildRequires:  osp-appfw-internal-devel
22
23 # runtime requires
24 Requires: osp-appfw 
25 Requires: osp-installer
26 Requires: osp-app-service
27
28 Requires(post): coreutils
29
30 %description
31 osp channel service
32
33 %prep
34 %setup -q
35
36 %build 
37 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
38 %ifarch %{ix86}
39 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
40 %else
41 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
42 %endif
43
44 # Call make instruction with smp support
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 mkdir -p %{buildroot}/usr/share/license
50 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
51
52 %make_install
53
54 %post
55
56 /bin/rm -fr /opt/apps/cp7ipabg4k
57
58 /usr/etc/package-manager/backend/tpk -i /usr/apps/cp7ipabg4k
59
60 #%postun -p /sbin/ldconfig
61
62 %files
63 %manifest osp-channel-service.manifest
64 /usr/share/license/%{name}
65 /usr/apps/*