316eaa1871946748ca6d762f813df207ae864bf7
[platform/framework/native/appwidget-service.git] / packaging / osp-appwidget-service.spec
1 Name: osp-appwidget-service
2 Summary:        osp appwidget service
3 Version:        1.2.2.0
4 Release:        2
5 Group:          System/Libraries
6 License:        Apache License, Version 2.0 
7 Source0:        %{name}-%{version}.tar.gz
8 Source1:        %{name}.rule
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(chromium)
11 BuildRequires:  pkgconfig(capi-appfw-application)
12 BuildRequires:  pkgconfig(aul)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(provider)
15 BuildRequires:  pkgconfig(osp-appfw)
16 BuildRequires:  pkgconfig(osp-uifw)
17 BuildRequires:  pkgconfig(osp-image)
18 BuildRequires:  pkgconfig(osp-shell)
19 BuildRequires:  osp-shell-internal-devel
20 BuildRequires:  osp-appfw-internal-devel
21
22 # runtime requires
23 Requires: chromium
24 Requires: osp-appfw
25 Requires: osp-shell
26 Requires: data-provider-master
27  
28 %description
29 osp appwidget service
30
31 %prep
32 %setup -q
33
34 %build 
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %ifarch %{ix86}
37 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38 %else
39 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
40 %endif
41
42 # Call make instruction with smp support
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 mkdir -p %{buildroot}/usr/share/license
48 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
49
50 %make_install
51 PKG_ID=gi2qxenosh
52 %define tizen_sign 1
53 %define tizen_sign_base /usr/apps/${PKG_ID}
54 %define tizen_sign_level platform
55 %define tizen_author_sign 1
56 %define tizen_dist_sign 1
57 mkdir -p %{buildroot}/opt/etc/smack/accesses.d
58 install -m 644 %{SOURCE1} %{buildroot}/opt/etc/smack/accesses.d/osp-appwidget-service.rule
59
60
61 %post
62
63 /bin/rm -fr /opt/apps/gi2qxenosh
64
65 /usr/etc/package-manager/backend/tpk -i /usr/apps/gi2qxenosh
66 cp -f %{_libdir}/osp/osp-system-service-loader /usr/apps/gi2qxenosh/bin/%{name}
67
68 #%postun -p /sbin/ldconfig
69
70 %files
71 %manifest %{name}.manifest
72 /usr/share/license/%{name}
73 /usr/apps/*
74 /opt/etc/smack/accesses.d/osp-appwidget-service.rule
75 #/opt/apps/gi2qxenosh/*
76
77