apply FSL(Flora Software License)
[apps/native/volume-app.git] / packaging / org.tizen.volume.spec
1 Name:       org.tizen.volume
2 Summary:    volume
3 Version:        0.2.0
4 Release:    3
5 Group:      Applications
6 License:    Flora Software License
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(appcore-efl)
9 BuildRequires: pkgconfig(bundle)
10 BuildRequires: pkgconfig(ecore)
11 BuildRequires: pkgconfig(ecore-input)
12 BuildRequires: pkgconfig(ecore-x)
13 BuildRequires: pkgconfig(edje)
14 BuildRequires: pkgconfig(evas)
15 BuildRequires: pkgconfig(glib-2.0)
16 BuildRequires: pkgconfig(mm-sound)
17 BuildRequires: pkgconfig(svi)
18 BuildRequires: pkgconfig(syspopup)
19 BuildRequires: pkgconfig(utilX)
20 BuildRequires: pkgconfig(vconf)
21
22 BuildRequires:  cmake
23 BuildRequires:  edje-tools
24 BuildRequires:  embryo-bin
25 BuildRequires:  gettext-tools
26
27 %description
28 Volume App
29
30
31 %prep
32 %setup -q -n %{name}-%{version}
33
34
35 %build
36 RPM_OPT=`echo $CFLAGS|sed -n 's/-Wp,-D_FORTIFY_SOURCE=2//'`
37 export CFLAGS=$RPM_OPT
38 cmake  -DCMAKE_INSTALL_PREFIX="/opt/apps/org.tizen.volume"
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %find_lang volume
46
47 %files -f volume.lang
48 /opt/apps/org.tizen.volume/bin/*
49 /opt/apps/org.tizen.volume/res/*
50 /opt/share/applications/*