Remove smack rule
[apps/native/volume-app.git] / packaging / org.tizen.volume.spec
1 %define _project_name volume
2 %define _package_name org.tizen.%{_project_name}
3 %if "%{?tizen_profile_name}" == "wearable"
4 ExcludeArch: %{arm} %ix86 x86_64
5 %endif
6
7 %if "%{?tizen_profile_name}" == "tv"
8 ExcludeArch: %{arm} %ix86 x86_64
9 %endif
10
11 Name:   org.tizen.volume
12 Summary:        Volume application (EFL)
13 Version:        0.1.148
14 Release:        1
15 Group:  TO_BE/FILLED_IN
16 License:        Apache
17 Source0:        %{name}-%{version}.tar.gz
18 BuildRequires:  pkgconfig(capi-appfw-application)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20 BuildRequires:  pkgconfig(appcore-efl)
21 BuildRequires:  pkgconfig(elementary)
22 #BuildRequires:  pkgconfig(utilX)
23 BuildRequires:  pkgconfig(capi-media-sound-manager)
24 BuildRequires:  pkgconfig(syspopup)
25 BuildRequires:  pkgconfig(dlog)
26 BuildRequires:  pkgconfig(notification)
27 BuildRequires:  pkgconfig(feedback)
28 BuildRequires:  pkgconfig(syspopup-caller)
29 #BuildRequires:  pkgconfig(x11)
30 #BuildRequires:  pkgconfig(xcomposite)
31 #BuildRequires:  pkgconfig(xext)
32 #BuildRequires:  pkgconfig(xi)
33 BuildRequires:  pkgconfig(capi-network-bluetooth)
34
35 BuildRequires:  cmake
36 BuildRequires:  edje-bin
37 BuildRequires:  embryo-bin
38 BuildRequires:  gettext-devel
39 BuildRequires:  hash-signer
40
41 %description
42 volume.
43
44 %prep
45 %setup -q
46
47 %define PREFIX /usr/apps/%{_package_name}
48
49 %build
50 export CFLAGS+=" -fPIE"
51 export CXXFLAGS+=" -fPIE"
52 export LDFLAGS+=" -pie"
53
54 %if 0%{?sec_build_binary_debug_enable}
55 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
56 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
57 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
58 %endif
59
60 %if 0%{?sec_build_binary_sdk}
61 export CFLAGS+=" -DFEATURE_SDK"
62 export CXXFLAGS+=" -DFEATURE_SDK"
63 export FFLAGS+=" -DFEATURE_SDK"
64
65 echo EMULATOR BUILD
66 %endif
67
68 RPM_OPT=`echo $CFLAGS|sed 's/-Wp,-D_FORTIFY_SOURCE=2//'`
69 export CFLAGS=$RPM_OPT
70 cmake  -DCMAKE_INSTALL_PREFIX="%{PREFIX}"
71 make %{?jobs:-j%jobs}
72
73 %install
74 rm -rf %{buildroot}
75 %make_install
76 mkdir -p %{buildroot}/usr/share/license
77 cp LICENSE %{buildroot}/usr/share/license/%{_package_name}
78 %define tizen_sign 1
79 %define tizen_sign_base /usr/apps/%{_package_name}
80 %define tizen_sign_level public
81 %define tizen_author_sign 1
82 %define tizen_dist_sign 1
83
84 %files
85 %manifest %{_package_name}.manifest
86 %defattr(-,root,root,-)
87 %{PREFIX}/*
88 #%{PREFIX}/bin/*
89 #%{PREFIX}/res/*
90 /usr/share/packages/%{_package_name}.xml
91 /usr/share/icons/default/small/%{_package_name}.png
92 /usr/share/license/%{_package_name}