tizen 2.3.1 release
[apps/home/volume-app.git] / packaging / org.tizen.volume.spec
1 %define _project_name volume
2 %define _package_name org.tizen.%{_project_name}
3 %if "%{?tizen_profile_name}" == "wearable"
4 ExcludeArch: %{arm} %ix86 x86_64
5 %endif
6
7 Name:   org.tizen.volume
8 Summary:        Volume application (EFL)
9 Version:        0.1.148
10 Release:        1
11 Group:  TO_BE/FILLED_IN
12 License:        Apache-2.0
13 Source0:        %{name}-%{version}.tar.gz
14 BuildRequires:  pkgconfig(capi-appfw-application)
15 BuildRequires:  pkgconfig(capi-appfw-app-manager)
16 BuildRequires:  pkgconfig(appcore-efl)
17 BuildRequires:  pkgconfig(elementary)
18 BuildRequires:  pkgconfig(utilX)
19 BuildRequires:  pkgconfig(capi-media-sound-manager)
20 BuildRequires:  pkgconfig(syspopup)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(ui-gadget-1)
23 BuildRequires:  pkgconfig(notification)
24 BuildRequires:  pkgconfig(feedback)
25 BuildRequires:  pkgconfig(syspopup-caller)
26 BuildRequires:  pkgconfig(x11)
27 BuildRequires:  pkgconfig(xcomposite)
28 BuildRequires:  pkgconfig(xext)
29 BuildRequires:  pkgconfig(xi)
30 BuildRequires:  pkgconfig(efl-assist)
31
32 BuildRequires:  cmake
33 BuildRequires:  edje-bin
34 BuildRequires:  embryo-bin
35 BuildRequires:  gettext-devel
36 BuildRequires:  hash-signer
37
38 %description
39 volume.
40
41 %prep
42 %setup -q
43
44 %define PREFIX /usr/apps/%{_package_name}
45
46 %build
47 export CFLAGS+=" -fPIE"
48 export CXXFLAGS+=" -fPIE"
49 export LDFLAGS+=" -pie"
50
51 %if 0%{?sec_build_binary_debug_enable}
52 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
53 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
54 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
55 %endif
56
57 %if 0%{?sec_build_binary_sdk}
58 export CFLAGS+=" -DFEATURE_SDK"
59 export CXXFLAGS+=" -DFEATURE_SDK"
60 export FFLAGS+=" -DFEATURE_SDK"
61
62 echo EMULATOR BUILD
63 %endif
64
65 RPM_OPT=`echo $CFLAGS|sed 's/-Wp,-D_FORTIFY_SOURCE=2//'`
66 export CFLAGS=$RPM_OPT
67 cmake  -DCMAKE_INSTALL_PREFIX="%{PREFIX}"
68 make %{?jobs:-j%jobs}
69
70 %install
71 rm -rf %{buildroot}
72 %make_install
73 mkdir -p %{buildroot}/usr/share/license
74 cp LICENSE %{buildroot}/usr/share/license/%{_package_name}
75 %define tizen_sign 1
76 %define tizen_sign_base /usr/apps/%{_package_name}
77 %define tizen_sign_level public
78 %define tizen_author_sign 1
79 %define tizen_dist_sign 1
80
81 %files
82 %manifest %{_package_name}.manifest
83 %defattr(-,root,root,-)
84 %{PREFIX}/*
85 #%{PREFIX}/bin/*
86 #%{PREFIX}/res/*
87 /etc/smack/accesses.d/%{_package_name}.efl
88 /usr/share/packages/%{_package_name}.xml
89 /usr/share/icons/default/small/%{_package_name}.png
90 /usr/share/license/%{_package_name}