Remove the dependency to ac.service from systemd requires
[profile/tv/apps/native/air_volume.git] / packaging / org.tizen.tv-volume.spec
1 Name:      org.tizen.tv-volume
2 Summary:   Volume widget for Tizen TV
3 Version:   0.2
4 Release:   1
5 Group:     Applications/Core Applications
6 License:   Apache-2.0
7 Source0:   %{name}-%{version}.tar.gz
8 Source1:   %{name}.service
9 Source2:   %{name}.path
10 Source3:   %{name}.manifest
11
12 BuildRequires: cmake
13 BuildRequires: pkgconfig(capi-appfw-application)
14 BuildRequires: pkgconfig(capi-media-sound-manager)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(ecore)
17 BuildRequires: pkgconfig(edje)
18 BuildRequires: pkgconfig(app-utils)
19 BuildRequires: gettext-devel
20 BuildRequires: edje-bin
21
22 %define _pkgdir /usr/apps/%{name}
23 %define _bindir %{_pkgdir}/bin
24 %define _resdir %{_pkgdir}/res
25 %define _datadir %{_pkgdir}/data
26 %define _edjedir %{_resdir}/edje
27 %define _manifestdir /usr/share/packages
28 %define _sysuserdir /systemd/user
29 %define _servicedir /systemd/user/default.target.wants
30
31 %description
32 Volume widget for Tizen TV
33
34 %prep
35 %setup -q
36 cp %{SOURCE3} .
37
38 %build
39 cmake \
40         -DCMAKE_INSTALL_PREFIX=%{_pkgdir} \
41         -DPACKAGE_NAME=%{name} \
42         -DBINDIR=%{_bindir} \
43         -DEDJEDIR=%{_edjedir} \
44         -DMANIFESTDIR=%{_manifestdir} \
45         -DVERSION=%{version}
46
47 make %{?jobs:-j%jobs}
48
49 %install
50 %make_install
51 install --directory %{buildroot}/%{_datadir}
52 install --directory %{buildroot}%{_libdir}%{_servicedir}
53 install -m 0644 %{SOURCE1} %{buildroot}%{_libdir}%{_sysuserdir}
54 install -m 0644 %{SOURCE2} %{buildroot}%{_libdir}%{_sysuserdir}
55 ln -sf ../%{name}.path %{buildroot}%{_libdir}%{_servicedir}
56
57 %clean
58 rm -rf %{buildroot}
59
60 %files
61 %manifest %{name}.manifest
62 %defattr(-,root,root,-)
63 %{_bindir}/*
64 %{_resdir}/*
65 %{_datadir}
66 %{_manifestdir}/%{name}.xml
67 %{_libdir}%{_sysuserdir}/%{name}.service
68 %{_libdir}%{_sysuserdir}/%{name}.path
69 %{_libdir}%{_servicedir}/%{name}.path
70 %{_datarootdir}/license/*