8445f766d008d4db9ab506d78f471939ce5da4b9
[platform/core/uifw/tts-engine-default.git] / packaging / org.tizen.tts-engine-default.spec
1 %define _optdir /opt
2 %define _appdir %{_optdir}/apps
3
4 Name:       org.tizen.tts-engine-default
5 Summary:    Text To Speech default engine library
6 Version:    0.1.2
7 Release:    1
8 Group:      Graphics & UI Framework/Voice Framework
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11 Source1001: %{name}.manifest
12
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 BuildRequires: cmake
17 BuildRequires: pkgconfig(libtzplatform-config)
18
19 %description
20 Description: Text To Speech default engine library
21
22 ####
23 #  Preparation
24 ####
25 %prep
26 %setup -q
27 cp %{SOURCE1001} .
28
29 %define APP_PREFIX      %{TZ_SYS_RO_APP}/%{name}
30 export LD_LIBRARY_PATH=%{APP_PREFIX}/lib
31
32 %define MANIFESTDIR     %{TZ_SYS_RO_PACKAGES}
33
34 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} \
35       -DCMAKE_INSTALL_PREFIX=/usr \
36       -DCMAKE_EXPORT_COMPILE_COMMANDS=1 \
37       -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE \
38           -DAPP_INSTALL_PREFIX=%{APP_PREFIX} \
39           -DAPP_MANIFESTDIR=%{MANIFESTDIR}
40
41 ####
42 #  Build
43 ####
44 %build
45 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
46 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
47 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
48 make %{?jobs:-j%jobs}
49
50 ####
51 #  Installation
52 ####
53 %install
54 rm -rf %{buildroot}
55
56 %make_install
57
58 ####
59 #  Post Install
60 ####
61 %post
62 /sbin/ldconfig
63 exit 0
64
65 ####
66 #  Post Uninstall
67 ####
68 %postun
69 /sbin/ldconfig
70 exit 0
71
72 ####
73 #  Files in Binary Packages
74 ####
75 %files
76 %license LICENSE
77 %manifest %{name}.manifest
78 %defattr(-,root,root,-)
79 %{APP_PREFIX}/bin/*
80 %{APP_PREFIX}/lib/*
81 #%{APP_PREFIX}/data/smt_vdata/*
82 %{MANIFESTDIR}/org.tizen.tts-engine-default.xml
83