Fixing backlight issue. IA is currently getting a timeout of 10min, when it should...
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    Flora License, Version 1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-content-media-content)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  pkgconfig(capi-network-wifi)
64 BuildRequires:  pkgconfig(capi-network-bluetooth)
65 BuildRequires:  pkgconfig(capi-network-tethering)
66 BuildRequires:  pkgconfig(capi-network-nfc)
67 BuildRequires:  pkgconfig(ecore-evas)
68 BuildRequires:  pkgconfig(pkgmgr)
69 BuildRequires:  sysman-internal-devel
70 BuildRequires:  cmake
71 BuildRequires:  edje-tools
72 BuildRequires:  gettext-tools
73 #Requires: org.tizen.phone
74 Requires: ug-bluetooth-efl
75 %description
76 Setting application
77  BEAT UI, Setting application.
78
79
80 %prep
81 %setup -q
82
83 %build
84
85 %define PREFIX    "/usr/apps/org.tizen.setting"
86 %define RESDIR    "/usr/apps/org.tizen.setting/res"
87 %define DATADIR    "/usr/apps/org.tizen.setting/data"
88 CFLAGS+=" -fPIC";export CFLAGS
89 CXXFLAGS+=" -fPIC";export CFLAGS
90 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
91
92 %ifarch %{arm}
93         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
94 %else
95         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
96 %endif
97
98 make
99
100 %install
101 rm -rf %{buildroot}
102 %make_install
103
104 mkdir -p %{buildroot}/opt/data/setting
105
106 %clean
107
108 %post
109
110 # Set vconf values with -g/-u options
111 GOPTION="-g 6514"
112
113 #resetMenuscreen
114         # menuscreen app will take this vconf
115         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
116
117
118 #resetFlightmode
119         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
120
121 #resetNetwork
122         vconftool $GOPTION set -t int db/setting/select_network "0"
123         vconftool $GOPTION set -t int db/setting/select_network_act "0"
124         vconftool $GOPTION set -t int db/setting/network_mode "0"
125         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
126         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
127
128 #resetUsbConnectivity
129         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
130         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
131         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
132         vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
133
134 #resetSound
135         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
136         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
137
138         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
139         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
140
141         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
142         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
144         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
145
146         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
148         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
149
150         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
151         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
152
153         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
155
156         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
157         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
158         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
159         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
160
161 #resetWallpaper
162         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
164
165 #resetTilt
166         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
167         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
168         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
169         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
170
171 #resetPanning
172         vconftool $GOPTION set -t bool db/setting/use_panning "0"
173         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
174         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
175         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
176
177 #resetDoubleTap
178         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
179
180 #resetShake
181         vconftool $GOPTION set -t bool db/setting/use_shake "1"
182
183 #resetPickup
184         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
185         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
186
187 #resetTurnOver
188         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
189
190 #resetMotions
191         vconftool $GOPTION set -t bool db/setting/motion_active "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
193         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
194         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
195
196 #resetDisplay
197         #backlight
198 # Set backlight timeout to dim display on all platforms except emulator
199 %if 0%{?simulator}
200         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
201 %else
202         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
203 %endif
204
205         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
206
207         #brightness
208         vconftool $GOPTION set -t int db/setting/Brightness "-1"
209         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
210
211         #battery
212         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
213         #launch
214         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
215
216         #smart screen
217         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
218         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
219         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
220         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
221         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
222
223 #resetPowersaving
224         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
225         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
227
228         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
234
235         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
236         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
237         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
238         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
239
240         #v0.4
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
242         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
243         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
244         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
245
246 #resetFont
247         vconftool $GOPTION set -t int db/setting/font_size "1"
248         vconftool $GOPTION set -t int db/setting/font_type "0"
249
250 #resetRotationLock
251         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
252         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
253         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
254 #resetTimeAndData
255 %ifarch %{arm}
256         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
257 %else
258         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
259 %endif
260
261         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
262         vconftool $GOPTION set -t int db/setting/date_format "0"
263         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
264
265         vconftool $GOPTION set -t string db/setting/timezone "+9"
266         # to be removed
267         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
268
269         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
270
271         #if [ -f /opt/etc/localtime ]
272         #then
273         rm -f /opt/etc/localtime
274         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
275         #fi
276
277
278 #resetAccessibility
279         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
280         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
281         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
282         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
283         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
284         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
285         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
286
287         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
288         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
289         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
290         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
291
292         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
293         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
294         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
295         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
296
297         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
298         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
299         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
300         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
301
302 #Driving Mode
303         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
305         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
306         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
307         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
308         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
309         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
310         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
311
312 #resetLanguageAndRegion
313         vconftool $GOPTION set -t int db/setting/lang "9"
314         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
315         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
316
317 #resetViewtype
318         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
319         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
320
321 #resetTouch
322         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
323         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
324
325 #resetLicense
326         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
327         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
328         vconftool $GOPTION set -t int db/setting/roaming_network "0"
329
330 #resetNotification
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
333         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
336
337         # display content
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
343
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
345         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
346         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
347         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
348         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
349
350 #resetSecurity
351         rm -rf /opt/data/setting/set_info
352         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
353
354         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
355         vconftool $GOPTION set -t bool db/setting/simple_password "1"
356         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
357         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
358         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
359         vconftool $GOPTION set -t string db/setting/fmm/sender ""
360         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
361         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
362         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
363
364         # NOT USED NOW.
365         #vconftool $GOPTION set -t bool db/setting/rcs "0"
366
367         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
368         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
369         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
370         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
371         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
372 #resetMemory
373         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
375         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
376         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
377         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
378         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
379         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
380         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
381
382         # format - system server
383         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
384
385 #resetAbout
386         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
387         vconftool $GOPTION set -t string db/setting/selected_num ""
388 #resetMenuWidgets
389         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
390         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
391
392 #resetDevoptions
393         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
394
395 #resetDatausage
396         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
397         vconftool $GOPTION set -t int db/setting/data_limit "0"
398         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
399         vconftool $GOPTION set -t int db/setting/data_each_month "1"
400
401 #resetDisplay
402         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
403
404 #------------------------------------------
405 #create directory /opt/data/setting
406 if [ ! -d /opt/data/setting ]
407 then
408         mkdir -p /opt/data/setting
409 fi
410
411 # create setting.cfg at runtime right after installation
412 #/opt/apps/org.tizen.setting/bin/setting_conf_util
413 # After flashing, initialize timezone file
414 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
415 chown 5000:5000 /opt/data/setting -R
416 #------------------------------------------
417 sync
418
419 mkdir -p /usr/ug/bin/
420 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
421 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
422
423 %files -n org.tizen.setting
424 %manifest settings.manifest
425 %defattr(-,root,root,-)
426 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
427 %attr(-,app,app) %dir /opt/data/setting
428 /usr/apps/org.tizen.setting/bin/setting
429 /usr/apps/org.tizen.setting/bin/setting_conf_util
430 /opt/data/setting/setting.cfg
431
432 /usr/share/packages/org.tizen.setting.xml
433
434 /usr/share/icons/default/small/org.tizen.setting.png
435 /opt/share/settings/*
436 /usr/apps/org.tizen.setting/res/*
437 /usr/apps/org.tizen.setting/lib/*
438 /usr/apps/org.tizen.setting/data/*
439 /usr/ug/lib/*
440 /opt/data/setting/langlist.xml
441 /opt/data/setting/plugin-cfg/*
442 /opt/data/setting/plugin-xml/*
443 #/usr/apps/org.tizen.setting/bin/test_server