tizen 2.3 release
[apps/home/b2-clocksetting.git] / packaging / org.tizen.setting.spec
1 %define PREFIX /usr/apps/org.tizen.clocksetting
2 Name: org.tizen.clocksetting
3 Version:    0.0.1
4 Release:    1
5 Summary: Tizen W ClockSetting application
6 URL: http://slp-source.sec.samsung.net
7 Source: %{name}-%{version}.tar.gz
8 License: SAMSUNG
9 Group: TO_BE/FILLED_IN
10
11 BuildRequires: cmake
12 BuildRequires: pkgconfig(edje)
13 BuildRequires: pkgconfig(embryo)
14 BuildRequires: pkgconfig(ecore)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(utilX)
17 BuildRequires: pkgconfig(appcore-efl)
18 BuildRequires: pkgconfig(appcore-common)
19 BuildRequires: pkgconfig(dlog)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(capi-appfw-application)
22 BuildRequires: pkgconfig(capi-appfw-app-manager)
23 BuildRequires: pkgconfig(feedback)
24 BuildRequires: pkgconfig(vconf)
25 BuildRequires: pkgconfig(json-glib-1.0)
26 BuildRequires: pkgconfig(deviced)
27 BuildRequires: pkgconfig(pkgmgr)
28 BuildRequires: pkgconfig(pkgmgr-info)
29 BuildRequires: efl-assist-devel
30 BuildRequires: gettext-tools
31 BuildRequires: edje-bin, embryo-bin
32 BuildRequires: elementary-devel
33 BuildRequires: efl-assist-devel
34 BuildRequires: pkgconfig(bluetooth-api)
35 BuildRequires: pkgconfig(capi-network-bluetooth)
36 BuildRequires: pkgconfig(capi-base-common)
37 BuildRequires: pkgconfig(capi-system-device)
38 BuildRequires: pkgconfig(capi-media-sound-manager)
39 BuildRequires: pkgconfig(capi-media-player)
40 BuildRequires: pkgconfig(capi-content-media-content)
41 BuildRequires: pkgconfig(capi-system-info)
42 BuildRequires: pkgconfig(capi-system-system-settings)
43 BuildRequires: pkgconfig(mm-player)
44 BuildRequires: pkgconfig(mm-sound)
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(capi-media-wav-player)
47 #BuildRequires: pkgconfig(capability-manager)
48 BuildRequires: model-build-features
49 BuildRequires: pkgconfig(ail)
50 BuildRequires: pkgconfig(aul)
51
52 %description
53 W ClockSetting application
54
55 %prep
56 %setup -q
57
58 %build
59 #%if 0export CFLAGS="${CFLAGS} -fPIC -fvisibility=hidden -fvisibility-inlines-hidden"
60 #CFLAGS+=" -fvisibility=hidden"; export CFLAGS
61 #CXXFLAGS+=" -fvisibility=hidden"; export CXXFLAGS
62 #FFLAGS+=" -fvisibility=hidden"; export FFLAGS
63
64 %if 0%{?tizen_build_binary_release_type_eng}
65 export CFLAGS+=" -DTIZEN_ENGINEER_MODE"
66 export CXXFLAGS+=" -DTIZEN_ENGINEER_MODE"
67 export FFLAGS+=" -DTIZEN_ENGINEER_MODE"
68 %endif
69 %if 0%{?sec_build_binary_debug_enable}
70 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
71 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
72 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
73 %endif
74
75 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
76 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} \
77 %if 0%{?sec_build_binary_sdk}
78         -DFEATURE_SETTING_SDK=YES \
79 %endif
80 %ifarch %{ix86}
81         -DFEATURE_SETTING_EMUL=YES \
82 %endif
83 #%if "%{?sec_build_project_name}" == "rinato_eur_open"
84 #       -DFEATURE_SETTING_TIZENW2=YES \
85 #%endif
86
87 make %{?jobs:-j%jobs}
88
89
90 %install
91 rm -rf %{buildroot}
92
93 %make_install
94 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting
95 mkdir -p %{buildroot}/opt/usr/apps/org.tizen.clocksetting/data/images
96
97 %clean
98
99 %post
100
101 # Set vconf values with -g/-u options
102 GOPTION="-g 6514"
103
104 #resetMenuscreen
105         #vconftool $GOPTION set -t string db/setting/menuscreen/selected "org.tizen.cluster-home"
106 %ifarch %{arm}
107         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.cluster-home" -s system::vconf_inhouse
108         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.cluster-home" -s system::vconf_setting
109 %else
110         vconftool $GOPTION set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -s system::vconf_inhouse
111         vconftool $GOPTION set -t string db/setting/homescreen/package_name "org.tizen.menu-screen" -s system::vconf_setting
112 %endif
113
114 #resetFlightmode
115 #       vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f -s system::vconf_network
116
117 #resetHomeBG
118         vconftool $GOPTION set -t int db/setting/home_bg_color_type "0" -s system::vconf_inhouse
119
120         vconftool $GOPTION set -t int db/setting/idle_clock_type "9" -s system::vconf_inhouse
121         vconftool $GOPTION set -t bool db/setting/hourly_alert "0" -s system::vconf_inhouse
122         vconftool $GOPTION set -t bool db/setting/prefer_arm_left "1" -s system::vconf_inhouse
123
124 #resetMotions
125         vconftool $GOPTION set -t int db/setting/motion_wake_up_guesture "2" -s system::vconf_inhouse
126         vconftool $GOPTION set -t bool db/setting/motion_smart_relay "0" -s system::vconf_inhouse
127
128
129 #resetNetwork
130         vconftool $GOPTION set -t int db/setting/select_network "0" -s org.tizen.setting::private
131         vconftool $GOPTION set -t int db/setting/select_network_act "0" -s org.tizen.setting::private
132         vconftool $GOPTION set -t int db/setting/network_mode "0" -s org.tizen.setting::private
133         vconftool $GOPTION set -t bool db/setting/3gEnabled "1" -s org.tizen.setting::system
134         vconftool $GOPTION set -t bool db/setting/data_roaming "0" -s system::vconf_system
135         vconftool $GOPTION set -t bool memory/setting/network_mode_changed "0" -i -s system::vconf_system
136
137 #resetUsbConnectivity
138         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -s system::vconf_system
139         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -s system::vconf_system
140         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -s org.tizen.setting::private
141         vconftool $GOPTION set -t bool db/setting/debug_mode "0" -s system::vconf_system
142         vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i -s system::vconf_system
143
144 #resetSound
145 %ifarch %{arm}
146         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Twinkle.ogg"
147         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
148 %else
149         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone.ogg"
150         #DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Ringtone1.ogg"
151 %endif
152
153 %ifarch %{arm}
154         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Flicker.ogg"
155         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
156 %else
157         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification.ogg"
158         #DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Notification1.ogg"
159 %endif
160
161         vconftool $GOPTION set -t bool db/setting/sound/sound_on "0" -s system::vconf_inhouse
162         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1" -s system::vconf_inhouse
163
164         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_ringing "1" -s system::vconf_setting
165         vconftool $GOPTION set -t bool db/setting/sound/vibrate_when_notification "1" -s system::vconf_setting
166
167         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "11" -s system::vconf_setting
168         vconftool $GOPTION set -t int db/setting/sound/call/rmd_ringtone_volume "11" -s system::vconf_setting
169         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "11" -s system::vconf_inhouse
170         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "11" -s org.tizen.setting::private
171         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "9" -s org.tizen.setting::private
172
173         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "3" -s system::vconf_inhouse
174         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3" -s system::vconf_inhouse
175         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" -s org.tizen.setting::private
176
177         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_inhouse
178         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}" -f -s system::vconf_setting
179         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2" -s system::vconf_setting
180         vconftool $GOPTION set -t string db/setting/sound/call/vibration_pattern_path "/opt/share/settings/Vibrations/haptic/default/Notification_Call.ivt" -f -s system::vconf_setting
181         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
182         vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
183         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0" -s system::vconf_inhouse
184
185         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}" -f -s system::vconf_inhouse
186         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0" -s system::vconf_inhouse
187
188         vconftool $GOPTION set -t bool db/setting/sound/button_sounds "0" -s system::vconf_inhouse
189         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "0" -s system::vconf_inhouse
190         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "0" -s system::vconf_inhouse
191         vconftool $GOPTION set -t bool db/setting/sound/haptic_feedback_on "1" -s system::vconf_inhouse
192
193         vconftool $GOPTION set -t bool db/setting/sound/sound_on_bak "1" -s org.tizen.setting::private
194         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds_bak "1" -s org.tizen.setting::private
195         vconftool $GOPTION set -t bool db/setting/sound/sound_lock_bak "1" -s org.tizen.setting::private
196 #resetWallpaper
197         vconftool $GOPTION set -t string db/menu_widget/bgset "" -f -s system::vconf_inhouse
198         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/usr/share/settings/Wallpapers/Lock_default.png" -f -s system::vconf_inhouse
199
200 #resetTilt
201         vconftool $GOPTION set -t bool db/setting/use_tilt "0" -s system::vconf_inhouse
202         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3" -s org.tizen.setting::private
203         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1" -s org.tizen.setting::private
204         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3" -s org.tizen.setting::private
205
206 #resetPanning
207         vconftool $GOPTION set -t bool db/setting/use_panning "0" -s system::vconf_inhouse
208         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3" -s org.tizen.setting::private
209         vconftool $GOPTION set -t bool db/setting/use_panning_browser "0" -s system::vconf_inhouse
210         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3" -s org.tizen.setting::private
211
212 #resetDoubleTap
213         vconftool $GOPTION set -t bool db/setting/use_double_tap "0" -s system::vconf_setting
214
215 #resetShake
216         vconftool $GOPTION set -t bool db/setting/use_shake "0" -s system::vconf_inhouse
217
218 #resetPickup
219         vconftool $GOPTION set -t bool db/setting/use_pick_up "1" -s system::vconf_setting
220         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "0" -s system::vconf_inhouse
221
222 #resetTurnOver
223         vconftool $GOPTION set -t bool db/setting/use_turn_over "0" -s system::vconf_setting
224
225 #resetMotions
226         vconftool $GOPTION set -t bool db/setting/motion_active "0" -s system::vconf_system
227         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1" -s org.tizen.setting::private
228         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1" -s org.tizen.setting::private
229         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1" -s org.tizen.setting::private
230
231 #resetDisplay
232         #backlight
233 %ifarch %{arm}
234         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "10" -s system::vconf_system
235 %else
236         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "10" -s system::vconf_system
237 %endif
238         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "10" -s org.tizen.setting::private
239         vconftool $GOPTION set -t int db/setting/automatic_brightness_level "60" -f -s org.tizen.setting::private
240         #brightness
241         vconftool $GOPTION set -t int db/setting/Brightness "80" -s system::vconf_system
242         vconftool $GOPTION set -t int db/setting/brightness_automatic "0" -s system::vconf_inhouse
243         vconftool $GOPTION set -t bool db/setting/auto_display_adjustment "1" -s system::vconf_inhouse
244
245         #battery
246         vconftool $GOPTION set -t bool db/setting/battery_percentage "1" -s system::vconf_inhouse
247         #launch
248         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
249
250         #smart screen
251         vconftool $GOPTION set -t int db/pm/smartstay_status "0" -f -s org.tizen.setting::private
252         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0" -s system::vconf_inhouse
253         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1" -s system::vconf_inhouse
254         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1" -s org.tizen.setting::private
255         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1" -s org.tizen.setting::private
256         vconftool $GOPTION set -t int db/setting/display/touchkey_light_duration "90" -s system::vconf_inhouse
257         vconftool $GOPTION set -t int db/setting/display/screen_capture_destination "0" -s system::vconf_inhouse
258         vconftool $GOPTION set -t bool db/setting/display/edit_after_screen_capture "0" -s system::vconf_inhouse
259
260         #LED indicator
261         vconftool $GOPTION set -t bool db/setting/led_indicator/charging "1" -s system::vconf_setting
262         vconftool $GOPTION set -t bool db/setting/led_indicator/low_batt "0" -s system::vconf_setting
263         vconftool $GOPTION set -t bool db/setting/led_indicator/notifications "1" -s system::vconf_setting
264         vconftool $GOPTION set -t bool db/setting/led_indicator/voice_rec "1" -s system::vconf_setting
265
266         #Accessory SViewer
267         vconftool $GOPTION set -t bool db/setting/accessories/atuomatic_unlock "1" -s system::vconf_setting
268         vconftool $GOPTION set -t bool db/setting/accessories/dock_sound "0" -s system::vconf_setting
269         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode "0" -s system::vconf_setting
270         vconftool $GOPTION set -t bool db/setting/accessories/audio_output_mode_reminder "0" -f -s org.tizen.setting::private
271         vconftool $GOPTION set -t bool db/setting/accessories/desk_home_screen_display "1" -s system::vconf_setting
272         vconftool $GOPTION set -t bool db/setting/accessories/hdmi_application "0" -s system::vconf_setting
273         vconftool $GOPTION set -t int db/setting/accessories/audio_output "0" -s system::vconf_setting
274         vconftool $GOPTION set -t bool db/setting/accessories/audio_applications "0" -s system::vconf_setting
275
276
277 #resetPowersaving
278         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0" -s org.tizen.setting::private
279
280         # remove this - and use 'preference'
281         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1" -s org.tizen.setting::private
282         #---------------------------------------------------------------------------
283
284         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0" -s system::vconf_inhouse
285
286         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30" -s org.tizen.setting::private
287         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1" -s org.tizen.setting::private
288         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "0" -s org.tizen.setting::private
289         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1" -s org.tizen.setting::private
290         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1" -s org.tizen.setting::private
291         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1" -s org.tizen.setting::private
292
293         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1" -s org.tizen.setting::private
294         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0" -s org.tizen.setting::private
295         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10" -s org.tizen.setting::private
296         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15" -s org.tizen.setting::private
297
298         #v0.4
299         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0" -s system::vconf_inhouse
300         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0" -s system::vconf_inhouse
301         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0" -s system::vconf_inhouse
302         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0" -s system::vconf_inhouse
303
304 #resetFont
305         vconftool $GOPTION set -t int db/setting/font_size "1" -s org.tizen.setting::private
306         vconftool $GOPTION set -t int db/setting/font_type "0" -s org.tizen.setting::private
307         vconftool $GOPTION set -t string memory/setting/tmp_font_name ""  -i -s org.tizen.setting::private
308
309 #resetRotationLock
310
311         # to be removed
312         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"  -s org.tizen.setting::private
313
314         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "1" -s system::vconf_inhouse
315         vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f -s org.tizen.setting::private
316
317 #resetTimeAndData
318 %ifarch %{arm}
319         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1" -s system::vconf_inhouse
320 %else
321         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0" -s system::vconf_inhouse
322 %endif
323
324         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1" -s system::vconf_setting
325         vconftool $GOPTION set -t int db/setting/date_format "0" -s system::vconf_setting
326         vconftool $GOPTION set -t int db/setting/weekofday_format  "0" -s system::vconf_inhouse
327
328         vconftool $GOPTION set -t string db/setting/timezone "+9:00" -s system::vconf_setting
329         # to be removed
330         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL" -s system::vconf_setting
331
332         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul" -s system::vconf_inhouse
333
334         rm -f /opt/etc/localtime
335         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
336         rm -f /etc/localtime
337         ln -s /opt/etc/localtime /etc/localtime
338
339 #resetAccessibility
340         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0" -s system::vconf_system
341         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "0" -s system::vconf_inhouse
342         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1" -s system::vconf_inhouse   #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
343         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue" -s system::vconf_misc
344         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0" -s system::vconf_system
345         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2" -s system::vconf_inhouse
346
347         vconftool $GOPTION set -t bool memory/setting/accessibility/torch_light "0" -i -s system::vconf_system
348         vconftool $GOPTION set -t bool db/setting/accessibility/assistive_light_reminder "1" -s system::vconf_inhouse
349         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0" -s system::vconf_setting
350         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1" -s system::vconf_inhouse
351         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0" -s system::vconf_setting
352         vconftool $GOPTION set -t string db/setting/accessibility/led_playing_path "/usr/share/feedback/led/default/Ticktock.led" -s org.tizen.setting::private
353         vconftool $GOPTION set -t bool db/setting/accessibility/turn_off_all_sounds "0" -s system::vconf_setting
354
355         vconftool $GOPTION set -t bool db/setting/accessibility/speak_passwd  "0" -s org.tizen.setting::private
356         vconftool $GOPTION set -t int db/setting/accessibility/lock_time "5" -s system::vconf_setting
357         vconftool $GOPTION set -t string db/setting/accessibility/taphold_delay "IDS_COM_POP_SHORT" -s org.tizen.setting::private
358
359 # duplicated key creation (it's in Call setting)
360 #       vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
361 #       vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
362 #       vconftool $GOPTION set -t int db/ciss/answering_mode "0"
363 #       vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
364
365         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0" -s org.tizen.setting::private
366         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0" -s org.tizen.setting::private
367         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1" -s org.tizen.setting::private
368         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0" -s org.tizen.setting::private
369
370         vconftool $GOPTION set -t int db/setting/accessibility/sound_balance "50" -s org.tizen.setting::private
371 # Colorblind
372         vconftool $GOPTION set -t bool db/setting/colorblind/status "0" -s org.tizen.setting::private
373         vconftool $GOPTION set -t string db/setting/colorblind/chip_array "" -s org.tizen.setting::private
374         vconftool $GOPTION set -t string db/setting/colorblind/rgbcmy "" -s org.tizen.setting::private
375         vconftool $GOPTION set -t double db/setting/colorblind/user_adjustment "0.0" -s org.tizen.setting::private
376 # Driving Mode
377         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "0" -s system::vconf_inhouse
378         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "0" -s system::vconf_setting
379         vconftool $GOPTION set -t bool db/setting/drivingmode/message "0" -s system::vconf_setting
380         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "0" -s system::vconf_setting
381         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "0" -s system::vconf_setting
382         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "0" -s system::vconf_setting
383         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "0" -s system::vconf_setting
384         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "0" -s system::vconf_setting
385
386 # Easymode
387         vconftool $GOPTION set -t bool db/setting/homescreen/easymode "0" -s system::vconf_inhouse
388
389 # Blocking Mode
390         vconftool $GOPTION set -t bool db/setting/blockingmode/blockingmode "0" -s system::vconf_setting
391         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/incomingcall "0" -s system::vconf_setting
392         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/notifications "0" -s system::vconf_setting
393         vconftool $GOPTION set -t bool db/setting/blockingmode/inter/alarm_and_timer "0" -s system::vconf_setting
394
395         vconftool $GOPTION set -t int db/setting/blockingmode/start_hour "21" -s org.tizen.setting::private
396         vconftool $GOPTION set -t int db/setting/blockingmode/start_min "0" -s org.tizen.setting::private
397         vconftool $GOPTION set -t int db/setting/blockingmode/end_hour "6" -s org.tizen.setting::private
398         vconftool $GOPTION set -t int db/setting/blockingmode/end_min "0" -s org.tizen.setting::private
399         vconftool $GOPTION set -t bool db/setting/blockingmode/incomingcall "0" -s org.tizen.setting::private
400         vconftool $GOPTION set -t bool db/setting/blockingmode/notifications "0" -s org.tizen.setting::private
401         vconftool $GOPTION set -t bool db/setting/blockingmode/alarm_and_timer "0" -s org.tizen.setting::private
402         vconftool $GOPTION set -t bool db/setting/blockingmode/allday "1" -s org.tizen.setting::private
403         vconftool $GOPTION set -t int db/setting/blockingmode/allowed_contact_type "0" -s system::vconf_setting
404         vconftool $GOPTION set -t string db/setting/blockingmode/allowed_contact_list "" -s system::vconf_setting
405         vconftool $GOPTION set -t int db/setting/blockingmode/start_alarm_id "" -s org.tizen.setting::private
406         vconftool $GOPTION set -t int db/setting/blockingmode/end_alarm_id "" -s org.tizen.setting::private
407
408 #resetLanguageAndRegion
409         vconftool $GOPTION set -t int db/setting/lang "9" -s org.tizen.setting::private
410         vconftool $GOPTION set -t bool db/setting/lang_automatic "0" -s org.tizen.setting::private
411         vconftool $GOPTION set -t bool db/setting/region_automatic "1" -s org.tizen.setting::private
412         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8" -s system::vconf_inhouse
413         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8" -s system::vconf_inhouse
414
415 #resetViewtype
416         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
417         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
418
419 #resetTouch
420         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
421         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
422
423 #resetLicense
424         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0" -s org.tizen.setting::private
425         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0" -s org.tizen.setting::private
426         vconftool $GOPTION set -t int db/setting/roaming_network "0" -s org.tizen.setting::private
427
428 #resetNotification
429         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1" -s system::vconf_setting
430         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1" -s system::vconf_inhouse
431         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1" -s system::vconf_setting
432         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1" -s org.tizen.setting::private
433         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1" -s org.tizen.setting::private
434
435                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/email "1" -s org.tizen.setting::private
436                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/messages "1" -s org.tizen.setting::private
437                 vconftool $GOPTION set -t bool db/setting/ticker_noti/sound/im "1" -s org.tizen.setting::private
438
439         # display content
440         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1" -s org.tizen.setting::private
441         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1" -s org.tizen.setting::private
442         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1" -s org.tizen.setting::private
443         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1" -s org.tizen.setting::private
444         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1" -s org.tizen.setting::private
445
446         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1" -s org.tizen.setting::private
447         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1" -s org.tizen.setting::private
448         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1" -s org.tizen.setting::private
449         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1" -s org.tizen.setting::private
450         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1" -s org.tizen.setting::private
451
452 #resetSecurity
453         rm -rf /opt/usr/data/setting/set_info
454         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
455
456         vconftool $GOPTION set -t bool db/setting/power_on_lock "0" -s system::vconf_setting
457         vconftool $GOPTION set -t bool db/setting/simple_password "1" -s org.tizen.setting::private
458         vconftool $GOPTION set -t int db/setting/screen_lock_type "0" -s system::vconf_inhouse
459         vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen" -s system::vconf_inhouse
460         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0" -s system::vconf_inhouse
461         vconftool $GOPTION set -t string db/setting/fmm/recipients "" -s system::vconf_inhouse
462         vconftool $GOPTION set -t string db/setting/fmm/sender "" -s system::vconf_inhouse
463         vconftool $GOPTION set -t string db/setting/fmm/alert_message "" -s system::vconf_inhouse
464         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0" -s system::vconf_inhouse
465         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0" -s system::vconf_inhouse
466
467         # for MMC encryption
468         vconftool $GOPTION set -t bool db/setting/mmc_encryption/status "0" -s system::vconf_system
469         vconftool $GOPTION set -t int db/setting/mmc_encryption/option "0" -s org.tizen.setting::private
470         vconftool $GOPTION set -t bool db/setting/mmc_encryption/exclude_multimedia "0" -s org.tizen.setting::private
471
472         # NOT USED NOW.
473         #vconftool $GOPTION set -t bool db/setting/rcs "0"
474
475         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5" -s system::vconf_inhouse
476         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp "" -s system::vconf_inhouse
477         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5" -s org.tizen.setting::private
478         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp "" -s org.tizen.setting::private
479         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0" -s org.tizen.setting::private
480 #resetMemory
481         vconftool $GOPTION set -t int db/setting/default_memory/wap "0" -s system::vconf_system
482         vconftool $GOPTION set -t int db/setting/default_memory/download "0" -s system::vconf_system
483         vconftool $GOPTION set -t int db/setting/default_memory/download_nfc "0" -s system::vconf_system
484         vconftool $GOPTION set -t int db/setting/default_memory/download_contents "0" -s system::vconf_system
485         vconftool $GOPTION set -t int db/setting/default_memory/download_application "0" -s system::vconf_system
486         vconftool $GOPTION set -t int db/setting/default_memory/wifi_direct "0" -s system::vconf_system
487         vconftool $GOPTION set -t int db/setting/default_memory/install_applications "0" -s system::vconf_system
488
489         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0" -s system::vconf_system
490         vconftool $GOPTION set -t int db/setting/default_memory/camera "0" -s system::vconf_system
491         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0" -s system::vconf_system
492         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0" -s system::vconf_system
493         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0" -s system::vconf_system
494         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0" -s system::vconf_system
495         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0" -s system::vconf_system
496
497         # format - system server
498         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
499
500 #resetAbout
501         vconftool $GOPTION set -t string db/setting/device_name "Gear 2" -s system::vconf_network
502         vconftool $GOPTION set -t string db/setting/selected_num "" -s org.tizen.setting::private
503 #resetMenuWidgets
504         vconftool $GOPTION -i set -t int memory/setting/font_changed "0" -s org.tizen.setting::private
505         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
506
507 #resetDevoptions
508         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0" -s system::vconf_setting
509
510 #resetDatausage
511         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0" -s org.tizen.setting::private
512         vconftool $GOPTION set -t int db/setting/data_limit "-1" -s org.tizen.setting::private
513         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0" -s org.tizen.setting::private
514         vconftool $GOPTION set -t int db/setting/data_each_month "1" -s org.tizen.setting::private
515         vconftool $GOPTION set -t int db/setting/data_each_month_app "1" -s org.tizen.setting::private
516         vconftool $GOPTION set -t bool db/setting/data_usage_roaming_status "0" -s org.tizen.setting::private
517         vconftool $GOPTION set -t int db/setting/data_limit_roaming "-1" -s org.tizen.setting::private
518         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit_roaming "0" -s org.tizen.setting::private
519
520 #resetDisplay
521         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic" -f -s org.tizen.setting::private
522
523 #resetMostRecentlySetting
524         vconftool $GOPTION set -t string db/setting/most_recently_setting "" -s org.tizen.setting::private
525
526 #psmode(power saving mode)
527         vconftool $GOPTION set -t int db/setting/psmode "0" -s system::vconf_setting
528
529 #resetMyplace
530         vconftool $GOPTION set -t string db/setting/myplace_home "" -s system::vconf_inhouse
531         vconftool $GOPTION set -t string db/setting/myplace_office "" -s system::vconf_inhouse
532
533 # personal page(not include on vconf internal yet)
534         vconftool $GOPTION set -t bool memory/setting/personal "0" -i -s system::vconf_setting
535         vconftool $GOPTION set -t string db/setting/personal_key "" -s system::vconf_setting
536
537 # homescreen layout type
538         vconftool $GOPTION set -t int db/setting/homescreen_type "1" -s system::vconf_inhouse
539
540 # privacy setting
541         vconftool $GOPTION set -t int db/setting/lock_type "0" -s system::vconf_inhouse
542         vconftool $GOPTION set -t bool db/setting/see_pattern "1" -s system::vconf_inhouse
543
544 # display screen rotation
545         vconftool $GOPTION set -t int db/setting/screen_rotation "0" -s system::vconf_inhouse
546
547 # display home screen bg set
548         vconftool $GOPTION set -t int db/setting/homescreen_bg "0" -s system::vconf_inhouse
549
550 # support emergency mode
551         vconftool $GOPTION set -t bool db/setting/support_emergency "1" -s system::vconf_setting
552         vconftool $GOPTION set -t bool db/setting/emergency_status "0" -s system::vconf_setting
553
554 # volume toast show
555 #       vconftool $GOPTION set -t int memory/setting/volume_ring_toast_show "0" -i -f -s org.tizen.setting::private
556 #       vconftool $GOPTION set -t int memory/setting/volume_noti_toast_show "0" -i -f -s org.tizen.setting::private
557
558 # safety, emergency mode
559         vconftool $GOPTION set -t int db/setting/emergency_wakeup_gesture "0" -s system::vconf_setting
560         vconftool $GOPTION set -t int db/setting/emergency_brightness "1" -s system::vconf_setting
561         vconftool $GOPTION set -t int db/setting/emergency_lcd_timeout "10" -s system::vconf_setting
562         vconftool $GOPTION set -t string db/setting/emergency_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
563
564 # power saver wearable
565         vconftool $GOPTION set -t int db/setting/pws_wakeup_gesture "0" -s system::vconf_setting
566         vconftool $GOPTION set -t int db/setting/pws_brightness "1" -s system::vconf_setting
567         vconftool $GOPTION set -t int db/setting/pws_lcd_timeout "10" -s system::vconf_setting
568         vconftool $GOPTION set -t string db/setting/pws_ringtone "/opt/share/settings/Emergency/Low_power_ringtone.ogg" -s system::vconf_setting
569
570         vconftool $GOPTION set -t string db/wms/clocks_set_idle "org.tizen.idle-clock-digital"  -u 5000 -s system::vconf
571         vconftool $GOPTION set -t int db/wms/home_bg_mode 0 -u 5000 -s system::vconf
572         vconftool $GOPTION set -t string db/wms/home_bg_palette "000000" -u 5000 -s system::vconf
573         vconftool $GOPTION set -t string db/wms/home_bg_wallpaper "wallpaper_01.png"  -u 5000 -s system::vconf
574         vconftool $GOPTION set -t string db/wms/home_bg_gallery "/opt/usr/media/.bgwallpaper.jpg" -u 5000 -s system::vconf 
575         
576         # Idle clock edit mode ( with Home )
577     vconftool $GOPTION set -t int db/setting/idle_clock_show "0" -s system::vconf_inhouse
578
579 if [ -d /opt/share/settings ]
580 then
581         rm -rf /opt/share/settings
582 fi
583
584 ln -s /opt/usr/share/settings /opt/share/settings
585
586 # shared dir
587 mkdir -p /usr/apps/org.tizen.clocksetting/shared
588 mkdir -p /usr/apps/org.tizen.clocksetting/shared/res
589
590 mkdir -p /opt/usr/data/setting
591
592 %files
593 %manifest %{name}.manifest
594 /etc/smack/accesses.d/org.tizen.clocksetting.efl
595 %defattr(-,root,root,-)
596 %attr(-,inhouse,inhouse)
597 %dir %{PREFIX}/data
598 #%{PREFIX}/bin/*
599 #%{PREFIX}/res/*
600 /usr/share/packages/*
601 /usr/share/icons/default/small/*
602 #/usr/share/packages/%{name}.xml
603 #/usr/apps/org.tizen.clocksetting/data/images/*
604 /usr/apps/org.tizen.clocksetting/*
605 #/usr/apps/org.tizen.clocksetting/shared/res/*
606 /opt/usr/share/settings/*
607 /usr/share/Safety.zip
608 /opt/usr/data/setting/*