Merge "Fix N_SE-27968" into tizen_2.1
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    Flora License, Version 1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(notification)
51 BuildRequires:  pkgconfig(pango)
52 BuildRequires:  pkgconfig(capi-system-runtime-info)
53 BuildRequires:  pkgconfig(capi-media-player)
54 BuildRequires:  pkgconfig(capi-media-sound-manager)
55 BuildRequires:  pkgconfig(capi-content-media-content)
56 BuildRequires:  pkgconfig(capi-system-device)
57 BuildRequires:  pkgconfig(capi-appfw-application)
58 BuildRequires:  pkgconfig(capi-appfw-app-manager)
59 BuildRequires:  pkgconfig(capi-system-sensor)
60 BuildRequires:  pkgconfig(capi-system-info)
61 BuildRequires:  pkgconfig(capi-system-system-settings)
62 BuildRequires:  pkgconfig(capi-network-wifi)
63 BuildRequires:  pkgconfig(capi-network-bluetooth)
64 BuildRequires:  pkgconfig(capi-network-tethering)
65 BuildRequires:  pkgconfig(capi-network-nfc)
66 BuildRequires:  pkgconfig(capi-security-privacy-manager)
67 BuildRequires:  pkgconfig(privacy-manager-client)
68 BuildRequires:  pkgconfig(privacy-manager-server)
69 BuildRequires:  pkgconfig(ecore-evas)
70 BuildRequires:  pkgconfig(pkgmgr)
71 BuildRequires:  pkgconfig(pkgmgr-info)
72 BuildRequires:  sysman-internal-devel
73 BuildRequires:  cmake
74 BuildRequires:  edje-tools
75 BuildRequires:  gettext-tools
76 #Requires: org.tizen.phone
77 Requires: ug-bluetooth-efl
78 %description
79 Setting application
80  BEAT UI, Setting application.
81
82
83 %prep
84 %setup -q
85
86 %build
87
88 %define PREFIX    "/usr/apps/org.tizen.setting"
89 %define RESDIR    "/usr/apps/org.tizen.setting/res"
90 %define DATADIR    "/usr/apps/org.tizen.setting/data"
91 CFLAGS+=" -fPIC";export CFLAGS
92 CXXFLAGS+=" -fPIC";export CFLAGS
93 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
94
95 %ifarch %{arm}
96         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
97 %else
98         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
99 %endif
100
101 make
102
103 %install
104 rm -rf %{buildroot}
105 %make_install
106
107 mkdir -p %{buildroot}/opt/data/setting
108
109 %clean
110
111 %post
112
113 # Set vconf values with -g/-u options
114 GOPTION="-g 6514"
115
116 #resetMenuscreen
117         # menuscreen app will take this vconf
118         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
119
120
121 #resetFlightmode
122         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
123
124 #resetNetwork
125         vconftool $GOPTION set -t int db/setting/select_network "0"
126         vconftool $GOPTION set -t int db/setting/select_network_act "0"
127         vconftool $GOPTION set -t int db/setting/network_mode "0"
128         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
129         vconftool $GOPTION set -t bool db/setting/data_roaming "0"
130
131 #resetUsbConnectivity
132         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
133         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
134         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
135         vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
136
137 #resetSound
138         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
139         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
140
141         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
142         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
143
144         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
145         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
146         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
148
149         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
150         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
151         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
152
153         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
155
156         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
157         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
158
159         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
160         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
161         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
162         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
163
164 #resetWallpaper
165         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
166         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
167
168 #resetTilt
169         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
170         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
171         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
172         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
173
174 #resetPanning
175         vconftool $GOPTION set -t bool db/setting/use_panning "0"
176         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
177         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
178         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
179
180 #resetDoubleTap
181         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
182
183 #resetShake
184         vconftool $GOPTION set -t bool db/setting/use_shake "1"
185
186 #resetPickup
187         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
188         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
189
190 #resetTurnOver
191         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
192
193 #resetMotions
194         vconftool $GOPTION set -t bool db/setting/motion_active "1"
195         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
196         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
197         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
198
199 #resetDisplay
200         #backlight
201 # Set backlight timeout to dim display on all platforms except emulator
202 # 0 sec : unlimited time
203 # 600 sec : 10 min
204 %if 0%{?simulator}
205         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
206 %else
207         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
208 %endif
209
210         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
211
212         #brightness
213         vconftool $GOPTION set -t int db/setting/Brightness "-1"
214         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
215
216         #battery
217         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
218         #launch
219         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
220
221         #smart screen
222         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
223         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
224         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
225         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
226         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
227
228 #resetPowersaving
229         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
232
233         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
234         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
235         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
236         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
237         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
239
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
242         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
243         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
244
245         #v0.4
246         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
247         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
248         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
249         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
250
251 #resetFont
252         vconftool $GOPTION set -t int db/setting/font_size "1"
253         vconftool $GOPTION set -t int db/setting/font_type "0"
254
255 #resetRotationLock
256         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
257         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
258         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
259 #resetTimeAndData
260 %ifarch %{arm}
261         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
262 %else
263         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
264 %endif
265
266         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
267         vconftool $GOPTION set -t int db/setting/date_format "0"
268         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
269
270         vconftool $GOPTION set -t string db/setting/timezone "+9"
271         # to be removed
272         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
273
274         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
275
276         #if [ -f /opt/etc/localtime ]
277         #then
278         rm -f /opt/etc/localtime
279         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
280         #fi
281
282
283 #resetAccessibility
284         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
285         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
286         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
287         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
288         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
289         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
290         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
291         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
292
293         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
294         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
295         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
296         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
297
298         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
299         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
300         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
301         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
302
303         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
304         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
305         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
306         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
307
308 #Driving Mode
309         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
310         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
311         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
312         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
313         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
314         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
315         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
316         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
317
318 #resetLanguageAndRegion
319         vconftool $GOPTION set -t int db/setting/lang "9"
320         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
321         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
322
323 #resetViewtype
324         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
325         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
326
327 #resetTouch
328         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
329         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
330
331 #resetLicense
332         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
333         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
334         vconftool $GOPTION set -t int db/setting/roaming_network "0"
335
336 #resetNotification
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
342
343         # display content
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
345         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
346         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
347         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
348         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
349
350         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
351         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
352         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
353         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
354         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
355
356 #resetSecurity
357         rm -rf /opt/data/setting/set_info
358         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
359
360         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
361         vconftool $GOPTION set -t bool db/setting/simple_password "1"
362         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
363         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
364         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
365         vconftool $GOPTION set -t string db/setting/fmm/sender ""
366         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
367         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
368         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
369
370         # NOT USED NOW.
371         #vconftool $GOPTION set -t bool db/setting/rcs "0"
372
373         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
374         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
375         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
376         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
377         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
378 #resetMemory
379         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
380         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
381         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
382         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
383         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
384         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
385         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
386         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
387
388         # format - system server
389         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
390
391 #resetAbout
392         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
393         vconftool $GOPTION set -t string db/setting/selected_num ""
394 #resetMenuWidgets
395         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
396         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
397
398 #resetDevoptions
399         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
400
401 #resetDatausage
402         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
403         vconftool $GOPTION set -t int db/setting/data_limit "0"
404         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
405         vconftool $GOPTION set -t int db/setting/data_each_month "1"
406
407 #resetDisplay
408         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
409
410 #------------------------------------------
411 #create directory /opt/data/setting
412 if [ ! -d /opt/data/setting ]
413 then
414         mkdir -p /opt/data/setting
415 fi
416
417 # create setting.cfg at runtime right after installation
418 #/opt/apps/org.tizen.setting/bin/setting_conf_util
419 # After flashing, initialize timezone file
420 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
421 chown 5000:5000 /opt/data/setting -R
422 #------------------------------------------
423 sync
424
425 mkdir -p /usr/ug/bin/
426 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
427 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
428 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
429 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-privacy-efl
430
431 %files -n org.tizen.setting
432 %manifest settings.manifest
433 %defattr(-,root,root,-)
434 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
435 %attr(-,app,app) %dir /opt/data/setting
436 /usr/apps/org.tizen.setting/bin/setting
437 /usr/apps/org.tizen.setting/bin/setting_conf_util
438 /opt/data/setting/setting.cfg
439
440 /usr/share/packages/org.tizen.setting.xml
441
442 /usr/share/icons/default/small/org.tizen.setting.png
443 /opt/share/settings/*
444 /usr/apps/org.tizen.setting/res/*
445 /usr/apps/org.tizen.setting/lib/*
446 /usr/apps/org.tizen.setting/data/*
447 /usr/ug/lib/*
448 /opt/data/setting/langlist.xml
449 /opt/data/setting/plugin-cfg/*
450 /opt/data/setting/plugin-xml/*
451 #/usr/apps/org.tizen.setting/bin/test_server