vconf set for speech rate
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    Flora License, Version 1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-content-media-content)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  pkgconfig(capi-network-wifi)
64 BuildRequires:  pkgconfig(capi-network-bluetooth)
65 BuildRequires:  pkgconfig(capi-network-tethering)
66 BuildRequires:  pkgconfig(capi-network-nfc)
67 BuildRequires:  pkgconfig(ecore-evas)
68 BuildRequires:  pkgconfig(pkgmgr)
69 BuildRequires:  sysman-internal-devel
70 BuildRequires:  cmake
71 BuildRequires:  edje-tools
72 BuildRequires:  gettext-tools
73 #Requires: org.tizen.phone
74 Requires: ug-bluetooth-efl
75 %description
76 Setting application
77  BEAT UI, Setting application.
78
79
80 %prep
81 %setup -q
82
83 %build
84
85 %define PREFIX    "/usr/apps/org.tizen.setting"
86 %define RESDIR    "/usr/apps/org.tizen.setting/res"
87 %define DATADIR    "/usr/apps/org.tizen.setting/data"
88 CFLAGS+=" -fPIC";export CFLAGS
89 CXXFLAGS+=" -fPIC";export CFLAGS
90 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
91
92 %ifarch %{arm}
93         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
94 %else
95         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
96 %endif
97
98 make
99
100 %install
101 rm -rf %{buildroot}
102 %make_install
103
104 mkdir -p %{buildroot}/opt/data/setting
105
106 %clean
107
108 %post
109
110 # Set vconf values with -g/-u options
111 GOPTION="-g 6514"
112
113 #resetMenuscreen
114         # menuscreen app will take this vconf
115         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
116
117
118 #resetFlightmode
119         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
120
121 #resetNetwork
122         vconftool $GOPTION set -t int db/setting/select_network "0"
123         vconftool $GOPTION set -t int db/setting/select_network_act "0"
124         vconftool $GOPTION set -t int db/setting/network_mode "0"
125         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
126         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
127
128 #resetUsbConnectivity
129         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
130         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
131         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
132         vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
133
134 #resetSound
135         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
136         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
137
138         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
139         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
140
141         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
142         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
144         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
145
146         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
148         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
149
150         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
151         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
152
153         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
155
156         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
157         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
158         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
159         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
160
161 #resetWallpaper
162         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
164
165 #resetTilt
166         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
167         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
168         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
169         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
170
171 #resetPanning
172         vconftool $GOPTION set -t bool db/setting/use_panning "0"
173         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
174         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
175         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
176
177 #resetDoubleTap
178         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
179
180 #resetShake
181         vconftool $GOPTION set -t bool db/setting/use_shake "1"
182
183 #resetPickup
184         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
185         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
186
187 #resetTurnOver
188         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
189
190 #resetMotions
191         vconftool $GOPTION set -t bool db/setting/motion_active "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
193         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
194         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
195
196 #resetDisplay
197         #backlight
198 # Set backlight timeout to dim display on all platforms except emulator
199 # 0 sec : unlimited time 
200 # 600 sec : 10 min
201 %if 0%{?simulator}
202         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
203 %else
204         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
205 %endif
206
207         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
208
209         #brightness
210         vconftool $GOPTION set -t int db/setting/Brightness "-1"
211         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
212
213         #battery
214         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
215         #launch
216         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
217
218         #smart screen
219         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
220         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
221         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
222         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
223         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
224
225 #resetPowersaving
226         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
229
230         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
234         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
235         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
236
237         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
239         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
240         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
241
242         #v0.4
243         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
244         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
245         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
246         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
247
248 #resetFont
249         vconftool $GOPTION set -t int db/setting/font_size "1"
250         vconftool $GOPTION set -t int db/setting/font_type "0"
251
252 #resetRotationLock
253         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
254         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
255         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
256 #resetTimeAndData
257 %ifarch %{arm}
258         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
259 %else
260         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
261 %endif
262
263         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
264         vconftool $GOPTION set -t int db/setting/date_format "0"
265         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
266
267         vconftool $GOPTION set -t string db/setting/timezone "+9"
268         # to be removed
269         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
270
271         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
272
273         #if [ -f /opt/etc/localtime ]
274         #then
275         rm -f /opt/etc/localtime
276         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
277         #fi
278
279
280 #resetAccessibility
281         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
282         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
283         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
284         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
285         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
286         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
287         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
288         vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
289
290         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
291         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
292         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
293         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
294
295         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
296         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
297         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
298         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
299
300         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
301         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
302         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
303         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
304
305 #Driving Mode
306         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
307         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
308         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
309         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
310         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
311         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
312         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
313         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
314
315 #resetLanguageAndRegion
316         vconftool $GOPTION set -t int db/setting/lang "9"
317         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
318         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
319
320 #resetViewtype
321         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
322         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
323
324 #resetTouch
325         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
326         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
327
328 #resetLicense
329         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
330         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
331         vconftool $GOPTION set -t int db/setting/roaming_network "0"
332
333 #resetNotification
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
339
340         # display content
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
343         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
345         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
346
347         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
348         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
349         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
350         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
351         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
352
353 #resetSecurity
354         rm -rf /opt/data/setting/set_info
355         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
356
357         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
358         vconftool $GOPTION set -t bool db/setting/simple_password "1"
359         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
360         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
361         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
362         vconftool $GOPTION set -t string db/setting/fmm/sender ""
363         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
364         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
365         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
366
367         # NOT USED NOW.
368         #vconftool $GOPTION set -t bool db/setting/rcs "0"
369
370         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
371         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
372         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
373         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
374         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
375 #resetMemory
376         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
377         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
378         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
379         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
380         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
381         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
382         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
383         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
384
385         # format - system server
386         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
387
388 #resetAbout
389         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
390         vconftool $GOPTION set -t string db/setting/selected_num ""
391 #resetMenuWidgets
392         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
393         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
394
395 #resetDevoptions
396         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
397
398 #resetDatausage
399         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
400         vconftool $GOPTION set -t int db/setting/data_limit "0"
401         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
402         vconftool $GOPTION set -t int db/setting/data_each_month "1"
403
404 #resetDisplay
405         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
406
407 #------------------------------------------
408 #create directory /opt/data/setting
409 if [ ! -d /opt/data/setting ]
410 then
411         mkdir -p /opt/data/setting
412 fi
413
414 # create setting.cfg at runtime right after installation
415 #/opt/apps/org.tizen.setting/bin/setting_conf_util
416 # After flashing, initialize timezone file
417 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
418 chown 5000:5000 /opt/data/setting -R
419 #------------------------------------------
420 sync
421
422 mkdir -p /usr/ug/bin/
423 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
424 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
425
426 %files -n org.tizen.setting
427 %manifest settings.manifest
428 %defattr(-,root,root,-)
429 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
430 %attr(-,app,app) %dir /opt/data/setting
431 /usr/apps/org.tizen.setting/bin/setting
432 /usr/apps/org.tizen.setting/bin/setting_conf_util
433 /opt/data/setting/setting.cfg
434
435 /usr/share/packages/org.tizen.setting.xml
436
437 /usr/share/icons/default/small/org.tizen.setting.png
438 /opt/share/settings/*
439 /usr/apps/org.tizen.setting/res/*
440 /usr/apps/org.tizen.setting/lib/*
441 /usr/apps/org.tizen.setting/data/*
442 /usr/ug/lib/*
443 /opt/data/setting/langlist.xml
444 /opt/data/setting/plugin-cfg/*
445 /opt/data/setting/plugin-xml/*
446 #/usr/apps/org.tizen.setting/bin/test_server