4d48d7e6dee87d39b66ada9bee871dcd2ddf480d
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-content-media-content)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  pkgconfig(capi-network-wifi)
64 BuildRequires:  pkgconfig(capi-network-bluetooth)
65 BuildRequires:  pkgconfig(capi-network-nfc)
66 BuildRequires:  pkgconfig(ecore-evas)
67 BuildRequires:  pkgconfig(pkgmgr)
68 BuildRequires:  sysman-internal-devel
69 BuildRequires:  cmake
70 BuildRequires:  edje-tools
71 BuildRequires:  gettext-tools
72 Requires: org.tizen.phone
73 %description
74 Setting application
75  BEAT UI, Setting application.
76
77
78 %prep
79 %setup -q
80
81 %build
82
83 %define PREFIX    "/usr/apps/org.tizen.setting"
84 %define RESDIR    "/usr/apps/org.tizen.setting/res"
85 %define DATADIR    "/usr/apps/org.tizen.setting/data"
86 CFLAGS+=" -fPIC";export CFLAGS
87 CXXFLAGS+=" -fPIC";export CFLAGS
88 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
89
90 %ifarch %{arm}
91         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
92 %else
93         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
94 %endif
95
96 make
97
98 %install
99 rm -rf %{buildroot}
100 %make_install
101
102 mkdir -p %{buildroot}/opt/data/setting
103
104 %clean
105
106 %post
107
108 # Set vconf values with -g/-u options
109 GOPTION="-g 6514"
110
111 #resetMenuscreen
112         # menuscreen app will take this vconf
113         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
114
115
116 #resetFlightmode
117         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
118
119 #resetNetwork
120         vconftool $GOPTION set -t int db/setting/select_network "0"
121         vconftool $GOPTION set -t int db/setting/select_network_act "0"
122         vconftool $GOPTION set -t int db/setting/network_mode "0"
123         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
124         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
125
126 #resetUsbConnectivity
127         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
128         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
129         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
130         vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
131
132 #resetSound
133         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
134         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
135
136         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
137         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
138
139         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
140         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
141         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
142         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
143
144         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
145         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
146         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
147
148         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
149         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
150
151         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
152         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
153
154         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
155         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
156         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
157         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
158
159 #resetWallpaper
160         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
161         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
162
163 #resetTilt
164         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
165         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
166         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
167         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
168
169 #resetPanning
170         vconftool $GOPTION set -t bool db/setting/use_panning "0"
171         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
172         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
173         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
174
175 #resetDoubleTap
176         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
177
178 #resetShake
179         vconftool $GOPTION set -t bool db/setting/use_shake "1"
180
181 #resetPickup
182         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
183         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
184
185 #resetTurnOver
186         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
187
188 #resetMotions
189         vconftool $GOPTION set -t bool db/setting/motion_active "1"
190         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
191         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
192         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
193
194 #resetDisplay
195         #backlight
196 %ifarch %{arm}
197         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
198 %else
199         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
200 %endif
201         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
202
203         #brightness
204         vconftool $GOPTION set -t int db/setting/Brightness "-1"
205         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
206
207         #battery
208         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
209         #launch
210         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
211
212         #smart screen
213         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
214         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
215         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
216         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
217         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
218
219 #resetPowersaving
220         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
221         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
222         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
223
224         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
225         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
230
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
233         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
234         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
235
236         #v0.4
237         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
241
242 #resetFont
243         vconftool $GOPTION set -t int db/setting/font_size "1"
244         vconftool $GOPTION set -t int db/setting/font_type "0"
245
246 #resetRotationLock
247         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
248         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
249 #resetTimeAndData
250 %ifarch %{arm}
251         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
252 %else
253         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
254 %endif
255
256         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
257         vconftool $GOPTION set -t int db/setting/date_format "0"
258         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
259
260         vconftool $GOPTION set -t string db/setting/timezone "+9"
261         # to be removed
262         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
263
264         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
265
266         #if [ -f /opt/etc/localtime ]
267         #then
268         rm -f /opt/etc/localtime
269         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
270         #fi
271
272
273 #resetAccessibility
274         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
275         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
276         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
277         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
278         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
279         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
280         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
281
282         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
283         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
284         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
285         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
286
287         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
288         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
289         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
290         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
291
292         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
293         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
294         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
295         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
296
297 #Driving Mode
298         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
299         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
300         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
303         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
305         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
306
307 #resetLanguageAndRegion
308         vconftool $GOPTION set -t int db/setting/lang "9"
309         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
310         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
311
312 #resetViewtype
313         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
314         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
315
316 #resetTouch
317         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
318         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
319
320 #resetLicense
321         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
322         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
323         vconftool $GOPTION set -t int db/setting/roaming_network "0"
324
325 #resetNotification
326         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
327         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
331
332         # display content
333         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
338
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
343         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
344
345 #resetSecurity
346         rm -rf /opt/data/setting/set_info
347         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
348
349         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
350         vconftool $GOPTION set -t bool db/setting/simple_password "1"
351         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
352         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
353         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
354         vconftool $GOPTION set -t string db/setting/fmm/sender ""
355         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
356         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
357         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
358
359         # NOT USED NOW.
360         #vconftool $GOPTION set -t bool db/setting/rcs "0"
361
362         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
363         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
364         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
365         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
366         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
367 #resetMemory
368         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
369         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
370         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
373         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
375         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
376
377         # format - system server
378         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
379
380 #resetAbout
381         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
382         vconftool $GOPTION set -t string db/setting/selected_num ""
383 #resetMenuWidgets
384         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
385         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
386
387 #resetDevoptions
388         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
389
390 #resetDatausage
391         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
392         vconftool $GOPTION set -t int db/setting/data_limit "0"
393         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
394         vconftool $GOPTION set -t int db/setting/data_each_month "1"
395
396 #resetDisplay
397         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
398
399 #------------------------------------------
400 #create directory /opt/data/setting
401 if [ ! -d /opt/data/setting ]
402 then
403         mkdir -p /opt/data/setting
404 fi
405
406 # create setting.cfg at runtime right after installation
407 #/opt/apps/org.tizen.setting/bin/setting_conf_util
408 # After flashing, initialize timezone file
409 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
410 chown 5000:5000 /opt/data/setting -R
411 #------------------------------------------
412 sync
413
414 mkdir -p /usr/ug/bin/
415 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
416 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
417
418 %files -n org.tizen.setting
419 %manifest settings.manifest
420 %defattr(-,root,root,-)
421 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
422 %attr(-,app,app) %dir /opt/data/setting
423 /usr/apps/org.tizen.setting/bin/setting
424 /usr/apps/org.tizen.setting/bin/setting_conf_util
425 /opt/data/setting/setting.cfg
426
427 /usr/share/packages/org.tizen.setting.xml
428
429 /usr/share/icons/default/small/org.tizen.setting.png
430 /opt/share/settings/*
431 /usr/apps/org.tizen.setting/res/*
432 /usr/apps/org.tizen.setting/lib/*
433 /usr/apps/org.tizen.setting/data/*
434 /usr/ug/lib/*
435 /opt/data/setting/langlist.xml
436 /opt/data/setting/plugin-cfg/*
437 /opt/data/setting/plugin-xml/*
438 #/usr/apps/org.tizen.setting/bin/test_server