3b07a268dcd3d0c07dde3192883025aba2dc500c
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-content-media-content)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  pkgconfig(capi-network-wifi)
64 BuildRequires:  pkgconfig(capi-network-bluetooth)
65 BuildRequires:  pkgconfig(capi-network-nfc)
66 BuildRequires:  pkgconfig(ecore-evas)
67 BuildRequires:  pkgconfig(pkgmgr)
68 BuildRequires:  sysman-internal-devel
69 BuildRequires:  cmake
70 BuildRequires:  edje-tools
71 BuildRequires:  gettext-tools
72 %description
73 Setting application
74  BEAT UI, Setting application.
75
76
77 %prep
78 %setup -q
79
80 %build
81
82 %define PREFIX    "/usr/apps/org.tizen.setting"
83 %define RESDIR    "/usr/apps/org.tizen.setting/res"
84 %define DATADIR    "/usr/apps/org.tizen.setting/data"
85 CFLAGS+=" -fPIC";export CFLAGS
86 CXXFLAGS+=" -fPIC";export CFLAGS
87 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
88
89 %ifarch %{arm}
90         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
91 %else
92         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
93 %endif
94
95 make
96
97 %install
98 rm -rf %{buildroot}
99 %make_install
100
101 mkdir -p %{buildroot}/opt/data/setting
102
103 %clean
104
105 %post
106
107 # Set vconf values with -g/-u options
108 GOPTION="-g 6514"
109
110 #resetMenuscreen
111         # menuscreen app will take this vconf
112         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
113
114
115 #resetFlightmode
116         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
117
118 #resetNetwork
119         vconftool $GOPTION set -t int db/setting/select_network "0"
120         vconftool $GOPTION set -t int db/setting/select_network_act "0"
121         vconftool $GOPTION set -t int db/setting/network_mode "0"
122         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
123         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
124
125 #resetUsbConnectivity
126         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
127         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
128         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
129         vconftool $GOPTION set -t bool db/setting/debug_mode "0" -f
130
131 #resetSound
132         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
133         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
134
135         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
136         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
137
138         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
139         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
140         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
141         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
142
143         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
144         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
145         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
146
147         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
148         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
149
150         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
151         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
152
153         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
154         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
155         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
156         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
157
158 #resetWallpaper
159         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
160         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
161
162 #resetTilt
163         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
164         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
165         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
166         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
167
168 #resetPanning
169         vconftool $GOPTION set -t bool db/setting/use_panning "0"
170         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
171         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
172         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
173
174 #resetDoubleTap
175         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
176
177 #resetShake
178         vconftool $GOPTION set -t bool db/setting/use_shake "1"
179
180 #resetPickup
181         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
182         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
183
184 #resetTurnOver
185         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
186
187 #resetMotions
188         vconftool $GOPTION set -t bool db/setting/motion_active "1"
189         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
190         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
191         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
192
193 #resetDisplay
194         #backlight
195 %ifarch %{arm}
196         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
197 %else
198         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
199 %endif
200         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
201
202         #brightness
203         vconftool $GOPTION set -t int db/setting/Brightness "-1"
204         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
205
206         #battery
207         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
208         #launch
209         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
210
211         #smart screen
212         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
213         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
214         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
215         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
216         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
217
218 #resetPowersaving
219         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
220         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
221         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
222
223         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
224         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
225         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
229
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
231         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
232         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
233         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
234
235         #v0.4
236         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
237         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
240
241 #resetFont
242         vconftool $GOPTION set -t int db/setting/font_size "1"
243         vconftool $GOPTION set -t int db/setting/font_type "0"
244
245 #resetRotationLock
246         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
247         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
248 #resetTimeAndData
249 %ifarch %{arm}
250         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
251 %else
252         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
253 %endif
254
255         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
256         vconftool $GOPTION set -t int db/setting/date_format "0"
257         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
258
259         vconftool $GOPTION set -t string db/setting/timezone "+9"
260         # to be removed
261         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
262
263         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
264
265         #if [ -f /opt/etc/localtime ]
266         #then
267         rm -f /opt/etc/localtime
268         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
269         #fi
270
271
272 #resetAccessibility
273         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
274         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
275         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
276         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
277         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
278         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
279         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
280
281         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
282         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
283         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
284         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
285
286         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
287         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
288         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
289         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
290
291         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
292         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
293         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
294         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
295
296 #Driving Mode
297         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
298         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
299         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
300         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
303         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
305
306 #resetLanguageAndRegion
307         vconftool $GOPTION set -t int db/setting/lang "9"
308         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
309         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
310
311 #resetViewtype
312         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
313         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
314
315 #resetTouch
316         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
317         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
318
319 #resetLicense
320         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
321         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
322         vconftool $GOPTION set -t int db/setting/roaming_network "0"
323
324 #resetNotification
325         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
326         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
327         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
330
331         # display content
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
333         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
334         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
337
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
340         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
343
344 #resetSecurity
345         rm -rf /opt/data/setting/set_info
346         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
347
348         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
349         vconftool $GOPTION set -t bool db/setting/simple_password "1"
350         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
351         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
352         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
353         vconftool $GOPTION set -t string db/setting/fmm/sender ""
354         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
355         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
356         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
357
358         # NOT USED NOW.
359         #vconftool $GOPTION set -t bool db/setting/rcs "0"
360
361         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
362         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
363         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
364         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
365         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
366 #resetMemory
367         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
368         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
369         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
370         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
373         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
375
376         # format - system server
377         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
378
379 #resetAbout
380         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
381         vconftool $GOPTION set -t string db/setting/selected_num ""
382 #resetMenuWidgets
383         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
384         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
385
386 #resetDevoptions
387         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
388
389 #resetDatausage
390         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
391         vconftool $GOPTION set -t int db/setting/data_limit "0"
392         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
393         vconftool $GOPTION set -t int db/setting/data_each_month "1"
394
395 #resetDisplay
396         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
397
398 #------------------------------------------
399 #create directory /opt/data/setting
400 if [ ! -d /opt/data/setting ]
401 then
402         mkdir -p /opt/data/setting
403 fi
404
405 # create setting.cfg at runtime right after installation
406 #/opt/apps/org.tizen.setting/bin/setting_conf_util
407 # After flashing, initialize timezone file
408 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
409 chown 5000:5000 /opt/data/setting -R
410 #------------------------------------------
411 sync
412
413 mkdir -p /usr/ug/bin/
414 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
415
416 %files -n org.tizen.setting
417 %manifest settings.manifest
418 %defattr(-,root,root,-)
419 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
420 %attr(-,app,app) %dir /opt/data/setting
421 /usr/apps/org.tizen.setting/bin/setting
422 /usr/apps/org.tizen.setting/bin/setting_conf_util
423 /opt/data/setting/setting.cfg
424
425 /usr/share/packages/org.tizen.setting.xml
426
427 /usr/share/icons/default/small/org.tizen.setting.png
428 /opt/share/settings/*
429 /usr/apps/org.tizen.setting/res/*
430 /usr/apps/org.tizen.setting/lib/*
431 /usr/apps/org.tizen.setting/data/*
432 /usr/ug/lib/*
433 /opt/data/setting/langlist.xml
434 /opt/data/setting/plugin-cfg/*
435 /opt/data/setting/plugin-xml/*
436 #/usr/apps/org.tizen.setting/bin/test_server