remove org.tizen.phone dep
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
1 Name:       org.tizen.setting
2 Summary:    Setting application
3 Version:    0.1.87
4 Release:    99
5 Group:      misc
6 License:    samsung
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(appcore-common)
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(vconf)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(utilX)
14 BuildRequires:  pkgconfig(devman)
15 BuildRequires:  pkgconfig(haptic)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(mm-sound)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(ui-gadget-1)
20 BuildRequires:  pkgconfig(json-glib-1.0)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(pmapi)
25 BuildRequires:  pkgconfig(ecore-input)
26 BuildRequires:  pkgconfig(eina)
27 BuildRequires:  pkgconfig(icu-i18n)
28 BuildRequires:  pkgconfig(ail)
29 BuildRequires:  pkgconfig(sysman)
30 BuildRequires:  pkgconfig(glib-2.0)
31 BuildRequires:  pkgconfig(gthread-2.0)
32 BuildRequires:  pkgconfig(dbus-glib-1)
33 BuildRequires:  pkgconfig(ecore-imf)
34 BuildRequires:  pkgconfig(ecore-x)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(icu-io)
38 BuildRequires:  pkgconfig(icu-le)
39 BuildRequires:  pkgconfig(icu-lx)
40 BuildRequires:  pkgconfig(icu-uc)
41 BuildRequires:  pkgconfig(ewebkit2)
42 BuildRequires:  pkgconfig(evas)
43 BuildRequires:  pkgconfig(edje)
44 BuildRequires:  pkgconfig(mm-player)
45 BuildRequires:  pkgconfig(capi-network-connection)
46 #BuildRequires:  pkgconfig(network)
47 #BuildRequires:  pkgconfig(security-server)
48 BuildRequires:  pkgconfig(svi)
49 BuildRequires:  pkgconfig(appsvc)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(notification)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(capi-system-runtime-info)
54 BuildRequires:  pkgconfig(capi-media-player)
55 BuildRequires:  pkgconfig(capi-media-sound-manager)
56 BuildRequires:  pkgconfig(capi-content-media-content)
57 BuildRequires:  pkgconfig(capi-system-device)
58 BuildRequires:  pkgconfig(capi-appfw-application)
59 BuildRequires:  pkgconfig(capi-appfw-app-manager)
60 BuildRequires:  pkgconfig(capi-system-sensor)
61 BuildRequires:  pkgconfig(capi-system-info)
62 BuildRequires:  pkgconfig(capi-system-system-settings)
63 BuildRequires:  pkgconfig(capi-network-wifi)
64 BuildRequires:  pkgconfig(capi-network-bluetooth)
65 BuildRequires:  pkgconfig(capi-network-nfc)
66 BuildRequires:  pkgconfig(ecore-evas)
67 BuildRequires:  pkgconfig(pkgmgr)
68 BuildRequires:  sysman-internal-devel
69 BuildRequires:  cmake
70 BuildRequires:  edje-tools
71 BuildRequires:  gettext-tools
72 #Requires: org.tizen.phone
73 Requires: ug-bluetooth-efl
74 %description
75 Setting application
76  BEAT UI, Setting application.
77
78
79 %prep
80 %setup -q
81
82 %build
83
84 %define PREFIX    "/usr/apps/org.tizen.setting"
85 %define RESDIR    "/usr/apps/org.tizen.setting/res"
86 %define DATADIR    "/usr/apps/org.tizen.setting/data"
87 CFLAGS+=" -fPIC";export CFLAGS
88 CXXFLAGS+=" -fPIC";export CFLAGS
89 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
90
91 %ifarch %{arm}
92         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
93 %else
94         cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
95 %endif
96
97 make
98
99 %install
100 rm -rf %{buildroot}
101 %make_install
102
103 mkdir -p %{buildroot}/opt/data/setting
104
105 %clean
106
107 %post
108
109 # Set vconf values with -g/-u options
110 GOPTION="-g 6514"
111
112 #resetMenuscreen
113         # menuscreen app will take this vconf
114         #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
115
116
117 #resetFlightmode
118         vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
119
120 #resetNetwork
121         vconftool $GOPTION set -t int db/setting/select_network "0"
122         vconftool $GOPTION set -t int db/setting/select_network_act "0"
123         vconftool $GOPTION set -t int db/setting/network_mode "0"
124         vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
125         vconftool $GOPTION set -t bool db/setting/data_roaming "1"
126
127 #resetUsbConnectivity
128         vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
129         vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
130         vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
131         vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
132
133 #resetSound
134         DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
135         DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
136
137         vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
138         vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
139
140         vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
141         vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
142         vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
143         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
144
145         vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
146         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
147         vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
148
149         vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
150         vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
151
152         vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
153         vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
154
155         vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
156         vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
157         vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
158         vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
159
160 #resetWallpaper
161         vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
162         vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
163
164 #resetTilt
165         vconftool $GOPTION set -t bool db/setting/use_tilt "1"
166         vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
167         vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
168         vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
169
170 #resetPanning
171         vconftool $GOPTION set -t bool db/setting/use_panning "0"
172         vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
173         vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
174         vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
175
176 #resetDoubleTap
177         vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
178
179 #resetShake
180         vconftool $GOPTION set -t bool db/setting/use_shake "1"
181
182 #resetPickup
183         vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
184         vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
185
186 #resetTurnOver
187         vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
188
189 #resetMotions
190         vconftool $GOPTION set -t bool db/setting/motion_active "1"
191         vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
192         vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
193         vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
194
195 #resetDisplay
196         #backlight
197 %ifarch %{arm}
198         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
199 %else
200         vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
201 %endif
202         vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
203
204         #brightness
205         vconftool $GOPTION set -t int db/setting/Brightness "-1"
206         vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
207
208         #battery
209         vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
210         #launch
211         #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
212
213         #smart screen
214         vconftool $GOPTION set -t int db/pm/smartstay_status "0"
215         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
216         vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
217         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
218         vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
219
220 #resetPowersaving
221         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
222         vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
223         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
224
225         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
226         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
227         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
228         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
229         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
230         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
231
232         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
233         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
234         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
235         vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
236
237         #v0.4
238         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
239         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
240         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
241         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
242
243 #resetFont
244         vconftool $GOPTION set -t int db/setting/font_size "1"
245         vconftool $GOPTION set -t int db/setting/font_type "0"
246
247 #resetRotationLock
248         vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
249         vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
250         #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
251 #resetTimeAndData
252 %ifarch %{arm}
253         vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
254 %else
255         vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
256 %endif
257
258         vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
259         vconftool $GOPTION set -t int db/setting/date_format "0"
260         vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
261
262         vconftool $GOPTION set -t string db/setting/timezone "+9"
263         # to be removed
264         vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
265
266         vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
267
268         #if [ -f /opt/etc/localtime ]
269         #then
270         rm -f /opt/etc/localtime
271         ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
272         #fi
273
274
275 #resetAccessibility
276         vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
277         vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
278         vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
279         vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
280         #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
281         vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
282         vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
283
284         vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
285         vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
286         vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
287         vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
288
289         vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
290         vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
291         vconftool $GOPTION set -t int db/ciss/answering_mode "0"
292         vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
293
294         vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
295         vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
296         vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
297         vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
298
299 #Driving Mode
300         vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
301         vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
302         vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
303         vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
304         vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
305         vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
306         vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
307         vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
308
309 #resetLanguageAndRegion
310         vconftool $GOPTION set -t int db/setting/lang "9"
311         vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
312         vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
313
314 #resetViewtype
315         #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
316         #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
317
318 #resetTouch
319         #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
320         #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
321
322 #resetLicense
323         vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
324         vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
325         vconftool $GOPTION set -t int db/setting/roaming_network "0"
326
327 #resetNotification
328         vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
329         vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
330         vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
331         vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
332         vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
333
334         # display content
335         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
336         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
337         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
338         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
339         vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
340
341         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
342         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
343         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
344         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
345         vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
346
347 #resetSecurity
348         rm -rf /opt/data/setting/set_info
349         #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
350
351         vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
352         vconftool $GOPTION set -t bool db/setting/simple_password "1"
353         vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
354         vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
355         vconftool $GOPTION set -t string db/setting/fmm/recipients ""
356         vconftool $GOPTION set -t string db/setting/fmm/sender ""
357         vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
358         vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
359         vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
360
361         # NOT USED NOW.
362         #vconftool $GOPTION set -t bool db/setting/rcs "0"
363
364         vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
365         vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
366         vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
367         vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
368         vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
369 #resetMemory
370         vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
371         vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
372         vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
373         vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
374         vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
375         vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
376         vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
377         vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
378
379         # format - system server
380         #vconftool $GOPTION -i set -t int memory/mmc/format "0"
381
382 #resetAbout
383         vconftool $GOPTION set -t string db/setting/device_name "Magnolia"
384         vconftool $GOPTION set -t string db/setting/selected_num ""
385 #resetMenuWidgets
386         vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
387         #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
388
389 #resetDevoptions
390         vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
391
392 #resetDatausage
393         vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
394         vconftool $GOPTION set -t int db/setting/data_limit "0"
395         vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
396         vconftool $GOPTION set -t int db/setting/data_each_month "1"
397
398 #resetDisplay
399         vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
400
401 #------------------------------------------
402 #create directory /opt/data/setting
403 if [ ! -d /opt/data/setting ]
404 then
405         mkdir -p /opt/data/setting
406 fi
407
408 # create setting.cfg at runtime right after installation
409 #/opt/apps/org.tizen.setting/bin/setting_conf_util
410 # After flashing, initialize timezone file
411 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
412 chown 5000:5000 /opt/data/setting -R
413 #------------------------------------------
414 sync
415
416 mkdir -p /usr/ug/bin/
417 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
418 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
419
420 %files -n org.tizen.setting
421 %manifest settings.manifest
422 %defattr(-,root,root,-)
423 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
424 %attr(-,app,app) %dir /opt/data/setting
425 /usr/apps/org.tizen.setting/bin/setting
426 /usr/apps/org.tizen.setting/bin/setting_conf_util
427 /opt/data/setting/setting.cfg
428
429 /usr/share/packages/org.tizen.setting.xml
430
431 /usr/share/icons/default/small/org.tizen.setting.png
432 /opt/share/settings/*
433 /usr/apps/org.tizen.setting/res/*
434 /usr/apps/org.tizen.setting/lib/*
435 /usr/apps/org.tizen.setting/data/*
436 /usr/ug/lib/*
437 /opt/data/setting/langlist.xml
438 /opt/data/setting/plugin-cfg/*
439 /opt/data/setting/plugin-xml/*
440 #/usr/apps/org.tizen.setting/bin/test_server