1 Name: org.tizen.setting
2 Summary: Setting application
6 License: Flora License, Version 1
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(appcore-common)
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(vconf)
12 BuildRequires: pkgconfig(tapi)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(devman)
15 BuildRequires: pkgconfig(haptic)
16 BuildRequires: pkgconfig(bluetooth-api)
17 BuildRequires: pkgconfig(mm-sound)
18 BuildRequires: pkgconfig(openssl)
19 BuildRequires: pkgconfig(ui-gadget-1)
20 BuildRequires: pkgconfig(json-glib-1.0)
21 BuildRequires: pkgconfig(libxml-2.0)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(aul)
24 BuildRequires: pkgconfig(pmapi)
25 BuildRequires: pkgconfig(ecore-input)
26 BuildRequires: pkgconfig(eina)
27 BuildRequires: pkgconfig(icu-i18n)
28 BuildRequires: pkgconfig(ail)
29 BuildRequires: pkgconfig(sysman)
30 BuildRequires: pkgconfig(glib-2.0)
31 BuildRequires: pkgconfig(gthread-2.0)
32 BuildRequires: pkgconfig(dbus-glib-1)
33 BuildRequires: pkgconfig(ecore-imf)
34 BuildRequires: pkgconfig(ecore-x)
35 BuildRequires: pkgconfig(ecore)
36 BuildRequires: pkgconfig(ecore-file)
37 BuildRequires: pkgconfig(icu-io)
38 BuildRequires: pkgconfig(icu-le)
39 BuildRequires: pkgconfig(icu-lx)
40 BuildRequires: pkgconfig(icu-uc)
41 BuildRequires: pkgconfig(ewebkit2)
42 BuildRequires: pkgconfig(evas)
43 BuildRequires: pkgconfig(edje)
44 BuildRequires: pkgconfig(mm-player)
45 BuildRequires: pkgconfig(capi-network-connection)
46 #BuildRequires: pkgconfig(network)
47 #BuildRequires: pkgconfig(security-server)
48 BuildRequires: pkgconfig(svi)
49 BuildRequires: pkgconfig(feedback)
50 BuildRequires: pkgconfig(appsvc)
51 BuildRequires: pkgconfig(notification)
52 BuildRequires: pkgconfig(pango)
53 BuildRequires: pkgconfig(capi-system-runtime-info)
54 BuildRequires: pkgconfig(capi-media-player)
55 BuildRequires: pkgconfig(capi-media-sound-manager)
56 BuildRequires: pkgconfig(capi-content-media-content)
57 BuildRequires: pkgconfig(capi-system-device)
58 BuildRequires: pkgconfig(capi-appfw-application)
59 BuildRequires: pkgconfig(capi-appfw-app-manager)
60 BuildRequires: pkgconfig(capi-system-sensor)
61 BuildRequires: pkgconfig(capi-system-info)
62 BuildRequires: pkgconfig(capi-system-system-settings)
63 BuildRequires: pkgconfig(capi-network-wifi)
64 BuildRequires: pkgconfig(capi-network-bluetooth)
65 BuildRequires: pkgconfig(capi-network-tethering)
66 BuildRequires: pkgconfig(capi-network-nfc)
67 BuildRequires: pkgconfig(capi-security-privacy-manager)
68 BuildRequires: pkgconfig(privacy-manager-client)
69 BuildRequires: pkgconfig(privacy-manager-server)
70 BuildRequires: pkgconfig(ecore-evas)
71 BuildRequires: pkgconfig(pkgmgr)
72 BuildRequires: pkgconfig(pkgmgr-info)
73 BuildRequires: sysman-internal-devel
75 BuildRequires: edje-tools
76 BuildRequires: gettext-tools
77 #Requires: org.tizen.phone
78 Requires: ug-bluetooth-efl
81 BEAT UI, Setting application.
89 %define PREFIX "/usr/apps/org.tizen.setting"
90 %define RESDIR "/usr/apps/org.tizen.setting/res"
91 %define DATADIR "/usr/apps/org.tizen.setting/data"
92 CFLAGS+=" -fPIC";export CFLAGS
93 CXXFLAGS+=" -fPIC";export CFLAGS
94 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
97 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=arm
99 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
108 mkdir -p %{buildroot}/opt/data/setting
114 # Set vconf values with -g/-u options
118 # menuscreen app will take this vconf
119 #vconftool $GOPTION set -t string db/setting/menuscreen/package_name "com.samsung.cluster-home"
123 vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
126 vconftool $GOPTION set -t int db/setting/select_network "0"
127 vconftool $GOPTION set -t int db/setting/select_network_act "0"
128 vconftool $GOPTION set -t int db/setting/network_mode "0"
129 vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
130 vconftool $GOPTION set -t bool db/setting/data_roaming "0"
132 #resetUsbConnectivity
133 vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
134 vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
135 vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
136 vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
137 vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i
140 DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
141 DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
143 vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
144 vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
146 vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
147 vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
148 vconftool $GOPTION set -t int db/setting/sound/media/sound_volume "7"
149 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/sound_volume "5"
151 vconftool $GOPTION set -t int db/setting/sound/noti/vibration_level "5"
152 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level "3"
153 vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
155 vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
156 vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}"
157 vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
159 vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path "${DEFAULT_NOTI_TONE}"
160 vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path "${DEFAULT_NOTI_TONE}"
161 vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type "0"
163 vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path "${DEFAULT_NOTI_TONE}"
164 vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type "0"
165 vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
166 vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
169 vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
170 vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
173 vconftool $GOPTION set -t bool db/setting/motion_active "1"
177 # Set backlight timeout to dim display on all platforms except emulator
178 # 0 sec : unlimited time
181 vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
183 vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
186 vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
189 vconftool $GOPTION set -t int db/setting/Brightness "-1"
190 vconftool $GOPTION set -t int db/setting/brightness_automatic "0"
193 vconftool $GOPTION set -t bool db/setting/battery_percentage "0"
195 #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
198 vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
199 vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
202 vconftool $GOPTION set -t int db/setting/font_size "1"
203 vconftool $GOPTION set -t int db/setting/font_type "0"
206 vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
207 vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
208 #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
211 vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
213 vconftool $GOPTION set -t bool db/setting/automatic_time_update "0"
216 vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
217 vconftool $GOPTION set -t int db/setting/date_format "0"
218 vconftool $GOPTION set -t int db/setting/weekofday_format "0"
220 #-----------------------------------------------------------------
222 # MOCK IMPLEMENTATION FOR API COMPATIBILITY
223 # NEED TO CHECK THE KEY WITH THE CALENDAR APP
224 #-----------------------------------------------------------------
225 vconftool $GOPTION set -t int db/setting/weekofday_format "0"
227 vconftool $GOPTION set -t string db/setting/timezone "+9"
229 vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
231 vconftool $GOPTION set -t string db/setting/timezone_id "Asia/Seoul"
233 #if [ -f /opt/etc/localtime ]
235 rm -f /opt/etc/localtime
236 ln -s /usr/share/zoneinfo/Asia/Seoul /opt/etc/localtime
241 vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
242 vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
243 vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
244 vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
245 #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
246 vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
247 vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
248 vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
250 #-----------------------------------------------------------------
252 # NOT SUPPORTED BUT ADDED FOR API COMPATIBILITY
253 # temp key for screen reader & speech rate
254 #-----------------------------------------------------------------
255 vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
256 vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
258 #resetLanguageAndRegion
259 vconftool $GOPTION set -t int db/setting/lang "9"
260 vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
261 vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
264 #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
265 #vconftool $GOPTION set -t int db/taskswitcher/viewtype "0"
268 #vconftool $GOPTION set -t int db/setting/vib_feedback "3"
269 #vconftool $GOPTION set -t bool db/setting/touch_panel_autolock "0"
272 vconftool $GOPTION set -t bool db/setting/transaction_tracking "0"
273 vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
274 vconftool $GOPTION set -t int db/setting/roaming_network "0"
277 rm -rf /opt/data/setting/set_info
278 #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
279 vconftool $GOPTION set -t int db/setting/screen_lock_type "5" -f
280 vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen"
283 #vconftool $GOPTION set -t bool db/setting/rcs "0"
286 vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
287 vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
288 vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
289 vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
290 vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
291 vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
292 vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
293 vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
295 # format - system server
296 #vconftool $GOPTION -i set -t int memory/mmc/format "0"
299 vconftool $GOPTION set -t string db/setting/device_name "Tizen"
300 vconftool $GOPTION set -t string db/setting/selected_num ""
302 vconftool $GOPTION -i set -t int memory/setting/font_changed "0"
303 #vconftool $GOPTION -i set -t int memory/mobile_hotspot/skin_changed "0"
306 vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
309 vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
311 #------------------------------------------
312 #create directory /opt/data/setting
313 if [ ! -d /opt/data/setting ]
315 mkdir -p /opt/data/setting
318 # create setting.cfg at runtime right after installation
319 #/opt/apps/org.tizen.setting/bin/setting_conf_util
320 # After flashing, initialize timezone file
321 /usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
322 chown 5000:5000 /opt/data/setting -R
323 #------------------------------------------
326 mkdir -p /usr/ug/bin/
327 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
328 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
329 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
330 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-privacy-efl
332 %files -n org.tizen.setting
333 %manifest settings.manifest
334 %defattr(-,root,root,-)
335 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
336 %attr(-,app,app) %dir /opt/data/setting
337 /usr/apps/org.tizen.setting/bin/setting
338 /usr/apps/org.tizen.setting/bin/setting_conf_util
339 /opt/data/setting/setting.cfg
341 /usr/share/packages/org.tizen.setting.xml
342 /opt/etc/smack/accesses.d/org.tizen.setting.rule
344 /usr/share/icons/default/small/org.tizen.setting.png
345 /opt/share/settings/*
346 /usr/apps/org.tizen.setting/res/*
347 /usr/apps/org.tizen.setting/lib/*
348 /usr/apps/org.tizen.setting/data/*
350 /opt/data/setting/langlist.xml
351 /opt/data/setting/plugin-cfg/*
352 /opt/data/setting/plugin-xml/*
353 #/usr/apps/org.tizen.setting/bin/test_server
354 /opt/media/Open_Source_Announcement.html