Profile Configuration.
[profile/tv/apps/native/screen-reader.git] / packaging / org.tizen.screen-reader.spec
1 %define AppInstallPath /usr/apps/%{name}
2 %define Exec screen-reader
3
4
5 Name:       org.tizen.screen-reader
6 Summary:    Screen Reader Assistive Technology
7 Version:    0.0.3
8 Release:    1
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  at-spi2-core
13 BuildRequires:  at-spi2-core-devel
14 BuildRequires:  cmake
15 BuildRequires:  pkgconfig(appcore-efl)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-x)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(eldbus)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(capi-media-tone-player)
22 BuildRequires:  pkgconfig(capi-system-device)
23 BuildRequires:  tts
24 BuildRequires:  tts-devel
25 BuildRequires:  vconf
26 BuildRequires:  gettext-tools
27 BuildRequires:  pkgconfig(check)
28 BuildRequires:  pkgconfig(capi-network-bluetooth)
29 BuildRequires:  pkgconfig(notification)
30 BuildRequires:  pkgconfig(capi-network-wifi)
31 #%if "%{?tizen_profile_name}" != "tv"
32 BuildRequires:  pkgconfig(tapi)
33 #%endif
34
35 %description
36 An utility library for developers of the menu screen.
37
38 %prep
39 %setup -q
40
41 %build
42 rm -rf CMakeFiles CMakeCache.txt
43
44 %if "%{?tizen_profile_name}" != "tv"
45         export SEC_FEATURE_TAPI_ENABLE="1"
46 %else
47         export SEC_FEATURE_TAPI_ENABLE="0"
48 %endif
49
50 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" \
51         -DCMAKE_TARGET="%{Exec}" \
52         -DCMAKE_PACKAGE="%{name}" \
53         -DSEC_FEATURE_TAPI_ENABLE=${SEC_FEATURE_TAPI_ENABLE}
54
55 make %{?jobs:-j%jobs} \
56 2>&1 | sed \
57 -e 's%^.*: error: .*$%\x1b[37;41m&\x1b[m%' \
58 -e 's%^.*: warning: .*$%\x1b[30;43m&\x1b[m%'
59 export LD_LIBRARY_PATH=/emul/ia32-linux/lib:/emul/ia32-linux/usr/lib:$LD_LIBRARY_PATH
60 #make test
61
62 %install
63 rm -rf %{buildroot}
64 %make_install
65
66 %post 
67 /sbin/ldconfig
68
69 %postun -p /sbin/ldconfig
70
71 %files
72 %manifest org.tizen.screen-reader.manifest
73 %{AppInstallPath}/bin/screen-reader
74 %{AppInstallPath}/res/icons/screen-reader.png
75 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
76 /opt/share/packages/%{name}.xml