[LICENSE] change to Flora-1.1 license
[profile/tv/apps/native/screen-reader.git] / packaging / org.tizen.screen-reader.spec
1 %define AppInstallPath /usr/apps/%{name}
2 %define Exec screen-reader
3
4
5 Name:       org.tizen.screen-reader
6 Summary:    Screen Reader Assistive Technology
7 Version:    0.0.3
8 Release:    1
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  at-spi2-core
13 BuildRequires:  at-spi2-core-devel
14 BuildRequires:  cmake
15 BuildRequires:  pkgconfig(appcore-efl)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-x)
18 BuildRequires:  pkgconfig(eina)
19 BuildRequires:  pkgconfig(eldbus)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(capi-media-tone-player)
22 BuildRequires:  pkgconfig(capi-system-device)
23 BuildRequires:  tts
24 BuildRequires:  tts-devel
25 BuildRequires:  vconf
26 BuildRequires:  gettext-tools
27 BuildRequires:  pkgconfig(check)
28 BuildRequires:  pkgconfig(capi-network-bluetooth)
29 BuildRequires:  pkgconfig(tapi)
30 BuildRequires:  pkgconfig(notification)
31 BuildRequires:  pkgconfig(capi-network-wifi)
32
33 %description
34 An utility library for developers of the menu screen.
35
36 %prep
37 %setup -q
38
39 %build
40 %if "%{?tizen_profile_name}" == "tv"
41     export CFLAGS+=" -DSCREEN_READER_TV"
42 %endif
43
44 rm -rf CMakeFiles CMakeCache.txt && cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}"
45 make %{?jobs:-j%jobs} \
46 2>&1 | sed \
47 -e 's%^.*: error: .*$%\x1b[37;41m&\x1b[m%' \
48 -e 's%^.*: warning: .*$%\x1b[30;43m&\x1b[m%'
49 export LD_LIBRARY_PATH=/emul/ia32-linux/lib:/emul/ia32-linux/usr/lib:$LD_LIBRARY_PATH
50 #make test
51
52 %install
53 rm -rf %{buildroot}
54 %make_install
55
56 %post 
57 /sbin/ldconfig
58
59 %postun -p /sbin/ldconfig
60
61 %files
62 %manifest org.tizen.screen-reader.manifest
63 %{AppInstallPath}/bin/screen-reader
64 %{AppInstallPath}/res/icons/screen-reader.png
65 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
66 /opt/share/packages/%{name}.xml