cleanup
[profile/tv/apps/native/screen-reader.git] / packaging / org.tizen.screen-reader.spec
1 Name:       org.tizen.screen-reader
2 Summary:    Empty app
3 Version:    0.0.1
4 Release:    1
5 Group:      Applications/Core Applications
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  at-spi2-core
10 BuildRequires:  at-spi2-core-devel
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(capi-appfw-application)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(bundle)
16 BuildRequires:  tts
17 BuildRequires:  tts-devel
18 BuildRequires:  vconf
19 BuildRequires:  pkgconfig(check)
20
21
22 %define AppInstallPath /usr/apps/%{name}
23 %define Exec screen-reader
24
25
26 %description
27 An utility library for developers of the menu screen.
28
29 %prep
30 %setup -q
31
32 %build
33 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}"
34 make %{?jobs:-j%jobs} \
35 2>&1 | sed \
36 -e 's%^.*: error: .*$%\x1b[37;41m&\x1b[m%' \
37 -e 's%^.*: warning: .*$%\x1b[30;43m&\x1b[m%'
38 export LD_LIBRARY_PATH=/emul/ia32-linux/lib:/emul/ia32-linux/usr/lib:$LD_LIBRARY_PATH
39 make test
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %post 
46 /sbin/ldconfig
47 vconftool set -t string db/setting/accessibility/language "en_US"
48 vconftool set -t int db/setting/accessibility/information_level 2
49 vconftool set -t int db/setting/accessibility/voice 1
50 vconftool set -t string db/setting/accessibility/tracking_signal "focused"
51
52 %postun -p /sbin/ldconfig
53
54 %files
55 %manifest org.tizen.screen-reader.manifest
56 %{AppInstallPath}/bin/screen-reader
57 %{AppInstallPath}/res/icons/screen-reader.png
58 /usr/share/packages/%{name}.xml