update spec file for license file
[apps/home/pwlock.git] / packaging / org.tizen.pwlock.spec
1 %define PREFIX /usr/apps/org.tizen.pwlock
2
3 Name:       org.tizen.pwlock
4 Summary:    Password Lock application
5 Version:    0.4.0
6 Release:    1
7 Group:      TBD
8 License:    TBD
9 Source0:    %{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig(elementary)
12 BuildRequires: pkgconfig(ui-gadget-1)
13 BuildRequires: pkgconfig(x11)
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(appcore-efl)
17 BuildRequires: pkgconfig(tapi)
18 BuildRequires: pkgconfig(utilX)
19 BuildRequires: pkgconfig(openssl)
20 BuildRequires: pkgconfig(aul)
21 BuildRequires: pkgconfig(accounts-svc)
22 BuildRequires: pkgconfig(appsvc)
23 BuildRequires: pkgconfig(sysman)
24 BuildRequires: pkgconfig(capi-base-common)
25 BuildRequires: pkgconfig(iniparser)
26 BuildRequires: pkgconfig(capi-system-info)
27 BuildRequires: pkgconfig(libxml-2.0)
28 BuildRequires: gettext
29 BuildRequires: cmake
30 BuildRequires: edje-tools
31 Requires(post): /usr/bin/vconftool
32
33 %description
34 Password lock application.
35
36 %prep
37 %setup -q
38
39 %build
40 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed";export LDFLAGS
41 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
42 # cmake does not have a good dependency and make parallel will fail
43 # make %{?jobs:-j%jobs}
44 make
45
46 %install
47 %make_install
48 mkdir -p %{buildroot}/usr/share/license
49 cp LICENSE.Flora %{buildroot}/usr/share/license/%{name}
50
51 %post
52 GOPTION="-g 6514"
53 vconftool $GOPTION set -t bool db/pwlock/first_boot "1" -f
54 vconftool $GOPTION set -t int memory/pwlock/state "0" -f -i
55
56 %files
57 %manifest org.tizen.pwlock.manifest 
58 /etc/smack/accesses.d/org.tizen.pwlock.rule
59 %defattr(-,root,root,-)
60 %attr(4755,root,root) /usr/apps/org.tizen.pwlock/bin/pwlock
61 /usr/apps/org.tizen.pwlock/bin/pwlock
62 /usr/apps/org.tizen.pwlock/res/locale/*/LC_MESSAGES/pwlock.mo
63 /usr/share/packages/org.tizen.pwlock.xml
64 /usr/apps/org.tizen.pwlock/res/langlist.xml
65 /usr/apps/org.tizen.pwlock/res/edje/*.edj
66 /usr/apps/org.tizen.pwlock/res/images/*.png
67 /usr/share/license/%{name}
68