bc3cc70b545623c34625abb1e4029ba941a19e02
[apps/core/preloaded/message-app.git] / packaging / org.tizen.message.spec
1 Name:       org.tizen.message
2 Summary:    message application
3 Version:    0.8.30
4 Release:    1
5 Group:      devel
6 License:    Samsung
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /bin/touch
9 Requires(post): /usr/bin/vconftool
10 Requires: pkgmgr
11 BuildRequires:  pkgconfig(appsvc)
12 BuildRequires:  pkgconfig(bundle)
13 BuildRequires:  pkgconfig(capi-appfw-application)
14 BuildRequires:  pkgconfig(capi-appfw-app-manager)
15 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
16 BuildRequires:  pkgconfig(capi-media-sound-manager)
17 BuildRequires:  pkgconfig(capi-system-info)
18 BuildRequires:  pkgconfig(capi-system-system-settings)
19 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
20 BuildRequires:  pkgconfig(capi-media-image-util)
21 BuildRequires:  pkgconfig(capi-media-player)
22 BuildRequires:  pkgconfig(capi-content-media-content)
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(drm-client)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(ecore)
28 BuildRequires:  pkgconfig(ecore-x)
29 BuildRequires:  pkgconfig(ecore-input)
30 BuildRequires:  pkgconfig(ecore-imf)
31 BuildRequires:  pkgconfig(ecore-file)
32 BuildRequires:  pkgconfig(ecore-evas)
33 BuildRequires:  pkgconfig(eina)
34 BuildRequires:  pkgconfig(evas)
35 BuildRequires:  pkgconfig(glib-2.0)
36 BuildRequires:  pkgconfig(heynoti)
37 BuildRequires:  pkgconfig(icu-i18n)
38 BuildRequires:  pkgconfig(libexif)
39 BuildRequires:  pkgconfig(msg-service)
40 BuildRequires:  pkgconfig(mm-common)
41 BuildRequires:  pkgconfig(mm-player)
42 BuildRequires:  pkgconfig(mm-session)
43 BuildRequires:  pkgconfig(syspopup-caller)
44 BuildRequires:  pkgconfig(status)
45 BuildRequires:  pkgconfig(tapi)
46 BuildRequires:  pkgconfig(ui-gadget-1)
47 BuildRequires:  pkgconfig(utilX)
48 BuildRequires:  libug-contacts-devel
49 BuildRequires:  cmake
50 BuildRequires:  edje-tools
51 BuildRequires:  gettext-tools
52
53 %description
54 message application.
55
56 %prep
57 %setup -q
58
59 %build
60
61 %define PREFIX    "/usr/apps/org.tizen.message"
62 %define RESDIR    "/usr/apps/org.tizen.message/res"
63 %define DATADIR    "/opt/usr/apps/org.tizen.message/data"
64 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
65 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DCMAKE_INSTALL_DATADIR=%{DATADIR}
66 # CMakeLists.Txt needs to be fixed for parallel build to work
67 make #%{?jobs:-j%jobs}
68
69 %install
70 rm -rf %{buildroot}
71 %make_install
72
73 %post
74 vconftool set -t int db/private/org.tizen.message/font_size 1 -u 5000 -f
75 vconftool set -t int db/private/org.tizen.message/accessibility_font_size 1 -u 5000 -f
76 vconftool set -t bool db/private/org.tizen.message/use_volume_key 0 -u 5000 -f
77 chown -R 5000:5000 /opt/usr/apps/org.tizen.message/data
78 mkdir -p /usr/ug/bin
79 ln -sf /usr/bin/ug-client /usr/ug/bin/msg-composer-efl
80
81 %files
82 %manifest %{name}.manifest
83 %defattr(-,root,root,-)
84 /usr/apps/org.tizen.message/bin/message
85 /usr/apps/org.tizen.message/lib/*
86 /usr/apps/org.tizen.message/bin/message-dialog
87 /usr/apps/org.tizen.message/bin/msg-ui-class0
88 /usr/share/packages/*.xml
89 /usr/apps/org.tizen.message/res/*
90 /usr/ug/lib/*.so
91 %dir /opt/usr/apps/org.tizen.message/data
92 /usr/share/icons/default/small/*.png
93
94 %changelog
95 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
96 - Applying EFL API changes.
97 - Change elm_scale_get to elm_config_scale_get of composer.
98 - Apply changed EFL api of thread.
99 - Change name of deprecated api elm_scale_get() to elm_config_scale_get().
100
101 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
102 - Change license URL from "tizenopensource.org" to "floralicense.org".
103 - Change enum value related with SESSION policy in MMFW.
104   (It is re-submitted because of invalid tag.)
105
106 * Wed Jan 16 2013 Jaeyun Jeong <jyjeong@samsung.com>
107 - Change enum value related with SESSION policy in MMFW.
108
109 * Mon Dec 10 2012 SooJung Lee <sj003.lee@samsung.com>
110 - Apply EFL migration to message setting.
111 - Use character count api of mf.
112 - Apply EFL migration of composer.
113 - Add isEmulator to check emulator mode.
114 - Apply EFL migration of thread, common.
115 - Apply EFL migration of viewer.
116
117 * Fri Nov 23 2012 SooJung Lee <sj003.lee@samsung.com>
118 - Modify smack manifest file.
119
120 * Tue Nov 20 2012 Jaeyun Jeong <jyjeong@samsung.com>
121 - Modify smack manifest file.
122 - Apply translation data of application title name.
123
124 * Sat Nov 10 2012 Jaeyun Jeong <jyjeong@samsung.com>
125 - Change application path from '/opt' to '/usr'.
126
127 * Fri Oct 26 2012 Jaeyun Jeong <jyjeong@samsung.com>
128 - Fix build errors.
129 - Fix cmaketext file.
130 - Apply latest UX.
131 - Remove unused define.
132 - Apply thread list options and create split view.
133 - Apply the latest Message Composer & Bubble UI guideline.
134 - Apply Viewer options and more functions.