5877a9a3d1690bed3be8b79e743afa6e578bcfe1
[apps/core/preloaded/message-app.git] / packaging / org.tizen.message.spec
1 Name:       org.tizen.message
2 Summary:    message application
3 Version:    0.8.44
4 Release:    1
5 Group:      devel
6 License:    Samsung
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /bin/touch
9 Requires(post): /usr/bin/vconftool
10 Requires: pkgmgr
11 BuildRequires:  pkgconfig(appsvc)
12 BuildRequires:  pkgconfig(bundle)
13 BuildRequires:  pkgconfig(capi-appfw-application)
14 BuildRequires:  pkgconfig(capi-appfw-app-manager)
15 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
16 BuildRequires:  pkgconfig(capi-media-sound-manager)
17 BuildRequires:  pkgconfig(capi-system-info)
18 BuildRequires:  pkgconfig(capi-system-system-settings)
19 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
20 BuildRequires:  pkgconfig(capi-media-image-util)
21 BuildRequires:  pkgconfig(capi-media-player)
22 BuildRequires:  pkgconfig(capi-content-media-content)
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(drm-client)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(ecore)
28 BuildRequires:  pkgconfig(ecore-x)
29 BuildRequires:  pkgconfig(ecore-input)
30 BuildRequires:  pkgconfig(ecore-imf)
31 BuildRequires:  pkgconfig(ecore-file)
32 BuildRequires:  pkgconfig(ecore-evas)
33 BuildRequires:  pkgconfig(eina)
34 BuildRequires:  pkgconfig(evas)
35 BuildRequires:  pkgconfig(glib-2.0)
36 BuildRequires:  pkgconfig(heynoti)
37 BuildRequires:  pkgconfig(icu-i18n)
38 BuildRequires:  pkgconfig(libexif)
39 BuildRequires:  pkgconfig(msg-service)
40 BuildRequires:  pkgconfig(mm-common)
41 BuildRequires:  pkgconfig(mm-player)
42 BuildRequires:  pkgconfig(mm-session)
43 BuildRequires:  pkgconfig(syspopup-caller)
44 BuildRequires:  pkgconfig(status)
45 BuildRequires:  pkgconfig(tapi)
46 BuildRequires:  pkgconfig(ui-gadget-1)
47 BuildRequires:  pkgconfig(utilX)
48 BuildRequires:  libug-contacts-devel
49 BuildRequires:  cmake
50 BuildRequires:  edje-tools
51 BuildRequires:  gettext-tools
52
53 %description
54 message application.
55
56 %prep
57 %setup -q
58
59 %build
60
61 %define PREFIX    "/usr/apps/org.tizen.message"
62 %define RESDIR    "/usr/apps/org.tizen.message/res"
63 %define DATADIR    "/opt/usr/apps/org.tizen.message/data"
64 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
65 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DCMAKE_INSTALL_DATADIR=%{DATADIR}
66 # CMakeLists.Txt needs to be fixed for parallel build to work
67 make #%{?jobs:-j%jobs}
68
69 %install
70 rm -rf %{buildroot}
71 %make_install
72
73 %post
74 vconftool set -t int db/private/org.tizen.message/font_size 1 -u 5000 -f
75 vconftool set -t int db/private/org.tizen.message/accessibility_font_size 1 -u 5000 -f
76 vconftool set -t bool db/private/org.tizen.message/use_volume_key 0 -u 5000 -f
77 chown -R 5000:5000 /opt/usr/apps/org.tizen.message/data
78 mkdir -p /usr/ug/bin
79 ln -sf /usr/bin/ug-client /usr/ug/bin/msg-composer-efl
80
81 %files
82 %manifest %{name}.manifest
83 %defattr(-,root,root,-)
84 /usr/apps/org.tizen.message/bin/message
85 /usr/apps/org.tizen.message/lib/*
86 /usr/apps/org.tizen.message/bin/message-dialog
87 /usr/apps/org.tizen.message/bin/msg-ui-class0
88 /usr/share/packages/*.xml
89 /usr/apps/org.tizen.message/res/*
90 /usr/ug/lib/*.so
91 %dir /opt/usr/apps/org.tizen.message/data
92 /usr/share/icons/default/small/*.png
93
94 %changelog
95 * Mon Feb 12 2013 Jaeyun Jeong <jyjeong@samsung.com>
96 - Fix N_SE-24797. Hide toolbar on horizontal search mode.
97 - Fix N_SE-24783. Cancel search mode after delete message.
98 - Fix N_SE-24338 issue - issue for loading bubbles after delete some messages.
99
100 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
101 - Focus is set to last page only.
102 - Fix N_SE-24694, popup focus issue.
103 - Fix disabled more button issue on bubble view.
104 - Fix N_SE-24578, flight mode issue.
105 - Fix TDIS-1849 issue : Protected message delete scenario.
106 - Fix N_SE-24534, duplicated recipient popup.
107 - Change indicator show/hide when composer is top.
108
109 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
110 - Fix N_SE-24385 that elm_win_resize_object_add() is removed.
111 - Delete draft messages before saving draft message.
112 - Fix N_SE-24422. reset thread list after cancel search.
113 - N_SE-24408.
114
115 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
116 - Fix N_SE-24338, mms draft message issue.
117
118 * Mon Feb 04 2013 Jaeyun Jeong <jyjeong@samsung.com>
119 - Fix N_SE-24139 that only plain text is copied to entry.
120 - N_SE-24098: Tapping volumebar is not working .
121 - Change cnp_mode on search entry.
122
123 * Mon Feb 04 2013 Jaeyun Jeong <jyjeong@samsung.com>
124 - Change message application icon.
125
126 * Fri Feb 01 2013 Jaeyun Jeong <jyjeong@samsung.com>
127 - Fix composer & conversation view title button alignment.
128 - Fix N_SE-23921. Change back button style.
129
130 * Mon Jan 28 2013 Jaeyun Jeong <jyjeong@samsung.com>
131 - Fix N_SE-23264, Remove elm_win_resize_object_add() when adding a layout to main window.
132 - Change image viewer launching method.
133
134 * Wed Jan 23 2013 Jaeyun Jeong <jyjeong@samsung.com>
135 - Fix N_SE-21691, disable more button of composer in case of sms.
136
137 * Tue Jan 22 2013 Jaeyun Jeong <jyjeong@samsung.com>
138 - Fix N_SE-22522, uri of filepath is supported.
139
140 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
141 - Change license URL from "tizenopensource.org" to "floralicense.org".
142 - Change enum value related with SESSION policy in MMFW.
143   (It is re-submitted because of invalid tag.)
144
145 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
146 - Apply EFL API changes.
147 - Change elm_scale_get to elm_config_scale_get of composer.
148 - Change name of deprecated api elm_scale_get() to elm_config_scale_get().
149 - Apply changed EFL api of thread.
150
151 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
152 - Fix N_SE-22080. Start search mode, reset toolbar.
153 - Fix N_SE-22064, recipient select popup focus issue.
154
155 * Thu Jan 17 2013 Jaeyun Jeong <jyjeong@samsung.com>
156 - Change license URL from "www.tizenopensource.org"  to "floralicense.org".
157 - Fix N_SE-18623, page duration string issue.
158
159 * Wed Jan 16 2013 Jaeyun Jeong <jyjeong@samsung.com>
160 - Change enum value related with SESSION policy in MMFW.
161
162 * Thu Jan 10 2013 Jaeyun Jeong <jyjeong@samsung.com>
163 - Fix prevent defect. 38150, 23538.
164
165 * Tue Jan 8 2013 Jaeyun Jeong <jyjeong@samsung.com>
166 - Fix bubble prevent major issue.
167 - Fix prevent defect. 35690, 35689, 23539, 23538.
168 - Fix prevent issue 27952: String not null terminated.
169 - Fix N_SE-17540, update subject font size issue.
170
171 * Fri Dec 28 2012 Jaeyun Jeong <jyjeong@samsung.com>
172 - Fix N_SE-17540, update subject font size issue.
173 - Update org.tizen.message.xml.target to support mmsto/sms scheme.
174
175 * Mon Dec 10 2012 SooJung Lee <sj003.lee@samsung.com>
176 - Apply EFL migration to message setting.
177 - Use character count api of mf.
178 - Apply EFL migration of composer.
179 - Add isEmulator to check emulator mode.
180 - Apply EFL migration of thread, common.
181 - Apply EFL migration of viewer.
182
183 * Fri Nov 23 2012 SooJung Lee <sj003.lee@samsung.com>
184 - Modify smack manifest file.
185
186 * Tue Nov 20 2012 Jaeyun Jeong <jyjeong@samsung.com>
187 - Modify smack manifest file.
188 - Apply translation data of application title name.
189
190 * Sat Nov 10 2012 Jaeyun Jeong <jyjeong@samsung.com>
191 - Change application path from '/opt' to '/usr'.
192
193 * Fri Oct 26 2012 Jaeyun Jeong <jyjeong@samsung.com>
194 - Fix build errors.
195 - Fix cmaketext file.
196 - Apply latest UX.
197 - Remove unused define.
198 - Apply thread list options and create split view.
199 - Apply the latest Message Composer & Bubble UI guideline.
200 - Apply Viewer options and more functions.