Change message application icon.
[apps/home/message-app.git] / packaging / org.tizen.message.spec
1 Name:       org.tizen.message
2 Summary:    message application
3 Version:    0.8.39
4 Release:    1
5 Group:      devel
6 License:    Samsung
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /bin/touch
9 Requires(post): /usr/bin/vconftool
10 Requires: pkgmgr
11 BuildRequires:  pkgconfig(appsvc)
12 BuildRequires:  pkgconfig(bundle)
13 BuildRequires:  pkgconfig(capi-appfw-application)
14 BuildRequires:  pkgconfig(capi-appfw-app-manager)
15 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
16 BuildRequires:  pkgconfig(capi-media-sound-manager)
17 BuildRequires:  pkgconfig(capi-system-info)
18 BuildRequires:  pkgconfig(capi-system-system-settings)
19 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
20 BuildRequires:  pkgconfig(capi-media-image-util)
21 BuildRequires:  pkgconfig(capi-media-player)
22 BuildRequires:  pkgconfig(capi-content-media-content)
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(drm-client)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(ecore)
28 BuildRequires:  pkgconfig(ecore-x)
29 BuildRequires:  pkgconfig(ecore-input)
30 BuildRequires:  pkgconfig(ecore-imf)
31 BuildRequires:  pkgconfig(ecore-file)
32 BuildRequires:  pkgconfig(ecore-evas)
33 BuildRequires:  pkgconfig(eina)
34 BuildRequires:  pkgconfig(evas)
35 BuildRequires:  pkgconfig(glib-2.0)
36 BuildRequires:  pkgconfig(heynoti)
37 BuildRequires:  pkgconfig(icu-i18n)
38 BuildRequires:  pkgconfig(libexif)
39 BuildRequires:  pkgconfig(msg-service)
40 BuildRequires:  pkgconfig(mm-common)
41 BuildRequires:  pkgconfig(mm-player)
42 BuildRequires:  pkgconfig(mm-session)
43 BuildRequires:  pkgconfig(syspopup-caller)
44 BuildRequires:  pkgconfig(status)
45 BuildRequires:  pkgconfig(tapi)
46 BuildRequires:  pkgconfig(ui-gadget-1)
47 BuildRequires:  pkgconfig(utilX)
48 BuildRequires:  libug-contacts-devel
49 BuildRequires:  cmake
50 BuildRequires:  edje-tools
51 BuildRequires:  gettext-tools
52
53 %description
54 message application.
55
56 %prep
57 %setup -q
58
59 %build
60
61 %define PREFIX    "/usr/apps/org.tizen.message"
62 %define RESDIR    "/usr/apps/org.tizen.message/res"
63 %define DATADIR    "/opt/usr/apps/org.tizen.message/data"
64 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
65 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DCMAKE_INSTALL_DATADIR=%{DATADIR}
66 # CMakeLists.Txt needs to be fixed for parallel build to work
67 make #%{?jobs:-j%jobs}
68
69 %install
70 rm -rf %{buildroot}
71 %make_install
72
73 %post
74 vconftool set -t int db/private/org.tizen.message/font_size 1 -u 5000 -f
75 vconftool set -t int db/private/org.tizen.message/accessibility_font_size 1 -u 5000 -f
76 vconftool set -t bool db/private/org.tizen.message/use_volume_key 0 -u 5000 -f
77 chown -R 5000:5000 /opt/usr/apps/org.tizen.message/data
78 mkdir -p /usr/ug/bin
79 ln -sf /usr/bin/ug-client /usr/ug/bin/msg-composer-efl
80
81 %files
82 %manifest %{name}.manifest
83 %defattr(-,root,root,-)
84 /usr/apps/org.tizen.message/bin/message
85 /usr/apps/org.tizen.message/lib/*
86 /usr/apps/org.tizen.message/bin/message-dialog
87 /usr/apps/org.tizen.message/bin/msg-ui-class0
88 /usr/share/packages/*.xml
89 /usr/apps/org.tizen.message/res/*
90 /usr/ug/lib/*.so
91 %dir /opt/usr/apps/org.tizen.message/data
92 /usr/share/icons/default/small/*.png
93
94 %changelog
95 * Mon Feb 04 2013 Jaeyun Jeong <jyjeong@samsung.com>
96 - Change message application icon.
97
98 * Fri Feb 01 2013 Jaeyun Jeong <jyjeong@samsung.com>
99 - Fix composer & conversation view title button alignment.
100 - Fix N_SE-23921. Change back button style.
101
102 * Mon Jan 28 2013 Jaeyun Jeong <jyjeong@samsung.com>
103 - Fix N_SE-23264, Remove elm_win_resize_object_add() when adding a layout to main window.
104 - Change image viewer launching method.
105
106 * Wed Jan 23 2013 Jaeyun Jeong <jyjeong@samsung.com>
107 - Fix N_SE-21691, disable more button of composer in case of sms.
108
109 * Tue Jan 22 2013 Jaeyun Jeong <jyjeong@samsung.com>
110 - Fix N_SE-22522, uri of filepath is supported.
111
112 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
113 - Apply EFL API changes.
114 - Change elm_scale_get to elm_config_scale_get of composer.
115 - Change name of deprecated api elm_scale_get() to elm_config_scale_get().
116 - Apply changed EFL api of thread.
117
118 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
119 - Fix N_SE-22080. Start search mode, reset toolbar.
120 - Fix N_SE-22064, recipient select popup focus issue.
121
122 * Thu Jan 17 2013 Jaeyun Jeong <jyjeong@samsung.com>
123 - Change license URL from "www.tizenopensource.org"  to "floralicense.org".
124 - Fix N_SE-18623, page duration string issue.
125
126 * Wed Jan 16 2013 Jaeyun Jeong <jyjeong@samsung.com>
127 - Change enum value related with SESSION policy in MMFW.
128
129 * Thu Jan 10 2013 Jaeyun Jeong <jyjeong@samsung.com>
130 - Fix prevent defect. 38150, 23538.
131
132 * Tue Jan 8 2013 Jaeyun Jeong <jyjeong@samsung.com>
133 - Fix bubble prevent major issue.
134 - Fix prevent defect. 35690, 35689, 23539, 23538.
135 - Fix prevent issue 27952: String not null terminated.
136 - Fix N_SE-17540, update subject font size issue.
137
138 * Fri Dec 28 2012 Jaeyun Jeong <jyjeong@samsung.com>
139 - Fix N_SE-17540, update subject font size issue.
140 - Update org.tizen.message.xml.target to support mmsto/sms scheme.
141
142 * Mon Dec 10 2012 SooJung Lee <sj003.lee@samsung.com>
143 - Apply EFL migration to message setting.
144 - Use character count api of mf.
145 - Apply EFL migration of composer.
146 - Add isEmulator to check emulator mode.
147 - Apply EFL migration of thread, common.
148 - Apply EFL migration of viewer.
149
150 * Fri Nov 23 2012 SooJung Lee <sj003.lee@samsung.com>
151 - Modify smack manifest file.
152
153 * Tue Nov 20 2012 Jaeyun Jeong <jyjeong@samsung.com>
154 - Modify smack manifest file.
155 - Apply translation data of application title name.
156
157 * Sat Nov 10 2012 Jaeyun Jeong <jyjeong@samsung.com>
158 - Change application path from '/opt' to '/usr'.
159
160 * Fri Oct 26 2012 Jaeyun Jeong <jyjeong@samsung.com>
161 - Fix build errors.
162 - Fix cmaketext file.
163 - Apply latest UX.
164 - Remove unused define.
165 - Apply thread list options and create split view.
166 - Apply the latest Message Composer & Bubble UI guideline.
167 - Apply Viewer options and more functions.