Remove SMACK rule file(.rule) according three domain model
[apps/core/preloaded/message-app.git] / packaging / org.tizen.message.spec
1 Name:       org.tizen.message
2 Summary:    message application
3 Version:    0.8.52
4 Release:    1
5 Group:      devel
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /bin/touch
9 Requires(post): /usr/bin/vconftool
10 Requires: pkgmgr
11 BuildRequires:  pkgconfig(appsvc)
12 BuildRequires:  pkgconfig(bundle)
13 BuildRequires:  pkgconfig(capi-appfw-application)
14 BuildRequires:  pkgconfig(capi-appfw-app-manager)
15 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
16 BuildRequires:  pkgconfig(capi-media-sound-manager)
17 BuildRequires:  pkgconfig(capi-system-info)
18 BuildRequires:  pkgconfig(capi-system-system-settings)
19 BuildRequires:  pkgconfig(capi-media-metadata-extractor)
20 BuildRequires:  pkgconfig(capi-media-image-util)
21 BuildRequires:  pkgconfig(capi-media-player)
22 BuildRequires:  pkgconfig(capi-content-media-content)
23 BuildRequires:  pkgconfig(contacts-service2)
24 BuildRequires:  pkgconfig(dlog)
25 BuildRequires:  pkgconfig(drm-client)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(ecore)
28 BuildRequires:  pkgconfig(ecore-x)
29 BuildRequires:  pkgconfig(ecore-input)
30 BuildRequires:  pkgconfig(ecore-imf)
31 BuildRequires:  pkgconfig(ecore-file)
32 BuildRequires:  pkgconfig(ecore-evas)
33 BuildRequires:  pkgconfig(eina)
34 BuildRequires:  pkgconfig(evas)
35 BuildRequires:  pkgconfig(ethumb)
36 BuildRequires:  pkgconfig(glib-2.0)
37 BuildRequires:  pkgconfig(heynoti)
38 BuildRequires:  pkgconfig(icu-i18n)
39 BuildRequires:  pkgconfig(libexif)
40 BuildRequires:  pkgconfig(msg-service)
41 BuildRequires:  pkgconfig(mm-common)
42 BuildRequires:  pkgconfig(mm-player)
43 BuildRequires:  pkgconfig(mm-session)
44 BuildRequires:  pkgconfig(syspopup-caller)
45 BuildRequires:  pkgconfig(status)
46 BuildRequires:  pkgconfig(tapi)
47 BuildRequires:  pkgconfig(ui-gadget-1)
48 BuildRequires:  pkgconfig(utilX)
49 BuildRequires:  libug-contacts-devel
50 BuildRequires:  cmake
51 BuildRequires:  edje-tools
52 BuildRequires:  gettext-tools
53
54 %description
55 message application.
56
57 %prep
58 %setup -q
59
60 %build
61
62 %define PREFIX    "/usr/apps/org.tizen.message"
63 %define RESDIR    "/usr/apps/org.tizen.message/res"
64 %define DATADIR    "/opt/usr/apps/org.tizen.message/data"
65 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed -Wl,--hash-style=both"; export LDFLAGS
66 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DCMAKE_INSTALL_DATADIR=%{DATADIR}
67 # CMakeLists.Txt needs to be fixed for parallel build to work
68 make #%{?jobs:-j%jobs}
69
70 %install
71 rm -rf %{buildroot}
72 %make_install
73 mkdir -p %{buildroot}/usr/share/license
74
75 %post
76 vconftool set -t int db/private/org.tizen.message/font_size 1 -u 5000 -f
77 vconftool set -t int db/private/org.tizen.message/accessibility_font_size 1 -u 5000 -f
78 vconftool set -t bool db/private/org.tizen.message/use_volume_key 0 -u 5000 -f
79 chown -R 5000:5000 /opt/usr/apps/org.tizen.message/data
80 mkdir -p /usr/ug/bin
81 ln -sf /usr/bin/ug-client /usr/ug/bin/msg-composer-efl
82
83 %files
84 %manifest %{name}.manifest
85 %defattr(-,root,root,-)
86 /usr/apps/org.tizen.message/bin/message
87 /usr/apps/org.tizen.message/lib/*
88 /usr/apps/org.tizen.message/bin/message-dialog
89 /usr/apps/org.tizen.message/bin/msg-ui-class0
90 /usr/share/packages/*.xml
91 /usr/apps/org.tizen.message/res/*
92 /usr/ug/lib/*.so
93 %dir /opt/usr/apps/org.tizen.message/data
94 /usr/share/icons/default/small/*.png
95 /usr/share/license/%{name}
96
97 %changelog
98 * Fri Apr 11 2014 Seongwook Chung <seong.chung@samsung.com>
99 - Remove SMACK rule file because of SMACK three domain model
100
101 * Tue May 14 2013 Jaeyun Jeong <jyjeong@samsung.com>
102 - Change message icon.
103
104 * Tue May 7 2013 Jaeyun Jeong <jyjeong@samsung.com>
105 - Change SMACK rule file.
106
107 * Fri May 3 2013 Jaeyun Jeong <jyjeong@samsung.com>
108 - Install smack rule files.
109 - Apply smack rule.
110
111 * Fri May 3 2013 Jaeyun Jeong <jyjeong@samsung.com>
112 - Apply latest Flora license.
113
114 * Tue Apr 23 2013 Jaeyun Jeong <jyjeong@samsung.com>
115 - Change LICENSE file because the date in LICENSE is changed.
116
117 * Sun Apr 7 2013 Jaeyun Jeong <jyjeong@samsung.com>
118 - Change rotation API.
119 - Removing feature related with video call.
120
121 * Fri Mar 29 2013 Jaeyun Jeong <jyjeong@samsung.com>
122 - Remove setting menu in message app.
123
124 * Thu Mar 28 2013 Jaeyun Jeong <jyjeong@samsung.com>
125 - Apply SIP back key concept to message setting.
126 - Apply latest codes migration.
127 - Fix protected message delete popup and split view.
128 - Apply sip back key concept in composer.
129 - Fix for TDIS-4472. Use correct manifest file for x86 device, instead of emulator one.
130 - Fix N_SE-25920. Add press/unpress callback to panes.
131 - N_SE-25971 : Change the timing of disconnection handler when launching appsvc.
132
133 * Sat Feb 16 2013 Jaeyun Jeong <jyjeong@samsung.com>
134 - N_SE-25398 : Fix lags on entering SMIL player.
135 - Fix N_SE-25203: bubble position issue & date_line issue.
136 - Fix N_SE-25242, N_SE-25243, N_SE-25248. Show normal view on horizontal edit mode.
137 - Fix N_SE-25254, splitview composer indicator issue, ref_count is applied in composer.
138 - Fix N_SE-25224, drawing memo inserting issue.
139
140 * Mon Feb 12 2013 Jaeyun Jeong <jyjeong@samsung.com>
141 - Fix N_SE-24797. Hide toolbar on horizontal search mode.
142 - Fix N_SE-24783. Cancel search mode after delete message.
143 - Fix N_SE-24338 issue - issue for loading bubbles after delete some messages.
144
145 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
146 - Focus is set to last page only.
147 - Fix N_SE-24694, popup focus issue.
148 - Fix disabled more button issue on bubble view.
149 - Fix N_SE-24578, flight mode issue.
150 - Fix TDIS-1849 issue : Protected message delete scenario.
151 - Fix N_SE-24534, duplicated recipient popup.
152 - Change indicator show/hide when composer is top.
153
154 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
155 - Fix N_SE-24385 that elm_win_resize_object_add() is removed.
156 - Delete draft messages before saving draft message.
157 - Fix N_SE-24422. reset thread list after cancel search.
158 - N_SE-24408.
159
160 * Wed Feb 06 2013 Jaeyun Jeong <jyjeong@samsung.com>
161 - Fix N_SE-24338, mms draft message issue.
162
163 * Mon Feb 04 2013 Jaeyun Jeong <jyjeong@samsung.com>
164 - Fix N_SE-24139 that only plain text is copied to entry.
165 - N_SE-24098: Tapping volumebar is not working .
166 - Change cnp_mode on search entry.
167
168 * Mon Feb 04 2013 Jaeyun Jeong <jyjeong@samsung.com>
169 - Change message application icon.
170
171 * Fri Feb 01 2013 Jaeyun Jeong <jyjeong@samsung.com>
172 - Fix composer & conversation view title button alignment.
173 - Fix N_SE-23921. Change back button style.
174
175 * Mon Jan 28 2013 Jaeyun Jeong <jyjeong@samsung.com>
176 - Fix N_SE-23264, Remove elm_win_resize_object_add() when adding a layout to main window.
177 - Change image viewer launching method.
178
179 * Wed Jan 23 2013 Jaeyun Jeong <jyjeong@samsung.com>
180 - Fix N_SE-21691, disable more button of composer in case of sms.
181
182 * Tue Jan 22 2013 Jaeyun Jeong <jyjeong@samsung.com>
183 - Fix N_SE-22522, uri of filepath is supported.
184
185 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
186 - Change license URL from "tizenopensource.org" to "floralicense.org".
187 - Change enum value related with SESSION policy in MMFW.
188   (It is re-submitted because of invalid tag.)
189
190 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
191 - Apply EFL API changes.
192 - Change elm_scale_get to elm_config_scale_get of composer.
193 - Change name of deprecated api elm_scale_get() to elm_config_scale_get().
194 - Apply changed EFL api of thread.
195
196 * Mon Jan 21 2013 Jaeyun Jeong <jyjeong@samsung.com>
197 - Fix N_SE-22080. Start search mode, reset toolbar.
198 - Fix N_SE-22064, recipient select popup focus issue.
199
200 * Thu Jan 17 2013 Jaeyun Jeong <jyjeong@samsung.com>
201 - Change license URL from "www.tizenopensource.org"  to "floralicense.org".
202 - Fix N_SE-18623, page duration string issue.
203
204 * Wed Jan 16 2013 Jaeyun Jeong <jyjeong@samsung.com>
205 - Change enum value related with SESSION policy in MMFW.
206
207 * Thu Jan 10 2013 Jaeyun Jeong <jyjeong@samsung.com>
208 - Fix prevent defect. 38150, 23538.
209
210 * Tue Jan 8 2013 Jaeyun Jeong <jyjeong@samsung.com>
211 - Fix bubble prevent major issue.
212 - Fix prevent defect. 35690, 35689, 23539, 23538.
213 - Fix prevent issue 27952: String not null terminated.
214 - Fix N_SE-17540, update subject font size issue.
215
216 * Fri Dec 28 2012 Jaeyun Jeong <jyjeong@samsung.com>
217 - Fix N_SE-17540, update subject font size issue.
218 - Update org.tizen.message.xml.target to support mmsto/sms scheme.
219
220 * Mon Dec 10 2012 SooJung Lee <sj003.lee@samsung.com>
221 - Apply EFL migration to message setting.
222 - Use character count api of mf.
223 - Apply EFL migration of composer.
224 - Add isEmulator to check emulator mode.
225 - Apply EFL migration of thread, common.
226 - Apply EFL migration of viewer.
227
228 * Fri Nov 23 2012 SooJung Lee <sj003.lee@samsung.com>
229 - Modify smack manifest file.
230
231 * Tue Nov 20 2012 Jaeyun Jeong <jyjeong@samsung.com>
232 - Modify smack manifest file.
233 - Apply translation data of application title name.
234
235 * Sat Nov 10 2012 Jaeyun Jeong <jyjeong@samsung.com>
236 - Change application path from '/opt' to '/usr'.
237
238 * Fri Oct 26 2012 Jaeyun Jeong <jyjeong@samsung.com>
239 - Fix build errors.
240 - Fix cmaketext file.
241 - Apply latest UX.
242 - Remove unused define.
243 - Apply thread list options and create split view.
244 - Apply the latest Message Composer & Bubble UI guideline.
245 - Apply Viewer options and more functions.