Supporting the auto-rotation for the bgset.
[apps/native/menu-screen.git] / packaging / org.tizen.menu-screen.spec
1 %define _optdir /opt
2 %define _usrdir /usr
3 %define _appdir %{_usrdir}/apps
4 %define _usr_datadir %{_usrdir}/share
5
6 %define _project_name menu-screen
7 %define _package_name org.tizen.%{_project_name}
8
9 %define _packagedir %{_appdir}/%{_package_name}
10 %define _bindir %{_packagedir}/bin
11 %define _datadir %{_optdir}%{_packagedir}/data
12 %define _resdir %{_packagedir}/res
13 %define _sharedir %{_packagedir}/share
14
15 Name:       org.tizen.menu-screen
16 Summary:    An utility library of the menu screen
17 Version:    1.0.21
18 Release:    1.1
19 Group:      TO_BE/FILLED_IN
20 License:    Flora Software License
21 Source0:    %{name}-%{version}.tar.gz
22 BuildRequires:  pkgconfig(elementary)
23 BuildRequires:  pkgconfig(appcore-efl)
24 BuildRequires:  pkgconfig(utilX)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(dlog)
27 BuildRequires:  pkgconfig(sysman)
28 BuildRequires:  pkgconfig(bundle)
29 BuildRequires:  pkgconfig(pkgmgr)
30 BuildRequires:  pkgconfig(syspopup-caller)
31 BuildRequires:  pkgconfig(heynoti)
32 BuildRequires:  pkgconfig(evas)
33 BuildRequires:  pkgconfig(ecore-evas)
34 BuildRequires:  pkgconfig(edje)
35 BuildRequires:  pkgconfig(ecore)
36 BuildRequires:  pkgconfig(ecore-file)
37 BuildRequires:  pkgconfig(ecore-imf)
38 BuildRequires:  pkgconfig(ecore-input)
39 BuildRequires:  pkgconfig(eet)
40 BuildRequires:  pkgconfig(eina)
41 BuildRequires:  pkgconfig(ail)
42 BuildRequires:  pkgconfig(capi-appfw-application)
43 BuildRequires:  cmake
44 BuildRequires:  edje-tools
45 BuildRequires:  gettext-tools
46
47
48 %description
49 An utility library for developers of the menu screen.
50
51
52
53 %package devel
54 Summary:    An utility library of the menu screen (devel)
55 Group:      Development/Libraries
56 Requires:   %{name} = %{version}-%{release}
57
58 %description devel
59 An utility library for developers of the menu screen (devel)
60
61
62 %prep
63 %setup -q
64
65 %build
66 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
67 CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
68 make %{?jobs:-j%jobs}
69
70 %install
71 %make_install
72 mkdir -p %{buildroot}%{_datadir}
73 mkdir -p %{buildroot}/usr/share/license
74
75 %post
76 INHOUSE_ID="5000"
77
78 init_vconf()
79 {
80         vconftool set -t int memory/idle-screen/top 0 -i -u 5000 -f
81         vconftool set -t string file/private/org.tizen.menu-screen/engine "gl" -i -u 5000 -f
82         vconftool set -t int memory/menu-screen/is_menu_screen_done 0 -i -f
83         vconftool set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -i -u 5000 -f
84 }
85
86
87
88 init_vconf
89
90 %files
91 %manifest %{name}.manifest
92 %defattr(-,root,root,-)
93 %{_bindir}/menu-screen
94 %{_resdir}/edje/all_apps_portrait.edj
95 %{_resdir}/edje/group_4x4_portrait.edj
96 %{_resdir}/edje/item_4x4.edj
97 %{_resdir}/edje/layout_portrait.edj
98 %{_resdir}/edje/index.edj
99 %{_usr_datadir}/packages/org.tizen.menu-screen.xml
100 %{_usr_datadir}/license/%{name}