3e287a1adcf761c50bf24f6be370550aef1d89d8
[profile/ivi/menu-screen.git] / packaging / org.tizen.menu-screen.spec
1 %define _optdir /opt
2 %define _appdir %{_optdir}/apps
3 %define _opt_datadir %{_optdir}/share
4
5 Name:       org.tizen.menu-screen
6 Summary:    An utility library of the menu screen
7 Version:    1.0.13
8 Release:    1.1
9 Group:      TO_BE/FILLED_IN
10 License:    Flora Software License
11 Source0:    %{name}-%{version}.tar.gz
12 BuildRequires:  pkgconfig(elementary)
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(utilX)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(sysman)
18 BuildRequires:  pkgconfig(bundle)
19 BuildRequires:  pkgconfig(pkgmgr)
20 BuildRequires:  pkgconfig(syspopup-caller)
21 BuildRequires:  pkgconfig(heynoti)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(ecore-evas)
24 BuildRequires:  pkgconfig(edje)
25 BuildRequires:  pkgconfig(ecore)
26 BuildRequires:  pkgconfig(ecore-file)
27 BuildRequires:  pkgconfig(ecore-imf)
28 BuildRequires:  pkgconfig(ecore-input)
29 BuildRequires:  pkgconfig(eet)
30 BuildRequires:  pkgconfig(eina)
31 BuildRequires:  pkgconfig(ail)
32 BuildRequires:  pkgconfig(capi-appfw-application)
33 BuildRequires:  cmake
34 BuildRequires:  edje-tools
35 BuildRequires:  gettext-tools
36
37
38 %description
39 An utility library for developers of the menu screen.
40
41
42
43 %package devel
44 Summary:    An utility library of the menu screen (devel)
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47
48 %description devel
49 An utility library for developers of the menu screen (devel)
50
51
52 %prep
53 %setup -q
54
55 %build
56 CFLAGS="-I/usr/lib/glib-2.0/include/ -I/usr/include/glib-2.0 -I/usr/lib/dbus-1.0/include -I/usr/include/dbus-1.0 -I/usr/include/e_dbus-1 -I/usr/include/ethumb-0 -I/usr/include/edje-1 -I/usr/include/efreet-1 -I/usr/include/embryo-1 -I/usr/include/ecore-1 -I/usr/include/eet-1 -I/usr/include/evas-1 -I/usr/include/eina-1 -I/usr/include/eina-1/eina $CFLAGS" CXXFLAGS=$CXXFLAGS cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
57
58 make %{?jobs:-j%jobs}
59
60 %install
61 %make_install
62 mkdir %{buildroot}/opt/apps/org.tizen.menu-screen/data
63
64
65 %post
66
67 INHOUSE_ID="5000"
68
69 chown -R 5000:5000 /opt/apps/org.tizen.menu-screen/data
70
71 init_vconf()
72 {
73         # for menu daemon
74         vconftool set -t int memory/menu-screen/is_menu_screen_done 0 -i -f
75
76         # for menu-screen
77         vconftool set -t int memory/idle_screen/top 0 -i -u 5000 -f
78         vconftool set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -i -u 5000 -f
79 }
80
81
82
83 init_vconf
84
85 #%files -f %{name}.lang
86 %files 
87 %{_appdir}/org.tizen.menu-screen/bin/menu-screen
88 %{_appdir}/org.tizen.menu-screen/res/edje/all_apps_portrait.edj
89 %{_appdir}/org.tizen.menu-screen/res/edje/group_4x4_portrait.edj
90 %{_appdir}/org.tizen.menu-screen/res/edje/item_4x4.edj
91 %{_appdir}/org.tizen.menu-screen/res/edje/layout_portrait.edj
92 %{_opt_datadir}/packages/org.tizen.menu-screen.xml
93
94