Spec tweak for mkdir command.
[profile/ivi/menu-screen.git] / packaging / org.tizen.menu-screen.spec
1 %define _optdir /opt
2 %define _appdir %{_optdir}/apps
3 %define _opt_datadir %{_optdir}/share
4
5 Name:       org.tizen.menu-screen
6 Summary:    An utility library of the menu screen
7 Version:    1.0.13
8 Release:    1.1
9 Group:      TO_BE/FILLED_IN
10 License:    Flora Software License
11 Source0:    %{name}-%{version}.tar.gz
12 BuildRequires:  pkgconfig(elementary)
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(utilX)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(sysman)
18 BuildRequires:  pkgconfig(bundle)
19 BuildRequires:  pkgconfig(pkgmgr)
20 BuildRequires:  pkgconfig(syspopup-caller)
21 BuildRequires:  pkgconfig(heynoti)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(ecore-evas)
24 BuildRequires:  pkgconfig(edje)
25 BuildRequires:  pkgconfig(ecore)
26 BuildRequires:  pkgconfig(ecore-file)
27 BuildRequires:  pkgconfig(ecore-imf)
28 BuildRequires:  pkgconfig(ecore-input)
29 BuildRequires:  pkgconfig(eet)
30 BuildRequires:  pkgconfig(eina)
31 BuildRequires:  pkgconfig(ail)
32 BuildRequires:  pkgconfig(capi-appfw-application)
33 BuildRequires:  cmake
34 BuildRequires:  edje-tools
35 BuildRequires:  gettext-tools
36
37
38 %description
39 An utility library for developers of the menu screen.
40
41 %package devel
42 Summary:    An utility library of the menu screen (devel)
43 Group:      Development/Libraries
44 Requires:   %{name} = %{version}-%{release}
45
46 %description devel
47 An utility library for developers of the menu screen (devel)
48
49
50 %prep
51 %setup -q
52
53 %build
54 CFLAGS="-I/usr/lib/glib-2.0/include/ -I/usr/include/glib-2.0 -I/usr/lib/dbus-1.0/include -I/usr/include/dbus-1.0 -I/usr/include/e_dbus-1 -I/usr/include/ethumb-0 -I/usr/include/edje-1 -I/usr/include/efreet-1 -I/usr/include/embryo-1 -I/usr/include/ecore-1 -I/usr/include/eet-1 -I/usr/include/evas-1 -I/usr/include/eina-1 -I/usr/include/eina-1/eina $CFLAGS" CXXFLAGS=$CXXFLAGS cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
55
56 make %{?jobs:-j%jobs}
57
58 %install
59 %make_install
60 mkdir -p %{buildroot}/opt/apps/org.tizen.menu-screen/data
61
62
63 %post
64
65 INHOUSE_ID="5000"
66
67 chown -R 5000:5000 /opt/apps/org.tizen.menu-screen/data
68
69 init_vconf()
70 {
71         # for menu daemon
72         vconftool set -t int memory/menu-screen/is_menu_screen_done 0 -i -f
73
74         # for menu-screen
75         vconftool set -t int memory/idle_screen/top 0 -i -u 5000 -f
76         vconftool set -t string db/setting/menuscreen/package_name "org.tizen.menu-screen" -i -u 5000 -f
77 }
78
79
80
81 init_vconf
82
83 #%files -f %{name}.lang
84 %files 
85 %{_appdir}/org.tizen.menu-screen/bin/menu-screen
86 %{_appdir}/org.tizen.menu-screen/res/edje/all_apps_portrait.edj
87 %{_appdir}/org.tizen.menu-screen/res/edje/group_4x4_portrait.edj
88 %{_appdir}/org.tizen.menu-screen/res/edje/item_4x4.edj
89 %{_appdir}/org.tizen.menu-screen/res/edje/layout_portrait.edj
90 %{_opt_datadir}/packages/org.tizen.menu-screen.xml
91
92