apply FSL(Flora Software License)
[apps/home/memo.git] / packaging / org.tizen.memo.spec
1 Name:       org.tizen.memo
2 Summary:    Memo displays the time as text
3 Version:    0.1.5
4 Release:    78
5 Group:      TO_BE/FILLED_IN
6 License:    Flora Software License
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(appcore-efl)
9 BuildRequires: pkgconfig(appsvc)
10 BuildRequires: pkgconfig(bundle)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(ecore-imf)
14 BuildRequires: pkgconfig(ecore-input)
15 BuildRequires: pkgconfig(ecore-x)
16 BuildRequires: pkgconfig(edje)
17 BuildRequires: pkgconfig(eina)
18 BuildRequires: pkgconfig(elementary)
19 BuildRequires: pkgconfig(evas)
20 BuildRequires: pkgconfig(heynoti)
21 BuildRequires: pkgconfig(iniparser)
22 BuildRequires: pkgconfig(memo)
23 BuildRequires: pkgconfig(ui-gadget)
24 BuildRequires: pkgconfig(icu-uc)
25 BuildRequires:  libug-contacts-devel
26
27 BuildRequires:  cmake
28 BuildRequires:  edje-bin
29 BuildRequires:  embryo-bin
30 BuildRequires:  gettext-tools
31
32
33 %description
34 Memo displays the time as text (e.g. "It's just gone 
35 five to ten"), and your next appointments, memos, 
36 and alarms in a small window.
37
38 %prep
39 %setup -q
40
41 %build
42 export PREFIX="/opt/apps/org.tizen.memo"
43 export CFLAGS+=" -fPIC"
44 export LDFLAGS+=" -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed -Wl,--hash-style=both"
45
46 cmake . -DCMAKE_INSTALL_PREFIX="$PREFIX"
47
48 make %{?jobs:-j%jobs}
49
50 %install
51 %make_install
52
53 %post
54 chown -R 5000:5000 /opt/apps/org.tizen.memo/data
55
56 %files
57 /opt/apps/org.tizen.memo/bin/*
58 /opt/apps/org.tizen.memo/res/*
59 /opt/apps/org.tizen.memo/data/*
60 /opt/share/applications/org.tizen.memo.desktop