f5145cb8f64df4563465fa3319dec1d44db41cdc
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %define PREFIX /usr/apps/org.tizen.lockscreen
2
3 Name:       org.tizen.lockscreen
4 Summary:    lockscreen application
5 Version: 0.1.2
6 Release:    1
7 Group:      TBD
8 License:    Apache
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-appfw-application)
11 BuildRequires: pkgconfig(ecore-x)
12 BuildRequires: pkgconfig(appcore-efl)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(ail)
15 BuildRequires: pkgconfig(notification)
16 BuildRequires: pkgconfig(security-server)
17 BuildRequires: pkgconfig(mdm)
18
19 BuildRequires: cmake
20 BuildRequires: gettext
21 BuildRequires: edje-tools
22 %description
23 lockscreen application.
24
25 %prep
26 %setup -q
27
28 %build
29 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed";export LDFLAGS
30 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
31 make %{?jobs:-j%jobs}
32
33 %install
34 %make_install
35 mkdir -p %{buildroot}/usr/apps/org.tizen.lockscreen/data
36 mkdir -p %{buildroot}/usr/share/license
37 install -m 0755 LICENSE %{buildroot}/usr/share/license/org.tizen.lockscreen
38
39 %post
40 /sbin/ldconfig
41
42 GOPTION="-g 6514"
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %manifest org.tizen.lockscreen.manifest
48 %defattr(-,root,root,-)
49 %attr(-,inhouse,inhouse) %dir /usr/apps/org.tizen.lockscreen/data
50 /usr/apps/org.tizen.lockscreen/*
51 /usr/share/packages/org.tizen.lockscreen.xml
52 /usr/share/license/org.tizen.lockscreen