Lockscreen refactor
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 Name:       org.tizen.lockscreen
2 Summary:    Lockscreen app
3 Group:      Applications/Core Applications
4 Version:    0.0.1
5 Release:    1
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 %if "%{profile}" == "wearable"
10 ExcludeArch: %{arm} %ix86 x86_64
11 %endif
12
13 %if "%{profile}" == "tv"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 BuildRequires:  cmake
18 BuildRequires:  edje-tools
19 BuildRequires:  gettext-tools
20 BuildRequires:  hash-signer
21 BuildRequires:  pkgconfig(bundle)
22 BuildRequires:  pkgconfig(capi-system-info)
23 BuildRequires:  pkgconfig(capi-system-runtime-info)
24 BuildRequires:  pkgconfig(capi-system-device)
25 BuildRequires:  pkgconfig(capi-system-system-settings)
26 BuildRequires:  pkgconfig(capi-appfw-application)
27 BuildRequires:  pkgconfig(capi-appfw-app-manager)
28 BuildRequires:  pkgconfig(dlog)
29 BuildRequires:  pkgconfig(elementary)
30 BuildRequires:  pkgconfig(notification)
31 BuildRequires:  pkgconfig(minicontrol-viewer)
32 BuildRequires:  pkgconfig(feedback)
33 BuildRequires:  pkgconfig(tzsh-lockscreen-service)
34 BuildRequires:  pkgconfig(libtzplatform-config)
35 BuildRequires:  pkgconfig(capi-base-utils-i18n)
36 BuildRequires:  pkgconfig(capi-telephony)
37
38 %description
39 Lockscreen application for Tizen.
40
41 %prep
42 %setup -q
43
44 %build
45
46 %define _pkg_dir %{TZ_SYS_RO_APP}/%{name}
47 %define _pkg_shared_dir %{_pkg_dir}/shared
48 %define _pkg_data_dir %{_pkg_dir}/data
49 %define _sys_icons_dir %{_pkg_shared_dir}/res
50 %define _sys_packages_dir %{TZ_SYS_RO_PACKAGES}
51 %define _sys_license_dir %{TZ_SYS_SHARE}/license
52
53 %if 0%{?tizen_build_binary_release_type_eng}
54 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
55 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
56 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
57 %endif
58
59 %ifarch %{arm}
60 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
61 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
62 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
63 %else
64 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
65 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
66 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
67 %endif
68
69
70 cd CMake
71 cmake . -DINSTALL_PREFIX=%{_pkg_dir} \
72         -DSYS_ICONS_DIR=%{_sys_icons_dir} \
73         -DSYS_PACKAGES_DIR=%{_sys_packages_dir}
74 make %{?jobs:-j%jobs}
75 cd -
76
77 %install
78 cd CMake
79 %make_install
80 cd -
81
82 %define tizen_sign 1
83 %define tizen_sign_base %{_pkg_dir}
84 %define tizen_sign_level public
85 %define tizen_author_sign 1
86 %define tizen_dist_sign 1
87 %find_lang lockscreen
88
89 %post
90 /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %files -f lockscreen.lang
95 %manifest org.tizen.lockscreen.manifest
96 %defattr(-,root,root,-)
97 %{_pkg_dir}/bin/lockscreen
98 %{_pkg_dir}/res/images/*.png
99 %{_pkg_dir}/res/images/*.jpg
100 %{_pkg_dir}/res/edje/*.edj
101 %{_pkg_dir}/res/locale/*/LC_MESSAGES/*
102 %{_sys_packages_dir}/org.tizen.lockscreen.xml
103 %{_sys_icons_dir}/lockscreen.png
104 %{_pkg_dir}/author-signature.xml
105 %{_pkg_dir}/signature1.xml