c56f9b79a777610f06d60e733048fc8ca3c51a54
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 Name:       org.tizen.lockscreen
2 Summary:    Lockscreen app
3 Group:      Applications/Core Applications
4 Version:    0.0.1
5 Release:    1
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  cmake
10 BuildRequires:  edje-tools
11 BuildRequires:  gettext-tools
12 BuildRequires:  hash-signer
13 BuildRequires:  pkgconfig(bundle)
14 BuildRequires:  pkgconfig(capi-system-info)
15 BuildRequires:  pkgconfig(capi-system-runtime-info)
16 BuildRequires:  pkgconfig(capi-system-device)
17 BuildRequires:  pkgconfig(capi-system-system-settings)
18 BuildRequires:  pkgconfig(capi-appfw-application)
19 BuildRequires:  pkgconfig(capi-appfw-app-manager)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(elementary)
22 BuildRequires:  pkgconfig(notification)
23 BuildRequires:  pkgconfig(minicontrol-viewer)
24 BuildRequires:  pkgconfig(feedback)
25 BuildRequires:  pkgconfig(tzsh-lockscreen-service)
26 BuildRequires:  pkgconfig(libtzplatform-config)
27 BuildRequires:  pkgconfig(capi-base-utils-i18n)
28 BuildRequires:  pkgconfig(capi-telephony)
29
30 %description
31 Lockscreen application for Tizen.
32
33 %prep
34 %setup -q
35
36 %build
37
38 %define _pkg_dir %{TZ_SYS_RO_APP}/%{name}
39 %define _pkg_shared_dir %{_pkg_dir}/shared
40 %define _pkg_data_dir %{_pkg_dir}/data
41 %define _sys_icons_dir %{_pkg_shared_dir}/res
42 %define _sys_packages_dir %{TZ_SYS_RO_PACKAGES}
43 %define _sys_license_dir %{TZ_SYS_SHARE}/license
44
45 %if 0%{?tizen_build_binary_release_type_eng}
46 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
47 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
48 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
49 %endif
50
51 %ifarch %{arm}
52 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
53 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
54 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
55 %else
56 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
57 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
58 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
59 %endif
60
61
62 cd CMake
63 cmake . -DINSTALL_PREFIX=%{_pkg_dir} \
64         -DSYS_ICONS_DIR=%{_sys_icons_dir} \
65         -DSYS_PACKAGES_DIR=%{_sys_packages_dir}
66 make %{?jobs:-j%jobs}
67 cd -
68
69 %install
70 cd CMake
71 %make_install
72 cd -
73
74 %define tizen_sign 1
75 %define tizen_sign_base %{_pkg_dir}
76 %define tizen_sign_level public
77 %define tizen_author_sign 1
78 %define tizen_dist_sign 1
79 %find_lang lockscreen
80
81 %post
82 /sbin/ldconfig
83
84 %postun -p /sbin/ldconfig
85
86 %files -f lockscreen.lang
87 %manifest org.tizen.lockscreen.manifest
88 %defattr(-,root,root,-)
89 %{_pkg_dir}/bin/lockscreen
90 %{_pkg_dir}/res/images/*.png
91 %{_pkg_dir}/res/images/*.jpg
92 %{_pkg_dir}/res/edje/*.edj
93 %{_pkg_dir}/res/locale/*/LC_MESSAGES/*
94 %{_sys_packages_dir}/org.tizen.lockscreen.xml
95 %{_sys_icons_dir}/lockscreen.png
96 %{_pkg_dir}/author-signature.xml
97 %{_pkg_dir}/signature1.xml