3 %define AppInstallPath /usr/apps/org.tizen.lockscreen
4 %define Exec lockscreen
6 Name: org.tizen.lockscreen
7 Summary: Lockscreen app
11 Source0: %{name}-%{version}.tar.gz
13 %if "%{profile}" == "wearable"
14 ExcludeArch: %{arm} %ix86 x86_64
17 %if "%{profile}" == "tv"
18 ExcludeArch: %{arm} %ix86 x86_64
21 BuildRequires: pkgconfig(appcore-efl)
22 BuildRequires: pkgconfig(ecore)
23 BuildRequires: pkgconfig(eina)
24 BuildRequires: pkgconfig(evas)
25 BuildRequires: pkgconfig(bundle)
26 BuildRequires: pkgconfig(capi-system-sensor)
27 BuildRequires: pkgconfig(capi-system-info)
28 BuildRequires: pkgconfig(capi-system-runtime-info)
29 BuildRequires: pkgconfig(capi-system-system-settings)
30 BuildRequires: pkgconfig(capi-system-device)
31 BuildRequires: pkgconfig(capi-appfw-application)
32 BuildRequires: pkgconfig(capi-appfw-preference)
33 BuildRequires: pkgconfig(capi-appfw-app-manager)
34 BuildRequires: pkgconfig(deviced)
35 BuildRequires: pkgconfig(edje)
36 BuildRequires: pkgconfig(aul)
37 BuildRequires: pkgconfig(ail)
38 BuildRequires: pkgconfig(dlog)
39 BuildRequires: pkgconfig(glib-2.0)
40 BuildRequires: pkgconfig(dbus-1)
41 BuildRequires: pkgconfig(dbus-glib-1)
42 BuildRequires: pkgconfig(elementary)
43 BuildRequires: pkgconfig(notification)
44 BuildRequires: pkgconfig(minicontrol-viewer)
45 BuildRequires: pkgconfig(security-server)
46 BuildRequires: pkgconfig(minicontrol-monitor)
47 BuildRequires: pkgconfig(ui-gadget-1)
48 BuildRequires: pkgconfig(feedback)
49 BuildRequires: pkgconfig(msg-service)
50 BuildRequires: pkgconfig(tapi)
51 BuildRequires: pkgconfig(efl-extension)
52 BuildRequires: pkgconfig(key-manager)
53 BuildRequires: pkgconfig(accounts-svc)
55 BuildRequires: edje-tools
56 BuildRequires: gettext-tools
57 #BuildRequires: model-build-features
60 BuildRequires: pkgconfig(ecore-wayland)
62 BuildRequires: pkgconfig(ecore-x)
63 BuildRequires: pkgconfig(utilX)
67 Lockscreen application for Tizen.
73 %if 0%{?tizen_build_binary_release_type_eng}
74 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
75 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
76 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
80 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
81 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
82 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
84 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
85 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
86 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
90 export WAYLAND_SUPPORT=On
91 export X11_SUPPORT=Off
93 export WAYLAND_SUPPORT=Off
97 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}" -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
107 %postun -p /sbin/ldconfig
110 %manifest org.tizen.lockscreen.manifest
111 %defattr(-,root,root,-)
112 %{AppInstallPath}/bin/lockscreen
113 %{AppInstallPath}/res/images/*.png
114 %{AppInstallPath}/res/edje/*.edj
115 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
116 /usr/share/packages/org.tizen.lockscreen.xml