[Other]Upgrade version
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %define PREFIX /usr/apps/org.tizen.lockscreen
2
3 Name:       org.tizen.lockscreen
4 Summary:    lockscreen application
5 Version:    0.1.7
6 Release:    1
7 Group:      TBD
8 License:    Apache
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-appfw-application)
11 BuildRequires: pkgconfig(ecore-x)
12 BuildRequires: pkgconfig(appcore-efl)
13 BuildRequires: pkgconfig(utilX)
14 BuildRequires: pkgconfig(ail)
15 BuildRequires: pkgconfig(notification)
16 BuildRequires: pkgconfig(security-server)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(capi-system-info)
19
20 BuildRequires: cmake
21 BuildRequires: gettext
22 BuildRequires: edje-tools
23 %description
24 lockscreen application.
25
26 %prep
27 %setup -q
28
29 %build
30 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--as-needed";export LDFLAGS
31 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
32 make %{?jobs:-j%jobs}
33
34 %install
35 %make_install
36 mkdir -p %{buildroot}/usr/apps/org.tizen.lockscreen/data
37 mkdir -p %{buildroot}/usr/share/license
38 install -m 0755 LICENSE.Flora %{buildroot}/usr/share/license/org.tizen.lockscreen
39
40 %post
41 /sbin/ldconfig
42
43 GOPTION="-g 6514"
44
45 %postun -p /sbin/ldconfig
46
47 %files
48 %manifest org.tizen.lockscreen.manifest
49 %defattr(-,root,root,-)
50 %attr(-,inhouse,inhouse) %dir /usr/apps/org.tizen.lockscreen/data
51 /usr/apps/org.tizen.lockscreen/*
52 /usr/share/packages/org.tizen.lockscreen.xml
53 /usr/share/license/org.tizen.lockscreen