Remove security-server dependency
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %bcond_with wayland
2
3 %define AppInstallPath /usr/apps/org.tizen.lockscreen
4 %define Exec lockscreen
5
6 Name:       org.tizen.lockscreen
7 Summary:    Lockscreen app
8 Version:    0.0.1
9 Release:    1
10 License:    Apache-2.0
11 Source0:    %{name}-%{version}.tar.gz
12
13 %if "%{profile}" == "wearable"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 %if "%{profile}" == "tv"
18 ExcludeArch: %{arm} %ix86 x86_64
19 %endif
20
21 BuildRequires:  pkgconfig(appcore-efl)
22 BuildRequires:  pkgconfig(ecore)
23 BuildRequires:  pkgconfig(eina)
24 BuildRequires:  pkgconfig(evas)
25 BuildRequires:  pkgconfig(bundle)
26 BuildRequires:  pkgconfig(capi-system-sensor)
27 BuildRequires:  pkgconfig(capi-system-info)
28 BuildRequires:  pkgconfig(capi-system-runtime-info)
29 BuildRequires:  pkgconfig(capi-system-system-settings)
30 BuildRequires:  pkgconfig(capi-system-device)
31 BuildRequires:  pkgconfig(capi-appfw-application)
32 BuildRequires:  pkgconfig(capi-appfw-preference)
33 BuildRequires:  pkgconfig(capi-appfw-app-manager)
34 BuildRequires:  pkgconfig(capi-ui-efl-util)
35 BuildRequires:  pkgconfig(deviced)
36 BuildRequires:  pkgconfig(edje)
37 BuildRequires:  pkgconfig(aul)
38 BuildRequires:  pkgconfig(ail)
39 BuildRequires:  pkgconfig(dlog)
40 BuildRequires:  pkgconfig(glib-2.0)
41 BuildRequires:  pkgconfig(dbus-1)
42 BuildRequires:  pkgconfig(dbus-glib-1)
43 BuildRequires:  pkgconfig(elementary)
44 BuildRequires:  pkgconfig(notification)
45 BuildRequires:  pkgconfig(minicontrol-viewer)
46 BuildRequires:  pkgconfig(minicontrol-monitor)
47 BuildRequires:  pkgconfig(ui-gadget-1)
48 BuildRequires:  pkgconfig(feedback)
49 BuildRequires:  pkgconfig(msg-service)
50 BuildRequires:  pkgconfig(tapi)
51 BuildRequires:  pkgconfig(efl-extension)
52 BuildRequires:  pkgconfig(key-manager)
53 BuildRequires:  pkgconfig(accounts-svc)
54 BuildRequires:  pkgconfig(tzsh-lockscreen-service)
55 BuildRequires:  cmake
56 BuildRequires:  edje-tools
57 BuildRequires:  gettext-tools
58 #BuildRequires:  model-build-features
59
60 BuildRequires:  pkgconfig(ecore-wayland)
61
62 %description
63 Lockscreen application for Tizen.
64
65 %prep
66 %setup -q
67
68 %build
69 %if 0%{?tizen_build_binary_release_type_eng}
70 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
71 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
72 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
73 %endif
74
75 %ifarch %{arm}
76 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
77 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
78 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
79 %else
80 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
81 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
82 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
83 %endif
84
85 %if %{with wayland}
86 export WAYLAND_SUPPORT=On
87 export X11_SUPPORT=Off
88 %else
89 export WAYLAND_SUPPORT=Off
90 export X11_SUPPORT=On
91 %endif
92
93 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}" -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
94 make %{?jobs:-j%jobs}
95
96 %install
97 rm -rf %{buildroot}
98 %make_install
99
100 %post
101 /sbin/ldconfig
102
103 %postun -p /sbin/ldconfig
104
105 %files
106 %manifest org.tizen.lockscreen.manifest
107 %defattr(-,root,root,-)
108 %{AppInstallPath}/bin/lockscreen
109 %{AppInstallPath}/res/images/*.png
110 %{AppInstallPath}/res/images/*.jpg
111 %{AppInstallPath}/res/edje/*.edj
112 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
113 /usr/share/packages/org.tizen.lockscreen.xml