Remove rule file
[apps/core/preloaded/lockscreen.git] / packaging / org.tizen.lockscreen.spec
1 %bcond_with wayland
2
3 %define AppInstallPath /usr/apps/org.tizen.lockscreen
4 %define Exec lockscreen
5
6 Name:       org.tizen.lockscreen
7 Summary:    Lockscreen app
8 Version:    0.0.1
9 Release:    1
10 License:    Apache-2.0
11 Source0:    %{name}-%{version}.tar.gz
12
13 %if "%{?tizen_profile_name}" == "wearable"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 %if "%{?tizen_profile_name}"=="tv"
18 ExcludeArch: %{arm} %ix86 x86_64
19 %endif
20
21 BuildRequires:  pkgconfig(appcore-efl)
22 BuildRequires:  pkgconfig(ecore)
23 BuildRequires:  pkgconfig(eina)
24 BuildRequires:  pkgconfig(evas)
25 BuildRequires:  pkgconfig(bundle)
26 BuildRequires:  pkgconfig(capi-system-sensor)
27 BuildRequires:  pkgconfig(capi-system-info)
28 BuildRequires:  pkgconfig(capi-system-runtime-info)
29 BuildRequires:  pkgconfig(capi-system-system-settings)
30 BuildRequires:  pkgconfig(capi-system-device)
31 BuildRequires:  pkgconfig(capi-appfw-application)
32 BuildRequires:  pkgconfig(capi-appfw-preference)
33 BuildRequires:  pkgconfig(capi-appfw-app-manager)
34 BuildRequires:  pkgconfig(deviced)
35 BuildRequires:  pkgconfig(edje)
36 BuildRequires:  pkgconfig(aul)
37 BuildRequires:  pkgconfig(ail)
38 BuildRequires:  pkgconfig(dlog)
39 BuildRequires:  pkgconfig(glib-2.0)
40 BuildRequires:  pkgconfig(dbus-1)
41 BuildRequires:  pkgconfig(dbus-glib-1)
42 BuildRequires:  pkgconfig(elementary)
43 BuildRequires:  pkgconfig(notification)
44 BuildRequires:  pkgconfig(minicontrol-viewer)
45 BuildRequires:  pkgconfig(contacts-service2)
46 BuildRequires:  pkgconfig(security-server)
47 BuildRequires:  pkgconfig(minicontrol-monitor)
48 BuildRequires:  pkgconfig(ui-gadget-1)
49 BuildRequires:  pkgconfig(feedback)
50 BuildRequires:  pkgconfig(msg-service)
51 BuildRequires:  pkgconfig(tapi)
52 BuildRequires:  pkgconfig(efl-assist)
53 BuildRequires:  pkgconfig(efl-extension)
54 BuildRequires:  pkgconfig(key-manager)
55 BuildRequires:  pkgconfig(accounts-svc)
56 BuildRequires:  cmake
57 BuildRequires:  edje-tools
58 BuildRequires:  gettext-tools
59 #BuildRequires:  model-build-features
60
61 %if %{with wayland}
62 BuildRequires:  pkgconfig(ecore-wayland)
63 %else
64 BuildRequires:  pkgconfig(ecore-x)
65 BuildRequires:  pkgconfig(utilX)
66 %endif
67
68 %description
69 Lockscreen application for Tizen.
70
71 %prep
72 %setup -q
73
74 %build
75 %if 0%{?tizen_build_binary_release_type_eng}
76 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
77 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
78 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
79 %endif
80
81 %ifarch %{arm}
82 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
83 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
84 export FFLAGS="$FFLAGS -DTIZEN_BUILD_TARGET"
85 %else
86 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
87 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
88 export FFLAGS="$FFLAGS -DTIZEN_BUILD_EMULATOR"
89 %endif
90
91 %if %{with wayland}
92 export WAYLAND_SUPPORT=On
93 export X11_SUPPORT=Off
94 %else
95 export WAYLAND_SUPPORT=Off
96 export X11_SUPPORT=On
97 %endif
98
99 cmake . -DCMAKE_INSTALL_PREFIX="%{AppInstallPath}" -DCMAKE_TARGET="%{Exec}" -DCMAKE_PACKAGE="%{name}" -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
100 make %{?jobs:-j%jobs}
101
102 %install
103 rm -rf %{buildroot}
104 %make_install
105
106 %post
107 /sbin/ldconfig
108
109 %postun -p /sbin/ldconfig
110
111 %files
112 %manifest org.tizen.lockscreen.manifest
113 %defattr(-,root,root,-)
114 %{AppInstallPath}/bin/lockscreen
115 %{AppInstallPath}/res/images/*.png
116 %{AppInstallPath}/res/edje/*.edj
117 %{AppInstallPath}/res/locale/*/LC_MESSAGES/*
118 /usr/share/packages/org.tizen.lockscreen.xml