Update package version to 0.1.161208
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 # For the backward compatibility, this is to be built for
2 # wearable profile or 4.0 unified building environment.
3 # This cannot be built for non-wearable in conventional 3.0 build environment.
4 # Note that it is not a good idea to limit building with ExcludeArch because there are new architectures being tested.
5 # Use ExclusiveArch istead.
6 %if "%{?profile}" == "mobile" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "common"
7 ExclusiveArch:  none
8 %endif
9
10 Name: org.tizen.inputdelegator
11 Summary: Input Delegator Application
12 Version: 0.1.161208
13 Release: 1
14 Group: Applications
15 License: Apache-2.0
16 Source0: %{name}-%{version}.tar.gz
17
18 %define enable_log_manager 1
19
20 BuildRequires:  pkgconfig(ecore-wayland)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(edje)
24 BuildRequires:  pkgconfig(edbus)
25
26 BuildRequires: cmake
27 BuildRequires: edje-bin
28 BuildRequires: gettext
29
30 BuildRequires: pkgconfig(dlog)
31 BuildRequires: pkgconfig(capi-appfw-application)
32 BuildRequires: pkgconfig(capi-media-wav-player)
33 BuildRequires: pkgconfig(capi-system-device)
34 BuildRequires: pkgconfig(eina)
35 BuildRequires: pkgconfig(elementary)
36 BuildRequires: pkgconfig(efl-extension)
37 BuildRequires: pkgconfig(feedback)
38 BuildRequires: pkgconfig(stt)
39 BuildRequires: pkgconfig(vconf)
40 BuildRequires: pkgconfig(db-util)
41 BuildRequires: pkgconfig(sqlite3)
42 BuildRequires: pkgconfig(capi-media-audio-io)
43
44
45 %if %{enable_log_manager}
46 BuildRequires:  pkgconfig(bundle)
47 %endif
48
49 %define _appdir         /usr/apps
50 %define _app_destdir    %{_appdir}/%{name}
51
52 # Sandboxed prefix '/'
53 %define _app_prefix     /
54 %define _app_localedir %{_app_prefix}res/locale
55
56 %description
57 Input Delegator Application for Wearable environment
58
59 %prep
60 %setup -q
61
62 %build
63 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
64 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
65 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
66
67 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
68
69
70 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
71         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
72         -DENABLE_LOG_MANAGER=%{enable_log_manager}
73
74 # compile warning & error filtering
75 make %{?jobs:-j%jobs} \
76   2>&1 | sed \
77   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
78   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
79
80 %install
81 rm -rf %{buildroot}
82 make install DESTDIR=%{buildroot}%{_app_destdir}
83
84 mkdir -p %{buildroot}%{_datadir}/packages/
85 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
86
87 %post
88 #nothing
89
90 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
91
92 %files
93 %manifest org.tizen.inputdelegator.manifest
94 %defattr(-,root,root,-)
95 %license LICENSE
96 %{_datadir}/packages/org.tizen.inputdelegator.xml
97 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
98 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
99 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
100 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
101 %{_app_destdir}%{_app_prefix}/res/images/*
102 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
103 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo