Modify SMACK manifest and remove SMACK rule file(.rule) according three domain model
[apps/core/preloaded/image-viewer.git] / packaging / org.tizen.image-viewer.spec
1 Name: org.tizen.image-viewer
2 Summary: Image Viewer
3 Version: 1.0.83
4 Release: 1
5 Group: Applications/Photo
6 License: Flora
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(edje)
12 BuildRequires: pkgconfig(evas)
13 BuildRequires: pkgconfig(ecore)
14 BuildRequires: pkgconfig(ecore-x)
15 BuildRequires: pkgconfig(ecore-input)
16 BuildRequires: pkgconfig(bundle)
17 BuildRequires: pkgconfig(sensor)
18 BuildRequires: pkgconfig(ui-gadget-1)
19 BuildRequires: pkgconfig(utilX)
20 BuildRequires: pkgconfig(appsvc)
21 BuildRequires: pkgconfig(vconf)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(capi-appfw-application)
24 BuildRequires: cmake
25 BuildRequires: edje-bin
26 BuildRequires: embryo-bin
27 Requires: pkgmgr
28
29 %description
30 Tizen 2.x Reference Application.
31 Various kinds of image files are supported.
32
33 %prep
34 %setup -q -n %{name}-%{version}
35 cp %{SOURCE1001} .
36
37 %build
38 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}/apps/%{name}/
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44 mkdir -p %{buildroot}/%{_datarootdir}/license
45
46 %files
47 %manifest %{name}.manifest
48 %defattr(-,root,root,-)
49 /opt/usr/apps/%{name}/*
50 %{_prefix}/apps/%{name}/*
51 %{_datarootdir}/icons/default/small/%{name}.png
52 %{_datarootdir}/packages/%{name}.xml
53 %{_datarootdir}/license/%{name}