Merge "add manifest file to avoid smack error" into tizen
[profile/tv/apps/native/air_favorite.git] / packaging / org.tizen.favorite.spec
1 Name: org.tizen.favorite
2 Summary: Favorite application for Tizen TV based on AirFlex UX
3 Version: 0.1
4 Release: 1
5 Group: Applications/Core Applications
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8 Source1: %{name}.manifest
9 Packager: hj903.jo@samsung.com
10
11 BuildRequires: cmake
12 BuildRequires: pkgconfig(elementary)
13 BuildRequires: pkgconfig(capi-appfw-application)
14 BuildRequires: pkgconfig(app-utils)
15 BuildRequires: pkgconfig(pkgmgr-info)
16 BuildRequires: pkgconfig(capi-content-media-content)
17 BuildRequires: pkgconfig(glib-2.0)
18 BuildRequires: pkgconfig(capi-web-bookmark)
19 BuildRequires: pkgconfig(tv-service)
20 BuildRequires: pkgconfig(ui-gadget-1)
21
22 %define _appdir /usr/apps/%{name}
23 %define _bindir %{_appdir}/bin
24 %define _resdir %{_appdir}/res
25 %define _edjedir %{_resdir}/edje
26 %define _imgdir %{_resdir}/images
27 %define _pkgdir %{_datadir}/packages
28 %define _desktop_icondir /usr/share/icons
29
30 %description
31 Favorite application shows the contents which were registered as favorite.
32
33 %prep
34 %setup -q
35 cp %{SOURCE1} .
36
37 %build
38 cmake \
39         -DCMAKE_INSTALL_PREFIX=%{_appdir} \
40         -DPACKAGE_NAME=%{name} \
41         -DVERSION=%{version} \
42         -DBINDIR=%{_bindir} \
43         -DRESDIR=%{_resdir} \
44         -DEDJEDIR=%{_edjedir} \
45         -DIMGDIR=%{_imgdir} \
46         -DDESKTOP_ICONDIR=%{_desktop_icondir} \
47         -DDESKTOP_ICON=%{name}.png \
48         -DPACKAGEDIR=%{_pkgdir}
49
50 make %{?jobs:-j%jobs}
51
52 # Copies the executables to appropriate location
53 %install
54 %make_install
55
56 %clean
57 rm -rf %{buildroot}
58
59 %files
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %{_bindir}/*
63 %{_resdir}/*
64 %{_pkgdir}/%{name}.xml
65 %{_desktop_icondir}/%{name}.png