5b58db4f9eab3d2106a97c7bf8980ea91be8bb2c
[apps/core/preloaded/calendar.git] / packaging / org.tizen.efl-calendar.spec
1 Name:       org.tizen.efl-calendar
2 Summary:    Calendar application
3 Version:    0.5.67
4 Release:    1
5 Group:      devel
6 License:    Samsung Proprietary License
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: packaging/org.tizen.efl-calendar.manifest 
9 BuildRequires:  pkgconfig(appcore-efl)
10 BuildRequires:  pkgconfig(appsvc)
11 BuildRequires:  pkgconfig(utilX)
12 BuildRequires:  pkgconfig(calendar)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(alarm-service)
15 BuildRequires:  pkgconfig(utilX)
16 BuildRequires:  pkgconfig(mm-player)
17 BuildRequires:  pkgconfig(accounts-svc)
18 BuildRequires:  pkgconfig(ui-gadget)
19 BuildRequires:  pkgconfig(heynoti)
20 BuildRequires:  pkgconfig(ui-gadget)
21 BuildRequires:  pkgconfig(pmapi)
22 BuildRequires:  pkgconfig(icu-i18n)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-media-sound-manager)
25 BuildRequires:  pkgconfig(capi-media-wav-player)
26
27 BuildRequires:  cmake
28 BuildRequires:  edje-bin
29 BuildRequires:  embryo-bin
30 BuildRequires:  gettext-devel
31
32 %description -n org.tizen.efl-calendar
33 Calendar application
34
35
36 %package -n org.tizen.calendar-viewer
37 Summary:    Calendar viewer (EFL)
38 Group:      TO_BE/FILLED_IN
39 Requires:   org.tizen.efl-calendar = %{version}-%{release}
40
41 %description -n org.tizen.calendar-viewer
42 Calendar viewer
43
44 %package -n libug-calendar-efl
45 Summary:    Calendar UI gadget (EFL)
46 Group:      devel
47 Requires:   %{name} = %{version}-%{release}
48 Requires:   org.tizen.efl-calendar
49
50 %description -n libug-calendar-efl
51 Calendar UI gadget
52
53
54 %prep
55 %setup -q
56
57
58 %build
59 cp %{SOURCE1001} .
60 %define PREFIX    "/opt/apps/org.tizen.efl-calendar"
61 %define RESDIR    "/opt/apps/org.tizen.efl-calendar/res"
62 %define DATADIR   "/opt/apps/org.tizen.efl-calendar/data"
63
64 cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX}
65 make %{?jobs:-j%jobs}
66
67 %install
68 rm -rf %{buildroot}
69 %make_install
70
71
72
73
74 %post
75
76 # Automatically added by dh_makeshlibs
77 if [ "$1" = "configure" ]; then
78         ldconfig
79 fi
80 # End automatically added section
81
82 # 5000 is inhouse user id
83 # do not use relative path
84 vconftool set -t int db/calendar/focusview 0 -u 5000
85 vconftool set -t int db/calendar/send 0 -u 5000
86 vconftool set -t int db/calendar/timezone_on_off 0 -u 5000
87 vconftool set -t string db/calendar/timezone_path "Asia/Seoul" -u 5000
88 vconftool set -t string db/calendar/timezone_city "IDS_WCL_BODY_CITYNAME_SEOUL" -u 5000
89 vconftool set -t string db/calendar/timezone_offset "GMT+9" -u 5000
90
91 mkdir -p /opt/data/ug-calendar
92 chgrp 6003 /opt/data/ug-calendar
93 chmod 770 /opt/data/ug-calendar
94
95 %postun
96
97 %files -n org.tizen.efl-calendar
98 %manifest org.tizen.efl-calendar.manifest
99
100 %defattr(-,root,root,-)
101 /opt/apps/org.tizen.efl-calendar/bin/efl-calendar
102 /opt/apps/org.tizen.efl-calendar/data/
103 /opt/apps/org.tizen.efl-calendar/res/locale/*
104 /opt/apps/org.tizen.efl-calendar/res/icons/*
105 /opt/apps/org.tizen.efl-calendar/res/edje/*.edj
106 /opt/apps/org.tizen.efl-calendar/res/sounds/*
107 /opt/share/applications/org.tizen.efl-calendar.desktop
108
109 %files -n org.tizen.calendar-viewer
110 %manifest org.tizen.efl-calendar.manifest
111 %defattr(-,root,root,-)
112 /opt/apps/org.tizen.calendar-viewer/bin/calendar-viewer
113 /opt/share/applications/org.tizen.calendar-viewer.desktop
114
115 %files -n libug-calendar-efl
116 %manifest org.tizen.efl-calendar.manifest
117 %defattr(-,root,root,-)
118 /opt/ug/lib/*.so