Remove some rule
[platform/framework/web/data-provider-slave.git] / packaging / org.tizen.data-provider-slave.spec
1 Name: org.tizen.data-provider-slave
2 Summary: Plugin type livebox service provider.
3 Version: 0.9.7
4 Release: 1
5 Group: frameowrk/livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(ail)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(aul)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(sqlite3)
15 BuildRequires: pkgconfig(db-util)
16 BuildRequires: pkgconfig(glib-2.0)
17 BuildRequires: pkgconfig(gio-2.0)
18 BuildRequires: pkgconfig(bundle)
19 BuildRequires: pkgconfig(ecore-x)
20 BuildRequires: pkgconfig(provider)
21 BuildRequires: pkgconfig(heap-monitor)
22 BuildRequires: pkgconfig(livebox-service)
23 BuildRequires: pkgconfig(capi-appfw-application)
24 BuildRequires: pkgconfig(capi-appfw-app-manager)
25 BuildRequires: pkgconfig(ecore)
26 BuildRequires: pkgconfig(edje)
27 BuildRequires: pkgconfig(evas)
28 BuildRequires: pkgconfig(livebox)
29 BuildRequires: pkgconfig(elementary)
30
31 %description
32 Plugin type liveboxes are managed by this.
33 Supporting the EFL.
34
35 %prep
36 %setup -q
37
38 %build
39 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
40 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
41 CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46 mkdir -p %{buildroot}/%{_datarootdir}/license
47
48 %post
49
50 %files -n org.tizen.data-provider-slave
51 %manifest org.tizen.data-provider-slave.manifest
52 %defattr(-,root,root,-)
53 %{_prefix}/apps/org.tizen.data-provider-slave/bin/data-provider-slave
54 %{_datarootdir}/packages/org.tizen.data-provider-slave.xml
55 %{_datarootdir}/license/*
56 %{_sysconfdir}/smack/accesses2.d/org.tizen.data-provider-slave.rule
57
58 # End of a file