Manage the updated status.
[platform/framework/web/data-provider-slave.git] / packaging / org.tizen.data-provider-slave.spec
1 %define app_data /opt/usr/apps/org.tizen.data-provider-slave/data
2
3 Name: org.tizen.data-provider-slave
4 Summary: Plugin type livebox service provider.
5 Version: 0.10.7
6 Release: 1
7 Group: HomeTF/Livebox
8 License: Flora License
9 Source0: %{name}-%{version}.tar.gz
10 BuildRequires: cmake, gettext-tools, coreutils
11 BuildRequires: pkgconfig(appcore-efl)
12 BuildRequires: pkgconfig(ail)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(aul)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(db-util)
18 BuildRequires: pkgconfig(glib-2.0)
19 BuildRequires: pkgconfig(gio-2.0)
20 BuildRequires: pkgconfig(bundle)
21 BuildRequires: pkgconfig(ecore-x)
22 BuildRequires: pkgconfig(provider)
23 BuildRequires: pkgconfig(heap-monitor)
24 BuildRequires: pkgconfig(livebox-service)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(capi-appfw-app-manager)
27 BuildRequires: pkgconfig(ecore)
28 BuildRequires: pkgconfig(edje)
29 BuildRequires: pkgconfig(evas)
30 BuildRequires: pkgconfig(livebox)
31 BuildRequires: pkgconfig(elementary)
32 BuildRequires: pkgconfig(capi-system-system-settings)
33
34 %description
35 Plugin type liveboxes are managed by this.
36 Supporting the EFL.
37 Supporting the In-house livebox only.
38
39 %prep
40 %setup -q
41
42 %build
43 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
44 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
45 CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49 %make_install
50 mkdir -p %{buildroot}/%{_datarootdir}/license
51 mkdir -p %{buildroot}%{app_data}
52
53 %post
54 chown 5000:5000 %{app_data}
55 chmod 755 %{app_data}
56
57 %files -n org.tizen.data-provider-slave
58 %manifest org.tizen.data-provider-slave.manifest
59 %defattr(-,root,root,-)
60 %{_prefix}/apps/org.tizen.data-provider-slave/bin/data-provider-slave
61 %{_datarootdir}/packages/org.tizen.data-provider-slave.xml
62 %{_datarootdir}/license/*
63 %{_sysconfdir}/smack/accesses2.d/org.tizen.data-provider-slave.rule
64 %dir %{app_data}
65
66 # End of a file