Remove code of the deprecated feature
[platform/framework/web/data-provider-slave.git] / packaging / org.tizen.data-provider-slave.spec
1 Name: org.tizen.data-provider-slave
2 Summary: Slave data provider
3 Version: 0.8.16
4 Release: 1
5 Group: main/app
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(ail)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(aul)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(sqlite3)
15 BuildRequires: pkgconfig(db-util)
16 BuildRequires: pkgconfig(glib-2.0)
17 BuildRequires: pkgconfig(gio-2.0)
18 BuildRequires: pkgconfig(bundle)
19 BuildRequires: pkgconfig(ecore-x)
20 BuildRequires: pkgconfig(provider)
21 BuildRequires: pkgconfig(heap-monitor)
22 BuildRequires: pkgconfig(livebox-service)
23 BuildRequires: pkgconfig(capi-appfw-application)
24 BuildRequires: pkgconfig(capi-appfw-app-manager)
25 BuildRequires: pkgconfig(ecore)
26 BuildRequires: pkgconfig(edje)
27 BuildRequires: pkgconfig(evas)
28 BuildRequires: pkgconfig(livebox)
29 BuildRequires: pkgconfig(elementary)
30
31 %description
32 Loading livebox and managing their life-cycle to generate contents properly.
33
34 %prep
35 %setup -q
36
37 %build
38 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
39 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
40 CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45 mkdir -p %{buildroot}/usr/share/license
46
47 %post
48
49 %files -n org.tizen.data-provider-slave
50 %manifest org.tizen.data-provider-slave.manifest
51 %defattr(-,root,root,-)
52 /usr/apps/org.tizen.data-provider-slave/bin/data-provider-slave
53 /usr/share/packages/org.tizen.data-provider-slave.xml
54 /usr/share/license/*