Update the conf file.
[platform/framework/web/data-provider-slave.git] / packaging / org.tizen.data-provider-slave.spec
1 %define app_data /opt/usr/apps/org.tizen.data-provider-slave/data
2
3 Name: org.tizen.data-provider-slave
4 Summary: Plugin type livebox service provider.
5 Version: 0.9.15
6 Release: 1
7 Group: frameowrk/livebox
8 License: Flora License
9 Source0: %{name}-%{version}.tar.gz
10 BuildRequires: cmake, gettext-tools, coreutils
11 BuildRequires: pkgconfig(appcore-efl)
12 BuildRequires: pkgconfig(ail)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(aul)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(db-util)
18 BuildRequires: pkgconfig(glib-2.0)
19 BuildRequires: pkgconfig(gio-2.0)
20 BuildRequires: pkgconfig(bundle)
21 BuildRequires: pkgconfig(ecore-x)
22 BuildRequires: pkgconfig(provider)
23 BuildRequires: pkgconfig(heap-monitor)
24 BuildRequires: pkgconfig(livebox-service)
25 BuildRequires: pkgconfig(capi-appfw-application)
26 BuildRequires: pkgconfig(capi-appfw-app-manager)
27 BuildRequires: pkgconfig(ecore)
28 BuildRequires: pkgconfig(edje)
29 BuildRequires: pkgconfig(evas)
30 BuildRequires: pkgconfig(livebox)
31 BuildRequires: pkgconfig(elementary)
32
33 %description
34 Plugin type liveboxes are managed by this.
35 Supporting the EFL.
36
37 %prep
38 %setup -q
39
40 %build
41 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
42 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
43 CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 %make_install
48 mkdir -p %{buildroot}/%{_datarootdir}/license
49 mkdir -p %{buildroot}%{app_data}
50
51 %post
52
53 %files -n org.tizen.data-provider-slave
54 %manifest org.tizen.data-provider-slave.manifest
55 %defattr(-,root,root,-)
56 %{_prefix}/apps/org.tizen.data-provider-slave/bin/data-provider-slave
57 %{_datarootdir}/packages/org.tizen.data-provider-slave.xml
58 %{_datarootdir}/license/*
59 %{_sysconfdir}/smack/accesses2.d/org.tizen.data-provider-slave.rule
60 %attr(-,app,app) %dir %{app_data}
61
62 # End of a file