Add HW back callback event
[platform/core/connectivity/bt-syspopup.git] / packaging / org.tizen.bt-syspopup.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 %bcond_with wayland
5
6 Name:       org.tizen.bt-syspopup
7 Summary:    bluetooth system-popup application (bluetooth system popup)
8 Version:    0.3.2
9 Release:    0
10 Group:      main
11 License:    Flora-1.1
12 Source0:    %{name}-%{version}.tar.gz
13 BuildRequires:  pkgconfig(evas)
14 %if "%{?profile}" == "wearable"
15 BuildRequires:  pkgconfig(syspopup-caller)
16 %else
17 BuildRequires:  pkgconfig(efl-assist)
18 BuildRequires:  pkgconfig(notification)
19 %endif
20 BuildRequires: pkgconfig(efl-extension)
21 BuildRequires:  pkgconfig(ecore-input)
22 BuildRequires:  pkgconfig(ethumb)
23 BuildRequires:  pkgconfig(elementary)
24 BuildRequires:  pkgconfig(efreet)
25 BuildRequires:  pkgconfig(sensor)
26 BuildRequires:  pkgconfig(syspopup)
27 BuildRequires:  pkgconfig(dlog)
28 BuildRequires:  pkgconfig(dbus-glib-1)
29 BuildRequires:  pkgconfig(glib-2.0)
30 BuildRequires:  pkgconfig(aul)
31 BuildRequires:  pkgconfig(edbus)
32 BuildRequires:  pkgconfig(feedback)
33 BuildRequires:  edje-tools
34 BuildRequires:  pkgconfig(libtzplatform-config)
35 BuildRequires:  pkgconfig(capi-appfw-application)
36 BuildRequires:  pkgconfig(capi-system-device)
37 BuildRequires:  pkgconfig(capi-media-player)
38 BuildRequires:  pkgconfig(deviced)
39 BuildRequires:  pkgconfig(capi-network-bluetooth)
40 BuildRequires:  pkgconfig(vconf)
41
42 BuildRequires:  cmake
43 BuildRequires:  gettext-devel
44
45 %description
46 bluetooth system-popup application (bluetooth system popup).
47
48 %prep
49 %setup -q
50
51
52 %build
53 %if "%{?profile}" == "wearable"
54 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE -DTIZEN_WEARABLE"
55 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
56 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
57 %else
58 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE -DTIZEN_MOBILE"
59 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
60 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
61 %endif
62 export CFLAGS+=" -fpie -fvisibility=hidden"
63 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
64
65 cmake . \
66     -DCMAKE_INSTALL_PREFIX=%{TZ_SYS_RO_APP}/org.tizen.bt-syspopup \
67 %if %{with wayland}
68     -DWAYLAND_SUPPORT=On \
69 %else
70     -DWAYLAND_SUPPORT=Off \
71 %endif
72     #eol
73
74 make %{?jobs:-j%jobs}
75
76 %cmake . \
77         -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
78         -DTZ_SYS_SHARE=%{TZ_SYS_SHARE}
79 make
80
81 %install
82 rm -rf %{buildroot}
83 %make_install
84
85
86 %files
87 %manifest org.tizen.bt-syspopup.manifest
88 %defattr(-,root,root,-)
89 %{TZ_SYS_RO_PACKAGES}/org.tizen.bt-syspopup.xml
90 %{TZ_SYS_RO_APP}/org.tizen.bt-syspopup/bin/bt-syspopup
91 %{TZ_SYS_RO_APP}/org.tizen.bt-syspopup/res/edje/*.edj
92 %{TZ_SYS_SHARE}/icons/default/small/org.tizen.bt-syspopup.png
93 %if "%{?profile}" == "wearable"
94 %{TZ_SYS_RO_APP}/org.tizen.bt-syspopup/shared/res/tables/org.tizen.bt-syspopup_ChangeableColorTable.xml
95 %{TZ_SYS_RO_APP}/org.tizen.bt-syspopup/shared/res/tables/org.tizen.bt-syspopup_FontInfoTable.xml
96 %{TZ_SYS_RO_APP}/org.tizen.bt-syspopup/res/images/*
97 %endif