2 %define _appdir %{_usrdir}/apps
4 Name: org.tizen.bluetooth-share-ui
5 Summary: bluetooth share UI application
10 Source0: %{name}-%{version}.tar.gz
12 %if "%{?profile}" != "mobile"
13 ExcludeArch: %{arm} %ix86 x86_64
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(vconf)
19 BuildRequires: pkgconfig(appcore-efl)
20 BuildRequires: pkgconfig(bundle)
21 BuildRequires: pkgconfig(ecore)
22 BuildRequires: pkgconfig(edbus)
23 BuildRequires: pkgconfig(edje)
24 BuildRequires: pkgconfig(elementary)
25 BuildRequires: pkgconfig(efl-extension)
26 BuildRequires: pkgconfig(evas)
27 BuildRequires: pkgconfig(aul)
28 BuildRequires: pkgconfig(capi-appfw-application)
29 BuildRequires: pkgconfig(capi-network-bluetooth)
30 BuildRequires: pkgconfig(bluetooth-share-api)
31 BuildRequires: pkgconfig(notification)
34 BuildRequires: edje-tools
35 BuildRequires: gettext-devel
36 BuildRequires: hash-signer
38 %define PKG_NAME org.tizen.bluetooth-share-ui
41 bluetooth share UI application
48 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
50 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
52 export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
53 export CFLAGS+=" -fpie -fvisibility=hidden"
54 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
56 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
63 PKG_ID=org.tizen.bluetooth-share-ui
65 %define tizen_sign_base /usr/apps/${PKG_ID}
66 %define tizen_sign_level platform
67 %define tizen_author_sign 1
68 %define tizen_dist_sign 1
70 install -D -m 0644 LICENSE %{buildroot}%{_datadir}/license/org.tizen.bluetooth-share-ui
78 #%defattr(-,root,root,-)
81 %manifest bluetooth-share-ui.manifest
82 %defattr(-,root,root,-)
83 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
84 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
85 %{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
86 %{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
87 %{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
88 %{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
89 %{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
90 %{_datadir}/license/org.tizen.bluetooth-share-ui