Modify the genlist item style for IOT profile
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.6.0
7 Release:    2
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(bundle)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(edbus)
18 BuildRequires:  pkgconfig(edje)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(efl-extension)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-network-bluetooth)
25 BuildRequires:  pkgconfig(capi-system-info)
26 BuildRequires:  pkgconfig(bluetooth-share-api)
27 BuildRequires:  pkgconfig(notification)
28
29 BuildRequires:  cmake
30 BuildRequires:  edje-tools
31 BuildRequires:  gettext-devel
32 BuildRequires:  hash-signer
33
34 %define PKG_NAME %{name}
35
36 %description
37 bluetooth share UI application
38
39
40 %prep
41 %setup -q
42
43 %build
44 export CFLAGS+=" -fpie -fvisibility=hidden"
45 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
46
47 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
48 make %{?jobs:-j%jobs}
49
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54 PKG_ID=%{name}
55 %define tizen_sign 1
56 %define tizen_sign_base /usr/apps/${PKG_ID}
57 %define tizen_sign_level platform
58 %define tizen_author_sign 1
59 %define tizen_dist_sign 1
60
61 %post
62
63 %postun
64
65
66 #%files
67 #%defattr(-,root,root,-)
68
69 %files
70 %manifest bluetooth-share-ui.manifest
71 %license LICENSE
72 %defattr(-,root,root,-)
73 %{_appdir}/%{name}/res/edje/bt-share-layout.edj
74 %{_appdir}/%{name}/res/edje/images.edj
75 %{_appdir}/%{name}/bin/bluetooth-share-ui
76 %{_appdir}/%{name}/author-signature.xml
77 %{_appdir}/%{name}/signature1.xml
78 %{_usrdir}/share/icons/default/small/%{name}.png
79 %{_usrdir}/share/packages/%{name}.xml
80