Remove the dbus-glib-1 dependency
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.2.1
7 Release:    1
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(appcore-efl)
15 BuildRequires:  pkgconfig(bundle)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(edbus)
18 BuildRequires:  pkgconfig(edje)
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(efl-extension)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-network-bluetooth)
25 BuildRequires:  pkgconfig(bluetooth-share-api)
26 BuildRequires:  pkgconfig(notification)
27
28 BuildRequires:  cmake
29 BuildRequires:  edje-tools
30 BuildRequires:  gettext-devel
31 BuildRequires:  hash-signer
32
33 %define PKG_NAME org.tizen.bluetooth-share-ui
34
35 %description
36 bluetooth share UI application
37
38
39 %prep
40 %setup -q
41
42 %build
43 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
44 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
45 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
46
47 export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
48 export CFLAGS+=" -fpie -fvisibility=hidden"
49 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
50
51 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
52 make %{?jobs:-j%jobs}
53
54
55 %install
56 rm -rf %{buildroot}
57 %make_install
58 PKG_ID=org.tizen.bluetooth-share-ui
59 %define tizen_sign 1
60 %define tizen_sign_base /usr/apps/${PKG_ID}
61 %define tizen_sign_level platform
62 %define tizen_author_sign 1
63 %define tizen_dist_sign 1
64
65 %post
66
67 %postun
68
69
70 #%files
71 #%defattr(-,root,root,-)
72
73 %files
74 %manifest bluetooth-share-ui.manifest
75 %license LICENSE
76 %defattr(-,root,root,-)
77 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
78 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
79 %{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
80 %{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
81 %{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
82 %{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
83 %{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
84