Add more app_control data to open image files
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.2.1
7 Release:    1
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 %if "%{?profile}" != "mobile"
13 ExcludeArch: %{arm} %ix86 x86_64
14 %endif
15
16 BuildRequires:  pkgconfig(dbus-glib-1)
17 BuildRequires:  pkgconfig(dlog)
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(appcore-efl)
20 BuildRequires:  pkgconfig(bundle)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(edbus)
23 BuildRequires:  pkgconfig(edje)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(efl-extension)
26 BuildRequires:  pkgconfig(evas)
27 BuildRequires:  pkgconfig(aul)
28 BuildRequires:  pkgconfig(capi-appfw-application)
29 BuildRequires:  pkgconfig(capi-network-bluetooth)
30 BuildRequires:  pkgconfig(bluetooth-share-api)
31 BuildRequires:  pkgconfig(notification)
32
33 BuildRequires:  cmake
34 BuildRequires:  edje-tools
35 BuildRequires:  gettext-devel
36 BuildRequires:  hash-signer
37
38 %define PKG_NAME org.tizen.bluetooth-share-ui
39
40 %description
41 bluetooth share UI application
42
43
44 %prep
45 %setup -q
46
47 %build
48 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
50 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
51
52 export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
53 export CFLAGS+=" -fpie -fvisibility=hidden"
54 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
55
56 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
57 make %{?jobs:-j%jobs}
58
59
60 %install
61 rm -rf %{buildroot}
62 %make_install
63 PKG_ID=org.tizen.bluetooth-share-ui
64 %define tizen_sign 1
65 %define tizen_sign_base /usr/apps/${PKG_ID}
66 %define tizen_sign_level platform
67 %define tizen_author_sign 1
68 %define tizen_dist_sign 1
69
70 install -D -m 0644 LICENSE %{buildroot}%{_datadir}/license/org.tizen.bluetooth-share-ui
71
72 %post
73
74 %postun
75
76
77 #%files
78 #%defattr(-,root,root,-)
79
80 %files
81 %manifest bluetooth-share-ui.manifest
82 %defattr(-,root,root,-)
83 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
84 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
85 %{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
86 %{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
87 %{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
88 %{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
89 %{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
90 %{_datadir}/license/org.tizen.bluetooth-share-ui
91