4ffd2c06c740e30677fdc988dad9071fde9ea4cd
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.2.1
7 Release:    1
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 BuildRequires:  pkgconfig(dbus-glib-1)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(appcore-efl)
16 BuildRequires:  pkgconfig(bundle)
17 BuildRequires:  pkgconfig(ecore)
18 BuildRequires:  pkgconfig(edbus)
19 BuildRequires:  pkgconfig(edje)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(efl-extension)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(aul)
24 BuildRequires:  pkgconfig(capi-appfw-application)
25 BuildRequires:  pkgconfig(capi-network-bluetooth)
26 BuildRequires:  pkgconfig(bluetooth-share-api)
27 BuildRequires:  pkgconfig(notification)
28
29 BuildRequires:  cmake
30 BuildRequires:  edje-tools
31 BuildRequires:  gettext-devel
32 BuildRequires:  hash-signer
33
34 %define PKG_NAME org.tizen.bluetooth-share-ui
35
36 %description
37 bluetooth share UI application
38
39
40 %prep
41 %setup -q
42
43 %build
44 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
45 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
46 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
47
48 export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
49 export CFLAGS+=" -fpie -fvisibility=hidden"
50 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
51
52 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
53 make %{?jobs:-j%jobs}
54
55
56 %install
57 rm -rf %{buildroot}
58 %make_install
59 PKG_ID=org.tizen.bluetooth-share-ui
60 %define tizen_sign 1
61 %define tizen_sign_base /usr/apps/${PKG_ID}
62 %define tizen_sign_level platform
63 %define tizen_author_sign 1
64 %define tizen_dist_sign 1
65
66 %post
67
68 %postun
69
70
71 #%files
72 #%defattr(-,root,root,-)
73
74 %files
75 %manifest bluetooth-share-ui.manifest
76 %license LICENSE
77 %defattr(-,root,root,-)
78 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
79 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
80 %{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
81 %{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
82 %{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
83 %{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
84 %{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
85