tizen 2.4 release
[apps/connectivity/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
1 %define _usrdir /usr
2 %define _appdir %{_usrdir}/apps
3
4 Name:       org.tizen.bluetooth-share-ui
5 Summary:    bluetooth share UI application
6 Version:    0.0.88
7 Release:    1
8 Group:      TO_BE_FILLED
9 License:    Flora-1.1
10 Source0:    %{name}-%{version}.tar.gz
11
12 %if "%{?tizen_profile_name}" != "mobile"
13 ExcludeArch: %{arm} %ix86 x86_64
14 %endif
15
16 Requires(post): sys-assert
17 BuildRequires:  pkgconfig(dbus-glib-1)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(vconf)
20 BuildRequires:  pkgconfig(appcore-efl)
21 BuildRequires:  pkgconfig(bundle)
22 BuildRequires:  pkgconfig(ecore)
23 BuildRequires:  pkgconfig(ecore-x)
24 BuildRequires:  pkgconfig(edbus)
25 BuildRequires:  pkgconfig(edje)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(efl-extension)
28 BuildRequires:  pkgconfig(evas)
29 BuildRequires:  pkgconfig(utilX)
30 BuildRequires:  pkgconfig(bluetooth-api)
31 BuildRequires:  pkgconfig(aul)
32 BuildRequires:  pkgconfig(capi-appfw-application)
33 BuildRequires:  pkgconfig(capi-network-bluetooth)
34 BuildRequires:  pkgconfig(bluetooth-share-api)
35 BuildRequires:  pkgconfig(notification)
36
37 BuildRequires:  cmake
38 BuildRequires:  edje-tools
39 BuildRequires:  gettext-devel
40 BuildRequires:  hash-signer
41
42 %define PKG_NAME org.tizen.bluetooth-share-ui
43
44 %description
45 bluetooth share UI application
46
47
48 %prep
49 %setup -q
50
51 %build
52 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
53 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
54 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
55
56 export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
57 export CFLAGS+=" -fpie -fvisibility=hidden"
58 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
59
60 cmake . -DCMAKE_INSTALL_PREFIX=%{_appdir}/org.tizen.bluetooth-share-ui
61 make %{?jobs:-j%jobs}
62
63
64 %install
65 rm -rf %{buildroot}
66 %make_install
67 PKG_ID=org.tizen.bluetooth-share-ui
68 %define tizen_sign 1
69 %define tizen_sign_base /usr/apps/${PKG_ID}
70 %define tizen_sign_level platform
71 %define tizen_author_sign 1
72 %define tizen_dist_sign 1
73
74 install -D -m 0644 LICENSE %{buildroot}%{_datadir}/license/org.tizen.bluetooth-share-ui
75
76 %post
77
78 %postun
79
80
81 #%files
82 #%defattr(-,root,root,-)
83
84 %files
85 %manifest bluetooth-share-ui.manifest
86 /etc/smack/accesses.d/org.tizen.bluetooth-share-ui.efl
87 %defattr(-,root,root,-)
88 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
89 %{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
90 %{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
91 %{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
92 %{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
93 %{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
94 %{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
95 %{_datadir}/license/org.tizen.bluetooth-share-ui
96